Import mu-cite-201006212322 as wip/mu-cite.
Citing recently read Mail message when writing mail reply. --- MU stands for "Message Utilities". It consists of following modules: mu-cite: a citation utility mu-cite.el --- main module of mu-cite mu-bbdb.el --- mu-cite submodule for BBDB mu-register.el --- mu-cite submodule for registration latex-math-symbol.el --- translate mathematical symbols of LaTeX into MULE characters ---
This commit is contained in:
parent
335908a11e
commit
136ef5de88
6 changed files with 97 additions and 0 deletions
12
mu-cite/DESCR
Normal file
12
mu-cite/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
Citing recently read Mail message when writing mail reply.
|
||||
---
|
||||
MU stands for "Message Utilities". It consists of following
|
||||
modules:
|
||||
mu-cite: a citation utility
|
||||
mu-cite.el --- main module of mu-cite
|
||||
mu-bbdb.el --- mu-cite submodule for BBDB
|
||||
mu-register.el --- mu-cite submodule for registration
|
||||
|
||||
latex-math-symbol.el --- translate mathematical symbols of
|
||||
LaTeX into MULE characters
|
||||
---
|
19
mu-cite/MESSAGE
Normal file
19
mu-cite/MESSAGE
Normal file
|
@ -0,0 +1,19 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2011/04/07 03:01:53 makoto Exp $
|
||||
You may have following lines in your init-file (~/.emacs etc)
|
||||
;; --------
|
||||
; -*- Emacs-Lisp -*-
|
||||
(autoload 'mu-cite-original "mu-cite" nil t)
|
||||
(add-hook 'mail-citation-hook (function mu-cite-original))
|
||||
(setq mu-cite-top-format
|
||||
'(
|
||||
id " in the following mail,\n"
|
||||
"| To: " to "\n"
|
||||
"| From: " from "\n"
|
||||
"| Subject: " subject "\n"
|
||||
"| Date: " date "\n"
|
||||
"| Message-ID: " message-id "\n"
|
||||
"\n"))
|
||||
;; --------
|
||||
For other info, see ${PREFIX}/share/doc/mu-cite/{README.en,NEWS}, thanks.
|
||||
===========================================================================
|
30
mu-cite/Makefile
Normal file
30
mu-cite/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/04/07 03:01:53 makoto Exp $
|
||||
|
||||
DISTNAME= mu-cite-201006212322
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.jpl.org/elips/mu/snapshots/
|
||||
|
||||
MAINTAINER= packages@ki.nu
|
||||
HOMEPAGE= http://emacs-21.ki.nu/application/mu-cite.html
|
||||
COMMENT= Mail (MUA) companion to cite other's mail
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
SUBST_CLASSES+= dest
|
||||
SUBST_STAGE.dest= pre-build
|
||||
SUBST_MESSAGE.dest= replacing for dest-dir
|
||||
SUBST_SED.dest= -e 's|@@PREFIX@@|${DESTDIR}${PREFIX}|'
|
||||
SUBST_FILES.dest+= Makefile
|
||||
|
||||
MAKE_DIRS+= ${PREFIX}/share/doc/mu-cite
|
||||
AUTO_MKDIRS= yes
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && ${MAKE})
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/README.en ${DESTDIR}${PREFIX}/share/doc/mu-cite
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${DESTDIR}${PREFIX}/share/doc/mu-cite
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
11
mu-cite/PLIST
Normal file
11
mu-cite/PLIST
Normal file
|
@ -0,0 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/04/07 03:01:53 makoto Exp $
|
||||
share/doc/mu-cite/README.en
|
||||
share/doc/mu-cite/NEWS
|
||||
share/emacs/site-lisp/mu/latex-math-symbol.el
|
||||
share/emacs/site-lisp/mu/latex-math-symbol.elc
|
||||
share/emacs/site-lisp/mu/mu-bbdb.el
|
||||
share/emacs/site-lisp/mu/mu-bbdb.elc
|
||||
share/emacs/site-lisp/mu/mu-cite.el
|
||||
share/emacs/site-lisp/mu/mu-cite.elc
|
||||
share/emacs/site-lisp/mu/mu-register.el
|
||||
share/emacs/site-lisp/mu/mu-register.elc
|
6
mu-cite/distinfo
Normal file
6
mu-cite/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/04/07 03:01:53 makoto Exp $
|
||||
|
||||
SHA1 (mu-cite-201006212322.tar.gz) = f4a4ad8dd75f9f5f67c9d04c3384a3c97221372d
|
||||
RMD160 (mu-cite-201006212322.tar.gz) = a7121cfdac75d113362df763848a3002cabe5be7
|
||||
Size (mu-cite-201006212322.tar.gz) = 19274 bytes
|
||||
SHA1 (patch-Makefile) = a443e9688bc14a632728276e134553a5bcfd0353
|
19
mu-cite/patches/patch-Makefile
Normal file
19
mu-cite/patches/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-Makefile,v 1.1.1.1 2011/04/07 03:01:53 makoto Exp $
|
||||
fix for PKG_DESTDIR_SUPPORT
|
||||
|
||||
--- Makefile.orig 2000-01-06 04:43:20.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -28,11 +28,11 @@ VERSION = $(API).$(RELEASE)
|
||||
ARC_DIR = /pub/elisp/mu
|
||||
|
||||
elc:
|
||||
- $(EMACS) $(FLAGS) -f compile-mu $(PREFIX) $(LISPDIR) \
|
||||
+ $(EMACS) $(FLAGS) -f compile-mu @@PREFIX@@ $(LISPDIR) \
|
||||
$(VERSION_SPECIFIC_LISPDIR)
|
||||
|
||||
install: elc
|
||||
- $(EMACS) $(FLAGS) -f install-mu $(PREFIX) $(LISPDIR) \
|
||||
+ $(EMACS) $(FLAGS) -f install-mu @@PREFIX@@ $(LISPDIR) \
|
||||
$(VERSION_SPECIFIC_LISPDIR)
|
||||
|
||||
|
Loading…
Reference in a new issue