Remove all patch-aa, add dependency on wip/py-genesis
This commit is contained in:
parent
97e1e50354
commit
13ce6a75a4
3 changed files with 27 additions and 22 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2 2012/08/17 17:27:19 slitvinov Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2012/08/17 18:00:16 slitvinov Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Sumatra-0.3.0.tar
|
||||
|
@ -20,6 +20,7 @@ DEPENDS+= ${PYPKGPREFIX}-django-[0-9]*:../../www/py-django
|
|||
DEPENDS+= ${PYPKGPREFIX}-django-tagging>=0.2.1:../../wip/py-django-tagging
|
||||
DEPENDS+= ${PYPKGPREFIX}-httplib2>=0.6.0:../../wip/py-httplib2
|
||||
DEPENDS+= ${PYPKGPREFIX}-mpi4py>=1.2.1:../../wip/py-mpich4py
|
||||
DEPENDS+= ${PYPKGPREFIX}-genesis:../../wip/py-genesis/
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
|
|
@ -1,6 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2012/08/17 17:27:19 slitvinov Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2012/08/17 18:00:16 slitvinov Exp $
|
||||
bin/smt2.7
|
||||
bin/smtweb2.7
|
||||
${PYSITELIB}/Sumatra-${PKGVERSION}-py2.7.egg-info/PKG-INFO
|
||||
${PYSITELIB}/Sumatra-${PKGVERSION}-py2.7.egg-info/SOURCES.txt
|
||||
${PYSITELIB}/Sumatra-${PKGVERSION}-py2.7.egg-info/dependency_links.txt
|
||||
${PYSITELIB}/Sumatra-${PKGVERSION}-py2.7.egg-info/requires.txt
|
||||
${PYSITELIB}/Sumatra-${PKGVERSION}-py2.7.egg-info/top_level.txt
|
||||
${PYSITELIB}/sumatra/__init__.py
|
||||
${PYSITELIB}/sumatra/__init__.pyc
|
||||
${PYSITELIB}/sumatra/__init__.pyo
|
||||
|
@ -19,6 +24,9 @@ ${PYSITELIB}/sumatra/dependency_finder/__init__.pyo
|
|||
${PYSITELIB}/sumatra/dependency_finder/core.py
|
||||
${PYSITELIB}/sumatra/dependency_finder/core.pyc
|
||||
${PYSITELIB}/sumatra/dependency_finder/core.pyo
|
||||
${PYSITELIB}/sumatra/dependency_finder/genesis.py
|
||||
${PYSITELIB}/sumatra/dependency_finder/genesis.pyc
|
||||
${PYSITELIB}/sumatra/dependency_finder/genesis.pyo
|
||||
${PYSITELIB}/sumatra/dependency_finder/neuron.py
|
||||
${PYSITELIB}/sumatra/dependency_finder/neuron.pyc
|
||||
${PYSITELIB}/sumatra/dependency_finder/neuron.pyo
|
||||
|
@ -61,6 +69,9 @@ ${PYSITELIB}/sumatra/records.pyo
|
|||
${PYSITELIB}/sumatra/recordstore/__init__.py
|
||||
${PYSITELIB}/sumatra/recordstore/__init__.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/__init__.pyo
|
||||
${PYSITELIB}/sumatra/recordstore/base.py
|
||||
${PYSITELIB}/sumatra/recordstore/base.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/base.pyo
|
||||
${PYSITELIB}/sumatra/recordstore/django_store/__init__.py
|
||||
${PYSITELIB}/sumatra/recordstore/django_store/__init__.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/django_store/__init__.pyo
|
||||
|
@ -70,12 +81,18 @@ ${PYSITELIB}/sumatra/recordstore/django_store/models.pyo
|
|||
${PYSITELIB}/sumatra/recordstore/http_store.py
|
||||
${PYSITELIB}/sumatra/recordstore/http_store.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/http_store.pyo
|
||||
${PYSITELIB}/sumatra/recordstore/serialization.py
|
||||
${PYSITELIB}/sumatra/recordstore/serialization.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/serialization.pyo
|
||||
${PYSITELIB}/sumatra/recordstore/shelve_store.py
|
||||
${PYSITELIB}/sumatra/recordstore/shelve_store.pyc
|
||||
${PYSITELIB}/sumatra/recordstore/shelve_store.pyo
|
||||
${PYSITELIB}/sumatra/versioncontrol/__init__.py
|
||||
${PYSITELIB}/sumatra/versioncontrol/__init__.pyc
|
||||
${PYSITELIB}/sumatra/versioncontrol/__init__.pyo
|
||||
${PYSITELIB}/sumatra/versioncontrol/_bazaar.py
|
||||
${PYSITELIB}/sumatra/versioncontrol/_bazaar.pyc
|
||||
${PYSITELIB}/sumatra/versioncontrol/_bazaar.pyo
|
||||
${PYSITELIB}/sumatra/versioncontrol/_git.py
|
||||
${PYSITELIB}/sumatra/versioncontrol/_git.pyc
|
||||
${PYSITELIB}/sumatra/versioncontrol/_git.pyo
|
||||
|
@ -91,9 +108,12 @@ ${PYSITELIB}/sumatra/versioncontrol/base.pyo
|
|||
${PYSITELIB}/sumatra/web/__init__.py
|
||||
${PYSITELIB}/sumatra/web/__init__.pyc
|
||||
${PYSITELIB}/sumatra/web/__init__.pyo
|
||||
${PYSITELIB}/sumatra/web/media/Go-next.png
|
||||
${PYSITELIB}/sumatra/web/media/Go-previous.png
|
||||
${PYSITELIB}/sumatra/web/media/smt.css
|
||||
${PYSITELIB}/sumatra/web/templates/base.html
|
||||
${PYSITELIB}/sumatra/web/templates/project_detail.html
|
||||
${PYSITELIB}/sumatra/web/templates/project_list.html
|
||||
${PYSITELIB}/sumatra/web/templates/record_detail.html
|
||||
${PYSITELIB}/sumatra/web/templates/record_list.html
|
||||
${PYSITELIB}/sumatra/web/templates/show_csv.html
|
||||
|
@ -114,12 +134,16 @@ ${PYSITELIB}/sumatra/web/views.py
|
|||
${PYSITELIB}/sumatra/web/views.pyc
|
||||
${PYSITELIB}/sumatra/web/views.pyo
|
||||
share/doc/py-sumatra/command_reference.txt
|
||||
share/doc/py-sumatra/developers_guide.txt
|
||||
share/doc/py-sumatra/faq.txt
|
||||
share/doc/py-sumatra/getting_started.txt
|
||||
share/doc/py-sumatra/gui.txt
|
||||
share/doc/py-sumatra/index.txt
|
||||
share/doc/py-sumatra/installation.txt
|
||||
share/doc/py-sumatra/introduction.txt
|
||||
share/doc/py-sumatra/migration.txt
|
||||
share/doc/py-sumatra/parallel_computations.txt
|
||||
share/doc/py-sumatra/parameter_files.txt
|
||||
share/doc/py-sumatra/upgrading.txt
|
||||
share/doc/py-sumatra/using_the_api.txt
|
||||
share/doc/py-sumatra/web_interface.txt
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/08/09 21:36:25 jihbed Exp $
|
||||
|
||||
--- setup.py.orig 2010-07-09 16:31:24.000000000 +0000
|
||||
+++ setup.py 2010-08-06 11:15:25.000000000 +0000
|
||||
@@ -1,5 +1,6 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
+import sys
|
||||
from distutils.core import setup
|
||||
from src.__init__ import __version__
|
||||
|
||||
@@ -15,7 +16,7 @@
|
||||
'sumatra.web', 'sumatra.web.templatetags'],
|
||||
package_data = {'sumatra': ['web/media/smt.css',
|
||||
'web/templates/*.html']},
|
||||
- scripts= ['src/smt', 'src/smtweb'],
|
||||
+ scripts= ['src/smt'+sys.version[:3], 'src/smtweb'+sys.version[:3]],
|
||||
author = "Andrew P. Davison",
|
||||
author_email = "andrewpdavison@gmail.com",
|
||||
description = "A tool for automated tracking of computation-based scientific projects",
|
Loading…
Reference in a new issue