Initial import of arping, version 1.08, into pkgsrc-wip.
Arping can be used to find out it a specific IP address on the LAN is 'taken' and what MAC address owns it. Sure, you *could* just use 'ping' to find out if it's taken and even if the computer blocks ping (and everything else) you still get an entry in your ARP cache. But what if you aren't on a routable net? Or the host blocks ping (all ICMP even)? Then you're screwed. Or you use arping.
This commit is contained in:
parent
71f6c82a7a
commit
1467819572
6 changed files with 123 additions and 0 deletions
5
arping/DESCR
Normal file
5
arping/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
Arping can be used to find out it a specific IP address on the LAN is 'taken'
|
||||
and what MAC address owns it. Sure, you *could* just use 'ping' to find out if
|
||||
it's taken and even if the computer blocks ping (and everything else) you still
|
||||
get an entry in your ARP cache. But what if you aren't on a routable net? Or
|
||||
the host blocks ping (all ICMP even)? Then you're screwed. Or you use arping.
|
35
arping/Makefile
Normal file
35
arping/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/10/14 07:56:02 cubidou Exp $
|
||||
#
|
||||
|
||||
PKGNAME= arping-1.08
|
||||
DISTNAME= arping-2.01
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
|
||||
|
||||
MAINTAINER= cube@NetBSD.org
|
||||
HOMEPAGE= ftp://ftp.habets.pp.se/pub/synscan/
|
||||
COMMENT= ARP-level ping utility
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
NO_CONFIGURE= yes
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD"
|
||||
ALL_TARGET= openbsd
|
||||
.elif ${OPSYS} == "Linux"
|
||||
ALL_TARGET= linux
|
||||
.elif ${OPSYS} == "FreeBSD"
|
||||
ALL_TARGET= freebsd
|
||||
.elif ${OPSYS} == "SunOS"
|
||||
ALL_TARGET= solaris
|
||||
.elif ${OPSYS} == "Darwin"
|
||||
ALL_TARGET= macosx
|
||||
.endif
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-* OpenBSD-* FreeBSD-* \
|
||||
Linux-* SunOS-* Darwin-*
|
||||
|
||||
.include "../../net/libpcap/buildlink2.mk"
|
||||
.include "../../devel/libnet/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
arping/PLIST
Normal file
3
arping/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/10/14 07:56:02 cubidou Exp $
|
||||
bin/arping
|
||||
man/man8/arping.8
|
6
arping/distinfo
Normal file
6
arping/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/10/14 07:56:02 cubidou Exp $
|
||||
|
||||
SHA1 (arping-2.01.tar.gz) = 00a84f390c9f9b5c9ac2ce457f0bd405bab2a63b
|
||||
Size (arping-2.01.tar.gz) = 31366 bytes
|
||||
SHA1 (patch-aa) = 3c6b4d78ddec573527c9f59173b17427ffc678d1
|
||||
SHA1 (patch-ab) = 17ef8cc62a202589bb9efb276d1bd99772648a22
|
61
arping/patches/patch-aa
Normal file
61
arping/patches/patch-aa
Normal file
|
@ -0,0 +1,61 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/10/14 07:56:02 cubidou Exp $
|
||||
|
||||
--- Makefile.orig 2003-08-04 01:20:07.000000000 +0200
|
||||
+++ Makefile
|
||||
@@ -9,9 +9,9 @@ SOLARIS=0
|
||||
FREEBSD=0
|
||||
MACOSX=0
|
||||
|
||||
-CC=gcc
|
||||
+#CC=gcc
|
||||
# explicit pcap include dir is for redhat which is fux0red
|
||||
-CFLAGS=-g -I/usr/local/include -L/usr/local/lib -DFINDIF=$(FINDIF) -DUSE_NETIF=$(USE_NETIF) -DOPENBSD=$(OPENBSD) -DLINUX=$(LINUX) -DSOLARIS=$(SOLARIS) -DFREEBSD=$(FREEBSD) -DMACOSX=$(MACOSX) -I/usr/include/pcap
|
||||
+CFLAGS=-I$(BUILDLINK_DIR)/include -L$(BUILDLINK_DIR)/lib -DFINDIF=$(FINDIF) -DUSE_NETIF=$(USE_NETIF) -DOPENBSD=$(OPENBSD) -DLINUX=$(LINUX) -DSOLARIS=$(SOLARIS) -DFREEBSD=$(FREEBSD) -DMACOSX=$(MACOSX)
|
||||
|
||||
all: message arping2
|
||||
|
||||
@@ -54,34 +54,34 @@ doc: arping.yodl
|
||||
yodl2man -o arping.8 arping.yodl
|
||||
|
||||
linux-nofindif:
|
||||
- make USE_NETIF=1 LINUX=1 FINDIF=0 arping1-make
|
||||
+ $(MAKE) USE_NETIF=1 LINUX=1 FINDIF=0 arping1-make
|
||||
linux:
|
||||
- make USE_NETIF=1 LINUX=1 arping1-make
|
||||
+ $(MAKE) USE_NETIF=1 LINUX=1 arping1-make
|
||||
|
||||
freebsd:
|
||||
- make USE_NETIF=1 FREEBSD=1 arping1-make
|
||||
+ $(MAKE) USE_NETIF=1 FREEBSD=1 arping1-make
|
||||
|
||||
macosx:
|
||||
- make USE_NETIF=1 MACOSX=1 arping1-make
|
||||
+ $(MAKE) USE_NETIF=1 MACOSX=1 arping1-make
|
||||
|
||||
openbsd:
|
||||
- make OPENBSD=1 arping1-make
|
||||
+ $(MAKE) OPENBSD=1 arping1-make
|
||||
netbsd:
|
||||
- make openbsd
|
||||
+ $(MAKE) openbsd
|
||||
|
||||
solaris:
|
||||
- make USE_NETIF=0 SOLARIS=1 arping1-make
|
||||
+ $(MAKE) USE_NETIF=0 SOLARIS=1 arping1-make
|
||||
|
||||
install:
|
||||
- install -c arping /usr/local/bin/arping
|
||||
- install arping.8 /usr/local/man/man8/arping.8
|
||||
+ $(BSD_INSTALL) -c arping $(PREFIX)/bin/arping
|
||||
+ $(BSD_INSTALL) -c arping.8 $(PREFIX)/man/man8/arping.8
|
||||
|
||||
arping.o: arping.c
|
||||
$(CC) -Wall $(CFLAGS) -c `libnet-config --defines` `libnet-config --cflags` arping.c
|
||||
|
||||
O_arping=arping.o
|
||||
arping1-make: $(O_arping)
|
||||
- $(CC) $(CFLAGS) -g -o arping $(O_arping) `libnet-config --libs` -lpcap
|
||||
+ $(CC) $(CFLAGS) -o arping $(O_arping) `libnet-config --libs` -lpcap
|
||||
|
||||
O_arping2=arping-2/arping.c
|
||||
arping2: arping-2/arping
|
13
arping/patches/patch-ab
Normal file
13
arping/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/10/14 07:56:02 cubidou Exp $
|
||||
|
||||
--- openbsd.h.orig 2000-09-15 19:22:30.000000000 +0200
|
||||
+++ openbsd.h
|
||||
@@ -22,7 +22,7 @@ struct icmphdr {
|
||||
} echo;
|
||||
__u32 gateway;
|
||||
struct {
|
||||
- __u16 __unused;
|
||||
+ __u16 arping__unused;
|
||||
__u16 mtu;
|
||||
} frag;
|
||||
} un;
|
Loading…
Reference in a new issue