Import amarok SVN snapshort post-1.86 as wip/amarok.

AmaroK is a media player for KDE.  There are many media players
around these days, true. What's missing from most players is a user
interface, that doesn't get in the way of the user. How many buttons
do you have to press for simply adding some new tracks to the
playlist? amaroK tries to be a little different, providing a simple
drag and drop interface, that really makes playlist handling easy.

This package contains the KDE4 version of amarok.

TODO:
PLIST needs more fixes, tries to remove too many files.
This commit is contained in:
Thomas Klausner 2008-08-12 12:07:39 +00:00
parent d03f1593e3
commit 14ef833cf2
4 changed files with 100 additions and 0 deletions

53
amarok/options.mk Normal file
View file

@ -0,0 +1,53 @@
# $NetBSD: options.mk,v 1.1.1.1 2008/08/12 12:07:39 thomasklausner Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.amarok
PKG_SUPPORTED_OPTIONS= libgpod libmp4v2 libmtp libnjb libvisual mp3tunes mysql plasma
PKG_SUGGESTED_OPTIONS= libgpod libmp4v2 libmtp libvisual mp3tunes plasma
# XXX: mysql doesn't work yet, probably needs more cmake magic
# XXX: libnjb is currently not supported
# XXX: not packaged yet
# libifp, 1.0.0.2: Support iRiver iFP audio devices <http://ifp-driver.sourceforge.net/libifp/>
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mlibgpod)
BUILDLINK_API_DEPENDS.libgpod+= libgpod>=0.6.0nb1
.include "../../audio/libgpod/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mlibmp4v2)
.include "../../multimedia/libmp4v2/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mlibmtp)
.include "../../wip/libmtp/buildlink3.mk"
.endif
#.if !empty(PKG_OPTIONS:Mlibnjb)
#.include "../../wip/libnjb/buildlink3.mk"
#.endif
.if !empty(PKG_OPTIONS:Mlibvisual)
.include "../../audio/libvisual/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mmp3tunes)
.include "../../chat/loudmouth/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
# XXX: make sure qt4-libs have glib enabled
.endif
.if !empty(PKG_OPTIONS:Mmysql)
MYSQL_VERSIONS_ACCEPTED= 41
.include "../../mk/mysql.buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mplasma)
.include "../../wip/kdebase-workspace4/buildlink3.mk"
.endif

15
amarok/patches/patch-ac Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1.1.1 2008/08/12 12:07:39 thomasklausner Exp $
Adapt for newer pkg-config support in cmake.
--- src/browsers/servicebrowser/mp3tunes/CMakeLists.txt.orig 2008-08-07 19:37:14.000000000 +0000
+++ src/browsers/servicebrowser/mp3tunes/CMakeLists.txt
@@ -24,7 +24,7 @@ if(OPENSSL_FOUND AND LIBXML2_FOUND AND C
./harmonydaemon
${GLIB2_INCLUDE_DIR}
${GOBJECT_INCLUDE_DIR}
- ${LOUDMOUTH_INCLUDE_DIR}
+ ${LOUDMOUTH_INCLUDE_DIRS}
)
set(amarok_service_mp3tunes_harmony_PART_SRCS

17
amarok/patches/patch-ad Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-ad,v 1.1.1.1 2008/08/12 12:07:39 thomasklausner Exp $
NetBSD-current doesn't have statfs.
--- src/browsers/servicebrowser/mp3tunes/harmonydaemon/Mp3tunesHarmonyDaemon.cpp.orig 2008-08-07 19:37:13.000000000 +0000
+++ src/browsers/servicebrowser/mp3tunes/harmonydaemon/Mp3tunesHarmonyDaemon.cpp
@@ -20,6 +20,10 @@
#include "Mp3tunesHarmonyDaemon.h"
#include "mp3tunesharmonydaemonadaptor.h"
+#ifndef statfs
+#define statfs statvfs
+#endif
+
#include <kcmdlineargs.h>
#include <QtDebug>

15
amarok/patches/patch-ae Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-ae,v 1.1.1.1 2008/08/12 12:07:39 thomasklausner Exp $
sys/vfs.h doesn't exist on NetBSD.
--- src/browsers/servicebrowser/mp3tunes/harmonydaemon/Mp3tunesHarmonyDaemon.h.orig 2008-08-07 19:37:13.000000000 +0000
+++ src/browsers/servicebrowser/mp3tunes/harmonydaemon/Mp3tunesHarmonyDaemon.h
@@ -31,7 +31,7 @@ extern "C" {
#include "../libmp3tunes/harmony.h"
#include "../libmp3tunes/locker.h"
#include <glib.h>
- #include <sys/vfs.h>
+ #include <sys/statvfs.h>
#include <errno.h>
#include <stdio.h>
#include <string.h>