added an include for stdlib.h from xpdf.../gfile.h and xpdf.../gfile.cc

exception is in newer boost library, but the code used the one from namespace std: added explicit std::
This commit is contained in:
Marko Schütz Schmuck 2009-03-06 04:55:31 +00:00 committed by Thomas Klausner
parent ed654dd390
commit 167a5aabcc
4 changed files with 59 additions and 1 deletions

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.3 2007/04/30 09:18:15 lkundrak Exp $
$NetBSD: distinfo,v 1.4 2009/03/06 04:55:31 marko_schuetz Exp $
SHA1 (pdfedit-0.3.1.tar.bz2) = 3629977b2b7d28d12ae397afbcd6aef677aec0e7
RMD160 (pdfedit-0.3.1.tar.bz2) = c278f71b4656f92d3d4b347dc28ba11327432c61
Size (pdfedit-0.3.1.tar.bz2) = 2645632 bytes
SHA1 (patch-aa) = bf6274a8648d52429b9d2a05d0fca069c262510f
SHA1 (patch-ab) = d38649c093d31fe302f69f8b9c39bcc683329ffc
SHA1 (patch-ac) = 5f1492615e699be30636711847f057c5a13bed0a

12
pdfedit/patches/patch-aa Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1 2009/03/06 04:55:31 marko_schuetz Exp $
--- src/xpdf/goo/gfile.h.orig 2008-01-16 09:50:32.000000000 -0400
+++ src/xpdf/goo/gfile.h
@@ -25,6 +25,7 @@
#elif defined(MACOS)
# include <ctime.h>
#else
+# include <stdlib.h>
# include <unistd.h>
# include <sys/types.h>
# ifdef VMS

12
pdfedit/patches/patch-ab Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2009/03/06 04:55:31 marko_schuetz Exp $
--- src/xpdf/goo/gfile.cc.orig 2008-09-09 10:21:12.000000000 -0400
+++ src/xpdf/goo/gfile.cc
@@ -20,6 +20,7 @@
# include <sys/stat.h>
# include <fcntl.h>
# endif
+# include <stdlib.h>
# include <limits.h>
# include <string.h>
# if !defined(VMS) && !defined(ACORN) && !defined(MACOS)

31
pdfedit/patches/patch-ac Normal file
View file

@ -0,0 +1,31 @@
$NetBSD: patch-ac,v 1.1 2009/03/06 04:55:31 marko_schuetz Exp $
--- src/kernel/cpdf.cc.orig 2007-02-04 16:17:02.000000000 -0400
+++ src/kernel/cpdf.cc
@@ -2546,7 +2546,7 @@ using namespace std;
CPdf * instance=new CPdf(stream, mode);
kernelPrintDbg(debug::DBG_INFO, "Instance created successfully openMode=" << openMode);
return instance;
- }catch(exception &e)
+ }catch(std::exception &e)
{
kernelPrintDbg(DBG_CRIT, "Pdf instance creation failed. cause="<<e.what());
string what=string("CPdf open failed. reason=")+e.what();
@@ -2821,7 +2821,7 @@ using namespace utils;
try
{
minPos = getNodePosition(*this, newValue, &nodeCountCache);
- }catch(exception &e)
+ }catch(std::exception &e)
{
// position can't be determined
// no special handling is needed, minPos keeps its value
@@ -2879,7 +2879,7 @@ using namespace utils;
kernelPrintDbg(DBG_WARN, "page with original position="<<i->first<<" is ambiguous. Invalidating.");
// page position is ambiguous and so it has to be invalidate
i->second->invalidate();
- }catch(exception & e)
+ }catch(std::exception & e)
{
kernelPrintDbg(DBG_CRIT, "Unexpected error. cause="<<e.what());
assert(!"Possibly bug.");