Import chemeq-2.12 as wip/chemeq.

chemeq is a chemical equation analyzer. It is a fast lexical and
syntaxic analyser which helps to find out chemical informations
embedded in source chemical equations. Data can be output in various
sophisticated formats, depending on options. 'chemeq' defaults to
'chemeq -mlcwCn'
This commit is contained in:
Kamel Ibn Aziz Derouiche 2014-07-15 13:38:02 +00:00 committed by Thomas Klausner
parent ac3b64ece3
commit 17335a6d63
6 changed files with 86 additions and 0 deletions

5
chemeq/DESCR Normal file
View file

@ -0,0 +1,5 @@
chemeq is a chemical equation analyzer. It is a fast lexical and
syntaxic analyser which helps to find out chemical informations
embedded in source chemical equations. Data can be output in various
sophisticated formats, depending on options. 'chemeq' defaults to
'chemeq -mlcwCn'

21
chemeq/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1 2014/07/15 13:38:02 jihbed Exp $
DISTNAME= chemeq_2.12.orig
PKGNAME= chemeq-2.12
CATEGORIES= biology
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/c/chemeq/}
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= http://savannah.nongnu.org/projects/chemeq/
COMMENT= Chemical Equation Parser and Renderer
LICENSE= gnu-gpl-v3
WRKSRC= ${WRKDIR}/chemeq-2.12.orig
USE_TOOLS+= bison gmake perl
USE_LANGUAGES= c c++
REPLACE_PERL+= tests/chemreport.pl
.include "../../textproc/libxslt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

8
chemeq/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2014/07/15 13:38:02 jihbed Exp $
bin/chemeq
man/man1/chemeq.1
share/doc/chemeq/tests/chemreport
share/doc/chemeq/tests/chemreport.pl
share/doc/chemeq/tests/chemtest
share/doc/chemeq/tests/chemtest.pl
share/doc/chemeq/tests/test.stuff

7
chemeq/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2014/07/15 13:38:02 jihbed Exp $
SHA1 (chemeq_2.12.orig.tar.gz) = c937844efc24f8b94133180f1b9f904647ca1520
RMD160 (chemeq_2.12.orig.tar.gz) = 83478506478176af349c54d2037dd6d3c00affbf
Size (chemeq_2.12.orig.tar.gz) = 484198 bytes
SHA1 (patch-aa) = d503a443bcaa6352105c180698ce7f593a086dd9
SHA1 (patch-ab) = a5c7c31d932b650cdcb3c0e1b91d6777c985c144

34
chemeq/patches/patch-aa Normal file
View file

@ -0,0 +1,34 @@
$NetBSD: patch-aa,v 1.1 2014/07/15 13:38:02 jihbed Exp $
--- Makefile.orig 2013-06-19 08:46:05.000000000 +0100
+++ Makefile 2014-07-15 14:25:47.000000000 +0100
@@ -1,15 +1,15 @@
INSTALL=install
DESTDIR =
-BIN = $(DESTDIR)/usr/bin
-MAN1 = $(DESTDIR)/usr/share/man/man1
-DOC = $(DESTDIR)/usr/share/doc/chemeq
+BIN = $(DESTDIR)$(PREFIX)/bin
+MAN1 = $(DESTDIR)$(PREFIX)/man/man1
+DOC = $(DESTDIR)$(PREFIX)/share/doc/chemeq
TESTS = $(DOC)/tests
TESTSUITE = tests/chemreport tests/chemreport.pl \
tests/chemtest tests/chemtest.pl
TESTSTUFF = tests/test.stuff
all :
- (cd src; ${MAKE})
+ (cd src; ${MAKE} clean; ${MAKE})
demo : all
(cd tests; chemreport)
@@ -20,8 +20,7 @@
install : all
${INSTALL} -d $(BIN) $(MAN1) $(TESTS)
${INSTALL} src/chemeq $(BIN)
- gzip -c -9 chemeq.1 > chemeq.1.gz
- ${INSTALL} -m644 chemeq.1.gz $(MAN1)
+ ${INSTALL} -m644 chemeq.1 $(MAN1)
${INSTALL} -m755 $(TESTSUITE) $(TESTS)
${INSTALL} -m644 $(TESTSTUFF) $(TESTS)

11
chemeq/patches/patch-ab Normal file
View file

@ -0,0 +1,11 @@
$NetBSD: patch-ab,v 1.1 2014/07/15 13:38:02 jihbed Exp $
--- src/Makefile.orig 2014-07-14 23:02:42.000000000 +0100
+++ src/Makefile 2014-07-14 23:03:00.000000000 +0100
@@ -1,6 +1,4 @@
# -*- coding: utf-8 -*-
-CXX = g++
-CXXFLAGS= -g -O1
chemeq : chemeq.o chemparser.o mendeleiev.o
${CXX} $(CXXFLAGS) -o chemeq chemeq.o chemparser.o mendeleiev.o -lfl