Initial import of py-spreadmodule 1.3
This is a Python extension module for Spread, an open source group communications package.
This commit is contained in:
parent
5876a95957
commit
17723d556e
6 changed files with 55 additions and 0 deletions
2
py-spreadmodule/DESCR
Normal file
2
py-spreadmodule/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
This is a Python extension module for Spread, an open source group
|
||||
communications package.
|
27
py-spreadmodule/Makefile
Normal file
27
py-spreadmodule/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/04/07 06:13:42 marc Exp $
|
||||
#
|
||||
|
||||
DISTNAME= SpreadModule-1.3
|
||||
PKGNAME= ${PYPKGPREFIX}-spreadmodule-1.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.python.org/other/spread/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= marc@informatik.uni-bremen.de
|
||||
HOMEPAGE= http://www.python.org/other/spread/
|
||||
COMMENT= Python bindings for the Spread messaging service
|
||||
|
||||
WRKSRC= ${WRKDIR}/SpreadModule-1.3
|
||||
PYDISTUTILSPKG= YES
|
||||
USE_BUILDLINK2= YES
|
||||
#LDFLAGS+= -lpthread
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
post-patch:
|
||||
${MV} ${WRKSRC}/setup.py ${WRKSRC}/setup.py.pre
|
||||
${SED} -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/setup.py.pre > ${WRKSRC}/setup.py
|
||||
|
||||
.include "../../net/spread/buildlink2.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
py-spreadmodule/PLIST
Normal file
2
py-spreadmodule/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/04/07 06:13:42 marc Exp $
|
||||
${PYSITELIB}/spread.so
|
3
py-spreadmodule/TODO
Normal file
3
py-spreadmodule/TODO
Normal file
|
@ -0,0 +1,3 @@
|
|||
Fix threading issues.
|
||||
SpreadModule needs a Python that has been built with support for
|
||||
threading.
|
5
py-spreadmodule/distinfo
Normal file
5
py-spreadmodule/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/04/07 06:13:42 marc Exp $
|
||||
|
||||
SHA1 (SpreadModule-1.3.tgz) = fc7f72735300828ca9710e26b6cf0e4a297df683
|
||||
Size (SpreadModule-1.3.tgz) = 15804 bytes
|
||||
SHA1 (patch-aa) = d847156d4f7e308c75499e4970e6067feb2fda2d
|
16
py-spreadmodule/patches/patch-aa
Normal file
16
py-spreadmodule/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/04/07 06:13:42 marc Exp $
|
||||
|
||||
--- setup.py.orig 2002-04-25 21:22:07.000000000 +0200
|
||||
+++ setup.py 2003-03-14 20:27:16.000000000 +0100
|
||||
@@ -19,9 +19,9 @@
|
||||
else:
|
||||
SPREAD_DIR = "/usr/local"
|
||||
ext = Extension('spread', ['spreadmodule.c'],
|
||||
- include_dirs = [SPREAD_DIR + "/include"],
|
||||
+ include_dirs = [SPREAD_DIR + "/include/spread"],
|
||||
library_dirs = [SPREAD_DIR + "/lib"],
|
||||
- libraries = ['tsp'],
|
||||
+ extra_objects = [SPREAD_DIR + '/lib/libtspread.a'],
|
||||
)
|
||||
|
||||
setup(name = "Spread API for Python",
|
Loading…
Reference in a new issue