Modplug Plugin for XMMS v2.0 / libmodplug v0.7

Based on the ModPlug sound engine by Olivier Lapicque <olivierl@jps.net>
 XMMS plugin by Kenton Varda <temporal@gauge3d.org>
 Placed in the public domain in October, 2001

Olivier Lapicque, author of Modplug, which is arguably the best quality
MOD-playing software available, has placed his sound rendering code in the
public domain.  This library and plugin is based on that code.
This commit is contained in:
Ben Collver 2003-07-12 02:41:12 +00:00
parent 347a7ccd0a
commit 183914e2c6
7 changed files with 103 additions and 0 deletions

8
xmms-modplug/DESCR Normal file
View file

@ -0,0 +1,8 @@
Modplug Plugin for XMMS v2.0 / libmodplug v0.7
Based on the ModPlug sound engine by Olivier Lapicque <olivierl@jps.net>
XMMS plugin by Kenton Varda <temporal@gauge3d.org>
Placed in the public domain in October, 2001
Olivier Lapicque, author of Modplug, which is arguably the best quality
MOD-playing software available, has placed his sound rendering code in the
public domain. This library and plugin is based on that code.

25
xmms-modplug/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
#
DISTNAME= modplugxmms-2.04
PKGNAME= xmms-modplug-2.04
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=modplug-xmms/}
MAINTAINER= collver1@comcast.net
HOMEPAGE= http://modplug-xmms.sourceforge.net
COMMENT= XMMS plugin based on modplug
DEPENDS+= unzip-[0-9]*:../../archivers/unzip
LDFLAGS+= -lm -lossaudio
USE_X11= yes
USE_BUILDLINK2= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
.include "../../audio/xmms/buildlink2.mk"
.include "../../mk/ossaudio.buildlink2.mk"
.include "../../mk/pthread.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

10
xmms-modplug/PLIST Normal file
View file

@ -0,0 +1,10 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
bin/modplugplay
include/modplug.h
lib/libmodplug.la
lib/libmodplug.so
lib/libmodplug.so.0
lib/libmodplug.so.0.0
lib/xmms/Input/libmodplugxmms.a
lib/xmms/Input/libmodplugxmms.la
lib/xmms/Input/libmodplugxmms.so

7
xmms-modplug/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
SHA1 (modplugxmms-2.04.tar.gz) = 9b56ebb690d7c6b556e9e079046726f31d5ae28c
Size (modplugxmms-2.04.tar.gz) = 479747 bytes
SHA1 (patch-aa) = 16e3ac2fb40b86c3b2bd542af1ab3aec4a01f9c8
SHA1 (patch-ab) = 011e13ee18b33b99ab4c6bf59a64b72d7e677b64
SHA1 (patch-ac) = 725af106ea6562ca5ce08b3addcd6f4b69a2a545

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
--- modplugxmms/modplugxmms.h.orig Sun Apr 27 04:30:48 2003
+++ modplugxmms/modplugxmms.h
@@ -7,6 +7,7 @@
#ifndef __MODPLUGXMMS_CMODPLUGXMMS_H_INCLUDED__
#define __MODPLUGXMMS_CMODPLUGXMMS_H_INCLUDED__
+#include <pthread.h>
#include <string>
#ifndef __MODPLUGXMMS_STDDEFS_H__INCLUDED__

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
--- modplugplay/Makefile.in.orig Fri Jul 11 02:21:15 2003
+++ modplugplay/Makefile.in
@@ -130,7 +130,7 @@ modplugplay_DEPENDENCIES =
modplugplay_LDFLAGS =
DEFS = @DEFS@
-DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) -I../libmodplug
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/07/12 02:41:12 bencollver Exp $
--- modplugplay/modplugplay.c.orig Tue Apr 29 02:52:59 2003
+++ modplugplay/modplugplay.c
@@ -33,7 +33,11 @@
#include <modplug.h>
#include <sys/ioctl.h>
#include <fcntl.h>
+#ifdef __NetBSD__
+#include <soundcard.h>
+#else
#include <sys/soundcard.h>
+#endif
#include <sys/time.h>
#include <sys/poll.h>
#include <getopt.h>
@@ -42,7 +46,11 @@
#define VERSION 0.0.1
#define BUF_SIZE 4096
+#ifdef __NetBSD__
+#define DEVICE_NAME "/dev/sound"
+#else
#define DEVICE_NAME "/dev/dsp"
+#endif
/* state variable */
int audio_fd;