Update to OpenSMTPD 5.3.2p1

release-5.3.2.txt:
This is a bugfix and reliability release mostly, with few new features.
Features:
=========
  * add support for transparent queue compression
  * fsqueue now keeps a safety disk space / inode 5% reserve
  * add SECURE and AUTH transmission type as specified in rfc3848
  * add db(3) support for "helo" lookups
  * make "source" no longer required for "helo" lookups
  * add check to ensure smtpd and smtpctl are "compatible"
  * add new "error" alias kind to have an alias return 4xx or 5xx
  * source and session are now logged when relaying
  * make OpenSMTPD cope gracefully with many former "fatal" cases
  * detect and cope with "corrupted" envelopes at runtime
  * smtpd -d no longer implies "debug" logging
  * smtpd -v no longer requires -d to output debug logging
  * traces no longer require -dv and can be (de)activated at runtime
  * add support for Unix sockets in local LMTP deliveries
    contributed by Gleb Kozyrev <gleb@gkoz.com>
BugFixes:
=========
  * fix logic error in our SSL layer causing possible DoS [1]
  * fix delivery_lmtp issues when dealing with multi-response LHLO
  * do not replace '/' with ':' in user.directory token
  * do not reject [IPv6:...] notation in clients HELO commands
  * do not close session on *recipient* temporary failures
  * fix possible spin when admin messes with queue perms at runtime
  * fix a bug where offline mails are not enqueued unless sent by root
  * support + as user-part "directory" separator in virtual domains
  * fix "reject" rules when used with senders
  * fix mbox deliveries when dealing with bounces
  * fix smtp-level sender rewriting when dealing with bounces
  * lowercase keys before performing table lookups
  * fix MTA to cope with reaching a limit on a MX
  * assorted minor bug fixes, memleak plugs and improvements
  * existing but empty ~/.forward should skip expansion
    contributed by "Naabed"
[1] bug exists in both native and portable version but DoS doesn't
    seem to trigger on OpenBSD. you should update still.
This commit is contained in:
Ryosuke Moro 2013-05-26 20:34:34 +00:00 committed by Thomas Klausner
parent 4217fce339
commit 195d17c05f
4 changed files with 37 additions and 6 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2013/05/09 07:40:09 szptvlfn Exp $
# $NetBSD: Makefile,v 1.8 2013/05/26 20:34:34 szptvlfn Exp $
VERSION= 5.3.1p1
VERSION= 5.3.2p1
DISTNAME= opensmtpd-${VERSION}
CATEGORIES= mail net
MASTER_SITES= http://www.opensmtpd.org/archives/

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.7 2013/05/09 07:40:09 szptvlfn Exp $
$NetBSD: distinfo,v 1.8 2013/05/26 20:34:34 szptvlfn Exp $
SHA1 (opensmtpd-5.3.1p1.tar.gz) = 333aa7795aabbb9c265818f0e7b71f135cb39474
RMD160 (opensmtpd-5.3.1p1.tar.gz) = 8384e3faebdcb0cf7d6a8664fe1a83fca57ab3c6
Size (opensmtpd-5.3.1p1.tar.gz) = 338091 bytes
SHA1 (opensmtpd-5.3.2p1.tar.gz) = 2a691fec7555deec07940a088884ea7d300ea1ed
RMD160 (opensmtpd-5.3.2p1.tar.gz) = f58aa2b7f52ba963dd6d889e298d26c8bc248a1e
Size (opensmtpd-5.3.2p1.tar.gz) = 345468 bytes
SHA1 (patch-configure.ac) = 14c126f580a806bcd221a343a286a0d57673b62a
SHA1 (patch-smtpd_Makefile.am) = 4267002ecadceaf68868b9d782d5e6f8571ebc36
SHA1 (patch-smtpd_queue_fsqueue.c) = ac421852649496329cdb3196c966fcc4ba01a927

View file

@ -0,0 +1,12 @@
$NetBSD: patch-configure.ac,v 1.1 2013/05/26 20:34:34 szptvlfn Exp $
--- configure.ac.orig 2013-05-16 15:19:59.000000000 +0000
+++ configure.ac
@@ -261,6 +261,7 @@ AC_CHECK_HEADERS([ \
sys/ndir.h \
sys/pstat.h \
sys/statfs.h \
+ sys/statvfs.h \
sys/un.h \
ucred.h \
util.h \

View file

@ -0,0 +1,17 @@
$NetBSD: patch-smtpd_queue_fsqueue.c,v 1.1 2013/05/26 20:34:34 szptvlfn Exp $
NetBSD use statvfs, not statfs.
--- smtpd/queue_fsqueue.c.orig 2013-05-16 15:19:59.000000000 +0000
+++ smtpd/queue_fsqueue.c
@@ -28,6 +28,10 @@
#endif
#include <sys/param.h>
#include <sys/mount.h>
+#ifdef __NetBSD__
+#include <sys/statvfs.h>
+#define statfs statvfs
+#endif
#include <ctype.h>
#include <err.h>