Added text editor optimized for the Dvorak keyboard layout.
This commit is contained in:
parent
8e784a0201
commit
1a164e59e9
6 changed files with 98 additions and 0 deletions
4
aoeui/DESCR
Normal file
4
aoeui/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Aoeui is a very small and efficient display editor built upon a philosophy of
|
||||
making interaction with UNIX text manipulation commands easy, rather than
|
||||
duplicating their features. Its command set is optimized for the Dvorak and
|
||||
QWERTY keyboard layouts.
|
18
aoeui/Makefile
Normal file
18
aoeui/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1 2011/07/03 14:27:56 realzhtw Exp $
|
||||
#
|
||||
|
||||
DISTNAME= aoeui-1.5
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://aoeui.googlecode.com/files/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= a@umc8.ru
|
||||
HOMEPAGE= http://code.google.com/p/aoeui/
|
||||
COMMENT= Lightweight text editor optimized for Dvorak
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_TARGET= default
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
8
aoeui/PLIST
Normal file
8
aoeui/PLIST
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2011/07/03 14:27:56 realzhtw Exp $
|
||||
bin/aoeui
|
||||
bin/asdfg
|
||||
man/man1/aoeui.1
|
||||
man/man1/asdfg.1
|
||||
share/doc/aoeui/aoeui.txt
|
||||
share/doc/aoeui/notes.txt
|
||||
share/doc/aoeui/xterm-ctlseqs.txt
|
7
aoeui/distinfo
Normal file
7
aoeui/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2011/07/03 14:27:56 realzhtw Exp $
|
||||
|
||||
SHA1 (aoeui-1.5.tgz) = f0368cf55ab75cc359d8b6f55928bbeac3aecaa0
|
||||
RMD160 (aoeui-1.5.tgz) = b1bc63a67ab6b1f9fe981d18bc12fea9d5e562c7
|
||||
Size (aoeui-1.5.tgz) = 86965 bytes
|
||||
SHA1 (patch-Makefile) = 1e4e998bdd63ef76986ad629245491321e764d77
|
||||
SHA1 (patch-all.h) = 721a41b12ed0b946e58463ded5eb76f5ae8dfb79
|
45
aoeui/patches/patch-Makefile
Normal file
45
aoeui/patches/patch-Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2011/07/03 14:27:56 realzhtw Exp $
|
||||
|
||||
--- Makefile.orig 2010-10-14 21:48:53.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -7,7 +7,7 @@ SRCS = main.c mem.c die.c display.c text
|
||||
HDRS = all.h buffer.h child.h mode.h text.h locus.h utf8.h display.h \
|
||||
window.h util.h clip.h macro.h mem.h die.h types.h
|
||||
RELS = $(SRCS:.c=.o)
|
||||
-INST_DIR = $(DESTDIR)/usr
|
||||
+INST_DIR = $(DESTDIR)/$(PREFIX)
|
||||
CFLAGS = -Wall -Wno-parentheses \
|
||||
-Wpointer-arith -Wcast-align -Wwrite-strings -Wstrict-prototypes \
|
||||
-Wmissing-prototypes -Wmissing-declarations
|
||||
@@ -30,7 +30,10 @@ aoeui.help: help.m4
|
||||
asdfg.help: help.m4
|
||||
m4 -D ASDFG help.m4 | $(STRINGIFY) >$@
|
||||
libs:
|
||||
- if [ .`uname -s` = .Linux ]; then echo -lutil; fi >$@
|
||||
+ case `uname -s` in \
|
||||
+ Linux) echo -lutil;; \
|
||||
+ *BSD*|DragonFly) echo -lutil -lcompat;; \
|
||||
+ esac >$@
|
||||
|
||||
display-test: display-test.o display.o mem.o utf8.o libs
|
||||
$(CC) $(CFLAGS) -o $@ display-test.o display.o mem.o utf8.o `cat libs`
|
||||
@@ -61,14 +64,14 @@ profile: clean
|
||||
TAGS: $(SRCS) $(HDRS)
|
||||
$(CTAGS) -x $(SRCS) $(HDRS) >$@
|
||||
|
||||
-install: aoeui aoeui.1.gz asdfg.1.gz
|
||||
+install: aoeui aoeui.1 asdfg.1
|
||||
install -d $(INST_DIR)/bin
|
||||
- install -d $(INST_DIR)/share/aoeui
|
||||
- install -d $(INST_DIR)/share/man/man1
|
||||
+ install -d $(INST_DIR)/share/doc/aoeui
|
||||
+ install -d $(INST_DIR)/man/man1
|
||||
install aoeui $(INST_DIR)/bin
|
||||
ln -nf $(INST_DIR)/bin/aoeui $(INST_DIR)/bin/asdfg
|
||||
- install *.txt $(INST_DIR)/share/aoeui
|
||||
- install *.1.gz $(INST_DIR)/share/man/man1
|
||||
+ install *.txt $(INST_DIR)/share/doc/aoeui
|
||||
+ install *.1 $(INST_DIR)/man/man1
|
||||
clean:
|
||||
rm -f *.o *.help libs core gmon.out screenlog.*
|
||||
clobber: clean
|
16
aoeui/patches/patch-all.h
Normal file
16
aoeui/patches/patch-all.h
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-all.h,v 1.1 2011/07/03 14:27:56 realzhtw Exp $
|
||||
|
||||
--- all.h.orig 2010-10-14 21:48:53.000000000 +0000
|
||||
+++ all.h
|
||||
@@ -23,8 +23,10 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/wait.h>
|
||||
-#ifdef __APPLE__
|
||||
+#if defined(__APPLE__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
# include <util.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+# include <libutil.h>
|
||||
#else
|
||||
# include <pty.h>
|
||||
#endif
|
Loading…
Reference in a new issue