Import libecc-0.14.0 as wip/libecc.
Libecc is an elliptic curve crypto library for C++ developers
This commit is contained in:
parent
057b90d63d
commit
1a32b4e882
6 changed files with 67 additions and 0 deletions
1
libecc/DESCR
Normal file
1
libecc/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Libecc is an elliptic curve crypto library for C++ developers
|
23
libecc/Makefile
Normal file
23
libecc/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/10/28 17:37:04 jihbed Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libecc-0.14.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://garr.dl.sourceforge.net/project/libecc/libecc/0.14.0/
|
||||
|
||||
MAINTAINER= jihbed.research@gmail.com
|
||||
HOMEPAGE= http://garr.dl.sourceforge.net/project/libecc/libecc/0.14.0/
|
||||
COMMENT= C++ elliptic curve library
|
||||
#LICENSE= # TODO: (see mk/license.mk)
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
MAKE_JOBS_SAFE=NO
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
.include "../../devel/gmp/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
10
libecc/PLIST
Normal file
10
libecc/PLIST
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/28 17:37:04 jihbed Exp $
|
||||
include/libecc/bitset.h
|
||||
include/libecc/debug.h
|
||||
include/libecc/fieldmath.h
|
||||
include/libecc/polynomial.h
|
||||
include/libecc/rds.h
|
||||
include/libecc/rng.h
|
||||
include/libecc/sha.h
|
||||
include/libecc/square.hcc
|
||||
lib/libecc.la
|
14
libecc/buildlink3.mk
Normal file
14
libecc/buildlink3.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/10/28 17:37:04 jihbed Exp $
|
||||
|
||||
BUILDLINK_TREE+= libecc
|
||||
|
||||
.if !defined(LIBECC_BUILDLINK3_MK)
|
||||
LIBECC_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libecc+= libecc>=0.14.0
|
||||
BUILDLINK_PKGSRCDIR.libecc?= ../../wip/libecc
|
||||
|
||||
.include "../../devel/gmp/buildlink3.mk"
|
||||
.endif # LIBECC_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libecc
|
6
libecc/distinfo
Normal file
6
libecc/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/10/28 17:37:04 jihbed Exp $
|
||||
|
||||
SHA1 (libecc-0.14.0.tar.gz) = 806940844ef78479790c08c36f3473c580c66e8d
|
||||
RMD160 (libecc-0.14.0.tar.gz) = fa8a094739212de2127968018928bcc876c9836c
|
||||
Size (libecc-0.14.0.tar.gz) = 2477120 bytes
|
||||
SHA1 (patch-bitset.h) = 2ca4628bfc608f252bce6e2a79695d726f06371a
|
13
libecc/patches/patch-bitset.h
Normal file
13
libecc/patches/patch-bitset.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bitset.h,v 1.1.1.1 2011/10/28 17:37:04 jihbed Exp $
|
||||
|
||||
--- include/libecc/bitset.h.orig 2011-08-08 00:32:31.000000000 +0100
|
||||
+++ include/libecc/bitset.h 2011-08-08 00:32:54.000000000 +0100
|
||||
@@ -39,7 +39,7 @@
|
||||
#include <string>
|
||||
#include <inttypes.h>
|
||||
#include <cassert>
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
#ifdef CWDEBUG
|
||||
#include "debug.h"
|
||||
#include <libcwd/cwprint.h>
|
Loading…
Reference in a new issue