Update to 1.1.99.903 (relase candidate for next 1.2). I have been using
this for a couple months. Update PKGNAME to prefix "modular-". Add SPECIAL_PERMS and PKG_DESTDIR_SUPPORT (from pkgsrc version). Fix tabs for spacing of some things to match up better with pkgsrc version. Set _NETBSD_SOURCE in CPPFLAGS. TODO: this should be done for NetBSD only in configure.ac Requires inputproto>=1.4 Include zlib, ncurses. Add patch-ad for mouse pointer stuck on left side of screen. This has been discussed and reported many times. librac and libdrm now gone. TODO: check this.
This commit is contained in:
parent
2f293d498e
commit
1c4d97f759
4 changed files with 56 additions and 21 deletions
|
@ -1,23 +1,32 @@
|
|||
# $NetBSD: Makefile,v 1.10 2006/11/19 11:46:53 thomasklausner Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2007/01/19 23:12:48 jeremy-c-reed Exp $
|
||||
|
||||
DISTNAME= xorg-server-1.1.99.3
|
||||
DISTNAME= xorg-server-1.1.99.903
|
||||
PKGNAME= modular-${DISTNAME}
|
||||
CATEGORIES= x11
|
||||
#MASTER_SITES= http://xorg.freedesktop.org/releases/individual/xserver/
|
||||
MASTER_SITES= http://xorg.freedesktop.org/releases/individual/xserver/
|
||||
# use snapshot
|
||||
MASTER_SITES= http://xorg.freedesktop.org/archive/development/individual/xserver/
|
||||
#MASTER_SITES= http://xorg.freedesktop.org/archive/development/individual/xserver/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
SPECIAL_PERMS+= bin/Xorg ${SETUID_ROOT_PERMS}
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
COMMENT= Xorg X11 Server from modular X.org X11
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/xorg-server.pc.in
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_TOOLS+= gmake
|
||||
USE_TOOLS+= perl
|
||||
USE_LIBTOOL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
PKGCONFIG_OVERRIDE+= xorg-server.pc.in
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_TOOLS+= gmake
|
||||
USE_TOOLS+= perl
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CPPFLAGS+= -D_NETBSD_SOURCE
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
BUILDLINK_API_DEPENDS.fixesproto+= fixesproto>=4.0
|
||||
BUILDLINK_API_DEPENDS.inputproto+= inputproto>=1.4
|
||||
BUILDLINK_API_DEPENDS.kbproto+= kbproto>=1.0.3
|
||||
BUILDLINK_API_DEPENDS.libXfixes+= libXfixes>=4.0
|
||||
BUILDLINK_API_DEPENDS.scrnsaverproto+= scrnsaverproto>=1.1
|
||||
|
@ -25,14 +34,16 @@ BUILDLINK_API_DEPENDS.xkbui+= xkbui>=1.0.2
|
|||
|
||||
# need mesa for glx and more
|
||||
# maybe this should be a configure option?
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
|
||||
#.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../x11/bigreqsproto/buildlink3.mk"
|
||||
.include "../../x11/compositeproto/buildlink3.mk"
|
||||
.include "../../x11/damageproto/buildlink3.mk"
|
||||
.include "../../x11/evieext/buildlink3.mk"
|
||||
.include "../../x11/fontsproto/buildlink3.mk"
|
||||
.include "../../x11/glproto/buildlink3.mk"
|
||||
.include "../../x11/inputproto/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXau/buildlink3.mk"
|
||||
.include "../../x11/libXaw/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2006/10/05 15:54:34 jeremy-c-reed Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2007/01/19 23:12:48 jeremy-c-reed Exp $
|
||||
bin/X
|
||||
bin/Xnest
|
||||
bin/Xorg
|
||||
|
@ -207,7 +207,6 @@ lib/xorg/modules/libi2c.la
|
|||
lib/xorg/modules/libint10.la
|
||||
lib/xorg/modules/libmfb.la
|
||||
lib/xorg/modules/libpcidata.la
|
||||
lib/xorg/modules/librac.a
|
||||
lib/xorg/modules/libramdac.la
|
||||
lib/xorg/modules/libscanpci.la
|
||||
lib/xorg/modules/libshadow.la
|
||||
|
@ -227,7 +226,6 @@ lib/xorg/modules/multimedia/tda8425_drv.la
|
|||
lib/xorg/modules/multimedia/tda9850_drv.la
|
||||
lib/xorg/modules/multimedia/tda9885_drv.la
|
||||
lib/xorg/modules/multimedia/uda1380_drv.la
|
||||
lib/xorg/modules/${LOWER_OPSYS}/libdrm.la
|
||||
lib/xserver/SecurityPolicy
|
||||
share/X11/xkb/compiled/README.compiled
|
||||
share/aclocal/xorg-server.m4
|
||||
|
@ -248,13 +246,12 @@ man/man5/xorg.conf.5
|
|||
@dirrm share/X11/xkb
|
||||
@comment @dirrm share/X11
|
||||
@dirrm lib/xserver
|
||||
@dirrm lib/xorg/modules/${LOWER_OPSYS}
|
||||
@dirrm lib/xorg/modules/multimedia
|
||||
@dirrm lib/xorg/modules/linux
|
||||
@dirrm lib/xorg/modules/fonts
|
||||
@dirrm lib/xorg/modules/extensions
|
||||
@dirrm lib/xorg/modules
|
||||
@dirrm lib/xorg
|
||||
@comment @dirrm lib/xorg
|
||||
@comment @dirrm lib/X11
|
||||
@dirrm include/xorg
|
||||
@dirrm include/X11/pixmaps
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2006/10/05 15:54:34 jeremy-c-reed Exp $
|
||||
$NetBSD: distinfo,v 1.7 2007/01/19 23:12:48 jeremy-c-reed Exp $
|
||||
|
||||
SHA1 (xorg-server-1.1.99.3.tar.bz2) = cc9becda7375eae42bb4f29408755874ad45d16d
|
||||
RMD160 (xorg-server-1.1.99.3.tar.bz2) = b78da53d2808cfa8fe927f6f8744b732f1e2c88e
|
||||
Size (xorg-server-1.1.99.3.tar.bz2) = 6130486 bytes
|
||||
SHA1 (xorg-server-1.1.99.903.tar.bz2) = e63ebbd368ca0f962de2f1e6a7720473e12f2d9b
|
||||
RMD160 (xorg-server-1.1.99.903.tar.bz2) = f6039cab1f233d2785b147e0963ccb90dcd735cd
|
||||
Size (xorg-server-1.1.99.903.tar.bz2) = 5980396 bytes
|
||||
SHA1 (patch-ab) = 2703d3786503407dc6d1b9a429c23233d719efdb
|
||||
SHA1 (patch-ad) = 39c3bede8d20962cfbf751667ad15e81aa81ef56
|
||||
|
|
26
xorg-server/patches/patch-ad
Normal file
26
xorg-server/patches/patch-ad
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-ad,v 1.1 2007/01/19 23:12:48 jeremy-c-reed Exp $
|
||||
|
||||
So mouse pointer does not get stuck on left side of screen.
|
||||
|
||||
--- hw/xfree86/common/xf86Xinput.c.orig
|
||||
+++ hw/xfree86/common/xf86Xinput.c
|
||||
@@ -938,15 +938,10 @@ xf86PostMotionEvent(DeviceIntPtr device,
|
||||
/* modeled from xf86Events.c */
|
||||
if (device->ptrfeed->ctrl.threshold) {
|
||||
if ((abs(dx) + abs(dy)) >= device->ptrfeed->ctrl.threshold) {
|
||||
- local->dxremaind = ((float)dx * (float)(device->ptrfeed->ctrl.num)) /
|
||||
- (float)(device->ptrfeed->ctrl.den) + local->dxremaind;
|
||||
- valuator[0] = (int)local->dxremaind;
|
||||
- local->dxremaind = local->dxremaind - (float)valuator[0];
|
||||
-
|
||||
- local->dyremaind = ((float)dy * (float)(device->ptrfeed->ctrl.num)) /
|
||||
- (float)(device->ptrfeed->ctrl.den) + local->dyremaind;
|
||||
- valuator[1] = (int)local->dyremaind;
|
||||
- local->dyremaind = local->dyremaind - (float)valuator[1];
|
||||
+ valuator[0] = (dx * device->ptrfeed->ctrl.num) /
|
||||
+ device->ptrfeed->ctrl.den;
|
||||
+ valuator[1] = (dy * device->ptrfeed->ctrl.num) /
|
||||
+ device->ptrfeed->ctrl.den;
|
||||
}
|
||||
}
|
||||
else if (dx || dy) {
|
Loading…
Reference in a new issue