synfigstudio-0.61.08: Fixed build problem where time.h does not declare extern daylight.

This commit is contained in:
PHO / phonohawk 2008-07-21 03:00:34 +00:00 committed by Thomas Klausner
parent 8b152d8ec8
commit 1caaef542b
4 changed files with 33 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/07/21 01:05:11 phonohawk Exp $
# $NetBSD: Makefile,v 1.2 2008/07/21 03:00:34 phonohawk Exp $
#
DISTNAME= synfigstudio-0.61.08
@ -20,6 +20,10 @@ USE_DIRS+= xdg-1.4
GCONF2_SCHEMAS+= synfigstudio-thumbnailer.schemas
USE_TOOLS+= automake
pre-configure:
cd ${WRKSRC} && autoreconf
.include "../../devel/GConf/schemas.mk"
.include "../../devel/libsigc++/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2008/07/21 01:05:11 phonohawk Exp $
$NetBSD: distinfo,v 1.2 2008/07/21 03:00:34 phonohawk Exp $
SHA1 (synfigstudio-0.61.08.tar.gz) = bbf5e9d5923804ef514a81444fce09ca4d1006f3
RMD160 (synfigstudio-0.61.08.tar.gz) = 954fa1050dd20c0f72aed1914528bbdfb4ba53d6
Size (synfigstudio-0.61.08.tar.gz) = 1204766 bytes
SHA1 (patch-aa) = d427710fdaf5db9acf2870df46fe491b30eb339b
SHA1 (patch-ab) = ea82744926f88bdef7b2d902ed69d4d7d23936eb

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1 2008/07/21 03:00:34 phonohawk Exp $
--- configure.ac.orig Mon Mar 3 04:18:01 2008
+++ configure.ac
@@ -216,6 +216,7 @@ AC_CHECK_HEADERS([unistd.h signal.h fcnt
AC_CHECK_HEADERS([sys/types.h sys/wait.h sys/stat.h sys/time.h sys/resource.h sys/errno.h])
# -- T Y P E S & S T R U C T S --------------------------------
+AC_CHECK_DECLS([daylight])
# -- F U N C T I O N S ----------------------------------------

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2008/07/21 03:00:34 phonohawk Exp $
--- src/synfigapp/cvs.cpp.orig Tue Nov 13 18:13:07 2007
+++ src/synfigapp/cvs.cpp
@@ -62,7 +62,7 @@ using namespace synfigapp;
#define HAVE_STRPTIME
#endif
-#ifdef __APPLE__
+#if !HAVE_DAYLIGHT
time_t _daylight_() { time_t t(time(0)); return localtime(&t)->tm_gmtoff; }
#define daylight _daylight_()
#endif