Import gdb-7.5 as wip/gdb.
The purpose of a debugger such as GDB is to allow you to see what is going on "inside" another program while it executes--or what another program was doing at the moment it crashed. GDB can do four main kinds of things (plus other things in support of these) to help you catch bugs in the act: * Start your program, specifying anything that might affect its behavior. * Make your program stop on specified conditions. * Examine what has happened, when your program has stopped. * Change things in your program, so you can experiment with correcting the effects of one bug and go on to learn about another.
This commit is contained in:
parent
32eddfb05e
commit
2134da53a8
8 changed files with 188 additions and 0 deletions
17
gdb/DESCR
Normal file
17
gdb/DESCR
Normal file
|
@ -0,0 +1,17 @@
|
|||
The purpose of a debugger such as GDB is to allow you to see what
|
||||
is going on "inside" another program while it executes--or what
|
||||
another program was doing at the moment it crashed.
|
||||
|
||||
GDB can do four main kinds of things (plus other things in support
|
||||
of these) to help you catch bugs in the act:
|
||||
|
||||
* Start your program, specifying anything that might affect its
|
||||
behavior.
|
||||
|
||||
* Make your program stop on specified conditions.
|
||||
|
||||
* Examine what has happened, when your program has stopped.
|
||||
|
||||
* Change things in your program, so you can experiment with
|
||||
correcting the effects of one bug and go on to learn about
|
||||
another.
|
47
gdb/Makefile
Normal file
47
gdb/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gdb-7.5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gdb/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.gnu.org/software/gdb/gdb.html
|
||||
COMMENT= Symbolic debugger for multiple language frontends
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
#NOT_FOR_PLATFORM= Darwin-*-* DragonFly-*-* NetBSD-*-x86_64
|
||||
|
||||
BROKEN_GETTEXT_DETECTION= yes
|
||||
GNU_CONFIGURE= YES
|
||||
USE_PKGLOCALEDIR= YES
|
||||
USE_LIBTOOL= YES
|
||||
|
||||
USE_TOOLS+= gmake msgfmt makeinfo
|
||||
REPLACE_LOCALEDIR_PATTERNS+= Make-in
|
||||
INSTALL_TARGET= install install-info
|
||||
TEST_TARGET= check
|
||||
INFO_FILES= yes
|
||||
CONFIGURE_ENV+= CONFIG_LDFLAGS=${LDFLAGS:M*:Q}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
# Work around a bug in gdb's configure
|
||||
CONFIGURE_ENV+= ac_cv_header_curses_h=yes
|
||||
.elif ${OPSYS} == "Linux"
|
||||
USE_TOOLS+= aclocal autoheader autoconf
|
||||
|
||||
pre-configure:
|
||||
${RUN} cd ${WRKSRC}/gdb/gdbserver && \
|
||||
aclocal && autoheader && autoconf
|
||||
|
||||
.endif
|
||||
|
||||
# pkg_add: Conflicting PLIST with autoconf-2.69nb1: info/standards.info
|
||||
post-patch:
|
||||
${RM} ${WRKSRC}/etc/standards.info
|
||||
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
gdb/PLIST.Linux
Normal file
3
gdb/PLIST.Linux
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST.Linux,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
bin/gdbserver
|
||||
man/man1/gdbserver.1
|
66
gdb/PLIST.common
Normal file
66
gdb/PLIST.common
Normal file
|
@ -0,0 +1,66 @@
|
|||
@comment $NetBSD: PLIST.common,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
bin/gdb
|
||||
include/ansidecl.h
|
||||
include/bfd.h
|
||||
include/bfdlink.h
|
||||
include/dis-asm.h
|
||||
include/gdb/jit-reader.h
|
||||
include/symcat.h
|
||||
info/annotate.info
|
||||
info/bfd.info
|
||||
info/configure.info
|
||||
info/gdb.info
|
||||
info/gdbint.info
|
||||
info/stabs.info
|
||||
lib/charset.alias
|
||||
lib/libbfd.la
|
||||
lib/libiberty.a
|
||||
lib/libopcodes.la
|
||||
man/man1/gdb.1
|
||||
share/gdb/python/gdb/__init__.py
|
||||
share/gdb/python/gdb/command/__init__.py
|
||||
share/gdb/python/gdb/command/explore.py
|
||||
share/gdb/python/gdb/command/pretty_printers.py
|
||||
share/gdb/python/gdb/command/prompt.py
|
||||
share/gdb/python/gdb/printing.py
|
||||
share/gdb/python/gdb/prompt.py
|
||||
share/gdb/python/gdb/types.py
|
||||
share/gdb/syscalls/amd64-linux.xml
|
||||
share/gdb/syscalls/gdb-syscalls.dtd
|
||||
share/gdb/syscalls/i386-linux.xml
|
||||
share/gdb/syscalls/mips-n32-linux.xml
|
||||
share/gdb/syscalls/mips-n64-linux.xml
|
||||
share/gdb/syscalls/mips-o32-linux.xml
|
||||
share/gdb/syscalls/ppc-linux.xml
|
||||
share/gdb/syscalls/ppc64-linux.xml
|
||||
share/gdb/syscalls/sparc-linux.xml
|
||||
share/gdb/syscalls/sparc64-linux.xml
|
||||
share/locale/da/LC_MESSAGES/bfd.mo
|
||||
share/locale/da/LC_MESSAGES/opcodes.mo
|
||||
share/locale/de/LC_MESSAGES/opcodes.mo
|
||||
share/locale/es/LC_MESSAGES/bfd.mo
|
||||
share/locale/es/LC_MESSAGES/opcodes.mo
|
||||
share/locale/fi/LC_MESSAGES/bfd.mo
|
||||
share/locale/fi/LC_MESSAGES/opcodes.mo
|
||||
share/locale/fr/LC_MESSAGES/bfd.mo
|
||||
share/locale/fr/LC_MESSAGES/opcodes.mo
|
||||
share/locale/ga/LC_MESSAGES/opcodes.mo
|
||||
share/locale/id/LC_MESSAGES/bfd.mo
|
||||
share/locale/id/LC_MESSAGES/opcodes.mo
|
||||
share/locale/it/LC_MESSAGES/opcodes.mo
|
||||
share/locale/ja/LC_MESSAGES/bfd.mo
|
||||
share/locale/nl/LC_MESSAGES/opcodes.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/opcodes.mo
|
||||
share/locale/ro/LC_MESSAGES/bfd.mo
|
||||
share/locale/ro/LC_MESSAGES/opcodes.mo
|
||||
share/locale/ru/LC_MESSAGES/bfd.mo
|
||||
share/locale/rw/LC_MESSAGES/bfd.mo
|
||||
share/locale/sv/LC_MESSAGES/bfd.mo
|
||||
share/locale/sv/LC_MESSAGES/opcodes.mo
|
||||
share/locale/tr/LC_MESSAGES/bfd.mo
|
||||
share/locale/tr/LC_MESSAGES/opcodes.mo
|
||||
share/locale/uk/LC_MESSAGES/bfd.mo
|
||||
share/locale/vi/LC_MESSAGES/bfd.mo
|
||||
share/locale/vi/LC_MESSAGES/opcodes.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/bfd.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/opcodes.mo
|
1
gdb/TODO
Normal file
1
gdb/TODO
Normal file
|
@ -0,0 +1 @@
|
|||
- NetBSD/amd64 6.0.1 segfaults
|
7
gdb/distinfo
Normal file
7
gdb/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
|
||||
SHA1 (gdb-7.5.tar.gz) = 57b58bc5b959e420d9aeb4cfeaa3b2fd7c685a10
|
||||
RMD160 (gdb-7.5.tar.gz) = 55488e96d0707d547530e49aa3e561185cca7ab0
|
||||
Size (gdb-7.5.tar.gz) = 28475479 bytes
|
||||
SHA1 (patch-ao) = 0738d5c2aae9a04af75432073706ca2ba183f750
|
||||
SHA1 (patch-etc_Makefile.in) = 9c01dc625f01cb6a057e3cad61a4d20386490c92
|
16
gdb/patches/patch-ao
Normal file
16
gdb/patches/patch-ao
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ao,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
|
||||
Avoid following ERROR:
|
||||
ERROR: [check-portability.awk] gdb/config/djgpp/djconfig.sh: if test "`pwd`" == "${srcdir}" ; then
|
||||
|
||||
--- gdb/config/djgpp/djconfig.sh.orig 2002-02-25 17:09:45.000000000 +0100
|
||||
+++ gdb/config/djgpp/djconfig.sh 2006-10-22 09:54:26.000000000 +0200
|
||||
@@ -76,7 +76,7 @@ TMPFILE="${TMPDIR-.}/cfg.tmp"
|
||||
|
||||
# We need to skip the build directory if it is a subdirectory of $srcdir,
|
||||
# otherwise we will have an infinite recursion on our hands...
|
||||
-if test "`pwd`" == "${srcdir}" ; then
|
||||
+if test "`pwd`" = "${srcdir}" ; then
|
||||
SKIPDIR=""
|
||||
SKIPFILES=""
|
||||
else
|
31
gdb/patches/patch-etc_Makefile.in
Normal file
31
gdb/patches/patch-etc_Makefile.in
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-etc_Makefile.in,v 1.1 2013/02/02 05:06:43 makoto Exp $
|
||||
|
||||
# pkg_add: Conflicting PLIST with autoconf-2.69nb1: info/standards.info
|
||||
|
||||
--- etc/Makefile.in.orig 2010-11-21 04:37:57.000000000 +0900
|
||||
+++ etc/Makefile.in 2013-02-02 12:03:17.000000000 +0900
|
||||
@@ -58,10 +58,10 @@
|
||||
#### Host, target, and site specific Makefile fragments come in here.
|
||||
###
|
||||
|
||||
-INFOFILES = standards.info configure.info
|
||||
-DVIFILES = standards.dvi configure.dvi
|
||||
-PDFFILES = standards.pdf configure.pdf
|
||||
-HTMLFILES = standards.html configure.html
|
||||
+INFOFILES = configure.info
|
||||
+DVIFILES = configure.dvi
|
||||
+PDFFILES = configure.pdf
|
||||
+HTMLFILES = configure.html
|
||||
|
||||
all: info
|
||||
install install-strip: install-info
|
||||
@@ -157,9 +157,6 @@
|
||||
done; \
|
||||
fi
|
||||
|
||||
-standards.info: $(srcdir)/standards.texi $(srcdir)/make-stds.texi
|
||||
- $(MAKEINFO) --no-split -I$(srcdir) -o standards.info $(srcdir)/standards.texi
|
||||
-
|
||||
standards.html: $(srcdir)/standards.texi $(srcdir)/make-stds.texi
|
||||
$(TEXI2HTML) --no-split -I$(srcdir) -o standards.html $(srcdir)/standards.texi
|
||||
|
Loading…
Reference in a new issue