re-import of pyPgSQL as py-PgSQL

This was requested by Lubomir Sedlacik <salo@Xtrmntr.org> to
match pkgsrc's naming scheme for Python pkgs.

pyPgSQL is a package of two modules that provide a Python DB-API 2.0 compliant
interface to PostgreSQL databases. The first module, libpq, exports the
PostgreSQL C API to Python. This module is written in C and can be compiled
into Python or can be dynamically loaded on demand. The second module, PgSQL,
provides the DB-API 2.0 compliant interface and support for various PostgreSQL
data types, such as INT8, NUMERIC, MONEY, BOOL, ARRAYS, etc. This module is
written in Python.
This commit is contained in:
Marc Recht 2003-04-05 21:46:29 +00:00
parent 85ec833c84
commit 21b4584045
6 changed files with 107 additions and 0 deletions

7
py-PgSQL/DESCR Normal file
View file

@ -0,0 +1,7 @@
pyPgSQL is a package of two modules that provide a Python DB-API 2.0 compliant
interface to PostgreSQL databases. The first module, libpq, exports the
PostgreSQL C API to Python. This module is written in C and can be compiled
into Python or can be dynamically loaded on demand. The second module, PgSQL,
provides the DB-API 2.0 compliant interface and support for various PostgreSQL
data types, such as INT8, NUMERIC, MONEY, BOOL, ARRAYS, etc. This module is
written in Python.

29
py-PgSQL/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/04/05 21:46:30 marc Exp $
#
DISTNAME= pyPgSQL-2.3
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pypgsql/}
MAINTAINER= marc@informatik.uni-bremen.de
HOMEPAGE= http://pypgsql.sourceforge.net/
COMMENT= Python DB-API 2.0 compliant interface to PostgreSQL
WRKSRC= ${WRKDIR}/pypgsql
USE_BUILDLINK2= YES
PYDISTUTILSPKG= YES
PYBINMODULE= YES
PY_PATCHPLIST= YES
PYTHON_VERSION_REQD>= 20
post-install:
${PYTHONBIN} -O ${LOCALBASE}/${PYLIB}/compileall.py \
${LOCALBASE}/${PYSITELIB}/pyPgSQL
.include "../../lang/python/extension.mk"
.include "../../lang/python/application.mk"
.include "../../time/py-mxDateTime/buildlink2.mk"
.include "../../databases/postgresql-lib/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

13
py-PgSQL/PLIST Normal file
View file

@ -0,0 +1,13 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/04/05 21:46:29 marc Exp $
${PYSITELIB}/pyPgSQL/PgSQL.py
${PYSITELIB}/pyPgSQL/PgSQL.pyc
${PYSITELIB}/pyPgSQL/PgSQL.pyo
${PYSITELIB}/pyPgSQL/__init__.py
${PYSITELIB}/pyPgSQL/__init__.pyc
${PYSITELIB}/pyPgSQL/__init__.pyo
${PYSITELIB}/pyPgSQL/libpq/__init__.py
${PYSITELIB}/pyPgSQL/libpq/__init__.pyc
${PYSITELIB}/pyPgSQL/libpq/__init__.pyo
${PYSITELIB}/pyPgSQL/libpq/libpqmodule.so
@dirrm ${PYSITELIB}/pyPgSQL/libpq
@dirrm ${PYSITELIB}/pyPgSQL

22
py-PgSQL/buildlink2.mk Normal file
View file

@ -0,0 +1,22 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/04/05 21:46:29 marc Exp $
.include "../../lang/python/pyversion.mk"
.if !defined(PYPGSQL_BUILDLINK2_MK)
PYPGSQL_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= pyPgSQL
BUILDLINK_DEPENDS.pyPgSQL?= ${PYPKGPREFIX}-PgSQL>=2.3
BUILDLINK_PKGSRCDIR.pyPgSQL?= ../../wip/py-PgSQL
EVAL_PREFIX+= BUILDLINK_PREFIX.pyPgSQL=${PYPKGPREFIX}-PgSQL
BUILDLINK_PREFIX.pyPgSQL_DEFAULT= ${LOCALBASE}
.include "../../time/py-mxDateTime/buildlink2.mk"
.include "../../databases/postgresql-lib/buildlink2.mk"
BUILDLINK_TARGETS+= pyPgSQL-buildlink
pyPgSQL-buildlink: _BUILDLINK_USE
.endif # PYPGSQL_BUILDLINK2_MK

5
py-PgSQL/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/04/05 21:46:30 marc Exp $
SHA1 (pyPgSQL-2.3.tar.gz) = 18b346dfea9f73653ceaa97bc25886b5d964881a
Size (pyPgSQL-2.3.tar.gz) = 151297 bytes
SHA1 (patch-aa) = 2ea5553702a7a52fc2411c15cd66ce0c6cd666f8

31
py-PgSQL/patches/patch-aa Normal file
View file

@ -0,0 +1,31 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/04/05 21:46:30 marc Exp $
--- libpqmodule.c.orig 2002-12-01 05:59:24.000000000 +0100
+++ libpqmodule.c 2003-02-01 14:30:57.000000000 +0100
@@ -764,7 +764,7 @@
return PgInt8_FromString(s, (char **)NULL, 10);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}
#endif
@@ -828,7 +828,7 @@
return PgInt2_FromString(s, (char **)NULL, 10);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}
@@ -880,7 +880,7 @@
return libPQbool_FromString(self, args);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}