Patch to obtain a lock on mutex before unlock it.

This commit is contained in:
Min Sik Kim 2004-01-18 08:50:43 +00:00 committed by Thomas Klausner
parent 9d93f53e24
commit 23bc3da8f7
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/11/26 18:31:48 mpasternak Exp $
$NetBSD: distinfo,v 1.2 2004/01/18 08:50:43 minskim Exp $
SHA1 (PyBabelPhish-2.0_All_Platforms.tar.bz2) = e1371f8010823fa3904efeb24f3d54f3d6f4feaf
Size (PyBabelPhish-2.0_All_Platforms.tar.bz2) = 62159 bytes
SHA1 (patch-aa) = faaf652b388bac2e080ec52af69cc782ad47eac5

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1 2004/01/18 08:50:44 minskim Exp $
--- pybabelfish.py.orig 2003-11-24 20:22:49.000000000 -0600
+++ pybabelfish.py
@@ -1770,7 +1770,9 @@ def runbabel() :
mybabel=babelwin()
mybabel.full_quit=1
threads_init()
+ threads_enter()
mainloop()
+ threads_leave()
if __name__== "__main__" :