Remove editline, newer version in pkgsrc.

This commit is contained in:
Thomas Klausner 2013-10-11 14:25:10 +00:00
parent 9ec10ba86d
commit 245193007c
9 changed files with 1 additions and 118 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.5493 2013/10/11 11:50:46 thomasklausner Exp $
# $Id: Makefile,v 1.5494 2013/10/11 14:25:10 thomasklausner Exp $
#
COMMENT= WIP pkgsrc packages
@ -531,7 +531,6 @@ SUBDIR+= eclipse
SUBDIR+= ecore
SUBDIR+= edb
SUBDIR+= edelib
SUBDIR+= editline
SUBDIR+= edje
SUBDIR+= eet
SUBDIR+= efltk

1
TODO
View file

@ -23,7 +23,6 @@ Suggested package updates
o e17-1.0
o ecasound-2.9
o ecb-2.40
o editline-20120311.3.0
o emboss-base-6.0.1
o emelfm2-0.8.2
o etoile-0.4.2

View file

@ -1,4 +0,0 @@
This is an autotool- and libtoolized port of the NetBSD Editline library
(libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions,
similar to those found in GNU Readline.

View file

@ -1,22 +0,0 @@
# $NetBSD: Makefile,v 1.13 2013/01/27 00:01:24 ryo-on Exp $
#
DISTNAME= libedit-20121213-3.0
PKGNAME= editline-3.0.20121213
CATEGORIES= devel
MASTER_SITES= http://www.thrysoee.dk/editline/
MAINTAINER= reed@reedmedia.net
HOMEPAGE= http://www.thrysoee.dk/editline/
COMMENT= NetBSD Editline library (libedit) for generic line editing
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= automake autoreconf
pre-configure:
cd ${WRKSRC} && autoreconf
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,29 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2009/10/11 10:44:34 thomasklausner Exp $
include/editline/readline.h
include/histedit.h
lib/libedit.la
lib/pkgconfig/libedit.pc
man/man3/editline.3
man/man3/el_deletestr.3
man/man3/el_end.3
man/man3/el_get.3
man/man3/el_getc.3
man/man3/el_gets.3
man/man3/el_history.3
man/man3/el_history_end.3
man/man3/el_history_init.3
man/man3/el_init.3
man/man3/el_insertstr.3
man/man3/el_line.3
man/man3/el_parse.3
man/man3/el_push.3
man/man3/el_reset.3
man/man3/el_resize.3
man/man3/el_set.3
man/man3/el_source.3
man/man3/el_tok_end.3
man/man3/el_tok_init.3
man/man3/el_tok_line.3
man/man3/el_tok_reset.3
man/man3/el_tok_str.3
man/man5/editrc.5

View file

@ -1,12 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.5 2009/03/20 19:43:40 jsonn Exp $
BUILDLINK_TREE+= editline
.if !defined(EDITLINE_BUILDLINK3_MK)
EDITLINE_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.editline+= editline>=2.11
BUILDLINK_PKGSRCDIR.editline?= ../../wip/editline
.endif # EDITLINE_BUILDLINK3_MK
BUILDLINK_TREE+= -editline

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.7 2013/01/27 00:01:24 ryo-on Exp $
SHA1 (libedit-20121213-3.0.tar.gz) = 2f20bc835c1282b6815c4c8e2f852d6fe4318f7a
RMD160 (libedit-20121213-3.0.tar.gz) = 880a3711863af5f0823475db76f0697d91d088c6
Size (libedit-20121213-3.0.tar.gz) = 473665 bytes
SHA1 (patch-ab) = 29ed6d0aad2a4c76ada124867cb0e3ff88b8030e
SHA1 (patch-ac) = 71b27006acc43128ad9756e07eb79e961f6f9c94

View file

@ -1,29 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/01/11 10:57:19 phonohawk Exp $
--- acinclude.m4.orig 2005-08-28 17:26:59.000000000 +0900
+++ acinclude.m4
@@ -65,3 +65,23 @@ AC_DEFUN([EL_GETPW_R_DRAFT],
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])
])
+
+AC_DEFUN([EL_PRAGMA_WEAK],
+[
+ AC_MSG_CHECKING([if we can use C pragma weak SYM])
+ AC_RUN_IFELSE([#include <stdio.h>
+ #pragma weak ___non_existent_function___
+ extern void ___non_existent_function___(void);
+ int main(void) {
+ if (___non_existent_function___ == 0) {
+ return 0;
+ }
+ else {
+ return 1;
+ }
+ }],
+ [AC_DEFINE([HAVE_PRAGMA_WEAK], 1, [Define to 1 if we can use C pragma weak SYM.])
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)],
+ [AC_MSG_RESULT(cross compiling; assumed `no')])
+])
\ No newline at end of file

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ac,v 1.1 2009/01/11 10:57:19 phonohawk Exp $
--- configure.ac.orig 2009-01-11 19:33:42.000000000 +0900
+++ configure.ac
@@ -57,6 +57,7 @@ AC_C_CONST
AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_CHECK_TYPES([u_int32_t])
+EL_PRAGMA_WEAK
# Checks for library functions.
AC_FUNC_CLOSEDIR_VOID