Changed multiple things:
* Typo in DESCR * Generate the PLIST * Add patches for the Makefile * Changed MAINTAINER to myself * Remove getopt.h inclusion from axe.h for FreeBSD compatability.
This commit is contained in:
parent
268b363f81
commit
24cf3af87d
6 changed files with 55 additions and 6 deletions
|
@ -1,3 +1,3 @@
|
|||
Command line tool that let's you look inside .ATR and .XFD files,
|
||||
insert new files into them, remove files from them, etc... Great
|
||||
Command line tool that lets you look inside .ATR and .XFD files,
|
||||
insert new files into them, remove files from them, etc. Great
|
||||
tool to go along with the atari800 emulator package.
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/09/17 15:25:20 xtraeme Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2003/09/27 20:30:00 virtus Exp $
|
||||
#
|
||||
|
||||
DISTNAME= axe-0.2.0
|
||||
CATEGORIES= emulators cross
|
||||
MASTER_SITES= http://www.hardcoders.org/axe/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
MAINTAINER= virtus@wanadoo.nl
|
||||
HOMEPAGE= http://www.hardcoders.org/axe/
|
||||
COMMENT= Manipulate contents of Atari 8bit disk image files (.ATR, .XFD)
|
||||
|
||||
|
|
|
@ -1 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/09/17 15:25:20 xtraeme Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2003/09/27 20:30:00 virtus Exp $
|
||||
bin/axe
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/09/17 15:25:21 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/09/27 20:30:00 virtus Exp $
|
||||
|
||||
SHA1 (axe-0.2.0.tar.gz) = 852fa466ad37f19839a99ae307482dd0c2eb1a97
|
||||
Size (axe-0.2.0.tar.gz) = 14138 bytes
|
||||
SHA1 (patch-aa) = ccbfc04361e1a6ff50afc4668f2cf38b6da69fef
|
||||
SHA1 (patch-ab) = 4d1ec149ff17f6fe8159682e54d62abfaf5e50c7
|
||||
|
|
11
axe/patches/patch-aa
Normal file
11
axe/patches/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- axe.h.orig Sat Sep 27 20:41:02 2003
|
||||
+++ axe.h Sat Sep 27 20:39:45 2003
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
-#include <getopt.h>
|
||||
+/* #include <getopt.h> -- This gives an error on FreeBSD */
|
||||
#include <dirent.h>
|
||||
|
||||
extern char *optarg;
|
35
axe/patches/patch-ab
Normal file
35
axe/patches/patch-ab
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- Makefile.orig Wed Feb 2 20:56:52 2000
|
||||
+++ Makefile Sat Sep 27 21:20:07 2003
|
||||
@@ -1,17 +1,13 @@
|
||||
all: axe
|
||||
|
||||
-CC=gcc
|
||||
-
|
||||
VERSION=0.2.0
|
||||
|
||||
-CFLAGS=-DVERSION=\"$(VERSION)\"
|
||||
-
|
||||
axe: axe.o axelib.o
|
||||
- $(CC) $(DEBUG) $(CFLAGS) -o axe axe.o axelib.o
|
||||
+ $(CC) $(CFLAGS) -o axe axe.o axelib.o
|
||||
axe.o: axe.c axe.h
|
||||
- $(CC) $(DEBUG) $(CFLAGS) -o axe.o -c axe.c
|
||||
+ $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c axe.c
|
||||
axelib.o: axelib.c axe.h
|
||||
- $(CC) $(DEBUG) $(CFLAGS) -o axelib.o -c axelib.c
|
||||
+ $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c axelib.c
|
||||
clean:
|
||||
rm -f axe axe.o axelib.o core *~ #*
|
||||
|
||||
@@ -19,10 +15,9 @@
|
||||
DEBUG="-DDEBUG -g" make -e all
|
||||
|
||||
install: axe
|
||||
- cp axe /usr/local/bin
|
||||
+ ${INSTALL} -c -m 0755 axe ${PREFIX}/bin
|
||||
|
||||
tarball: clean
|
||||
@ cd .. ; \
|
||||
tar cvfz axe-$(VERSION).tar.gz axe-$(VERSION); \
|
||||
echo ../axe-$(VERSION).tar.gz created
|
||||
-
|
Loading…
Reference in a new issue