Remove patch. Use files/nbtool_config.h instead
This commit is contained in:
parent
2630d1241c
commit
25eb9f4eac
3 changed files with 14 additions and 21 deletions
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.10 2011/05/28 15:54:14 cheusov Exp $
|
||||
$NetBSD: distinfo,v 1.11 2011/05/29 08:56:50 cheusov Exp $
|
||||
|
||||
SHA1 (netbsd-awk-20110509.tar.bz2) = 4ccb0d8f6ee0bf8b4cea23d4c20dbe4524fef858
|
||||
RMD160 (netbsd-awk-20110509.tar.bz2) = 623e77c53b6edded01edcfeae769fa5994758767
|
||||
Size (netbsd-awk-20110509.tar.bz2) = 57262 bytes
|
||||
SHA1 (patch-run.c) = 9b407c8ac6fbfc4d1f4faad85d62cd915a0eda80
|
||||
|
|
|
@ -1,3 +1,16 @@
|
|||
#ifndef _NBTOOL_CONFIG_H_
|
||||
#define _NBTOOL_CONFIG_H_
|
||||
|
||||
#include <stdint.h>
|
||||
|
||||
#define __UNCONST(a) ((void *) (intptr_t) (const void *) (a))
|
||||
|
||||
#ifndef HAVE_FUNC1_FPURGE
|
||||
int fpurge (FILE *stream);
|
||||
#endif
|
||||
|
||||
#ifndef HAVE_FUNC3_STRLCAT
|
||||
size_t strlcat(char *dst, const char *src, size_t size);
|
||||
#endif
|
||||
|
||||
#endif // _NBTOOL_CONFIG_H_
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-run.c,v 1.1 2011/05/28 15:54:14 cheusov Exp $
|
||||
|
||||
--- run.c.orig 2011-04-18 15:23:28.000000000 +0000
|
||||
+++ run.c
|
||||
@@ -40,6 +40,14 @@ THIS SOFTWARE.
|
||||
#include "awk.h"
|
||||
#include "awkgram.h"
|
||||
|
||||
+#ifndef HAVE_FUNC1_FPURGE
|
||||
+int fpurge (FILE *stream);
|
||||
+#endif
|
||||
+
|
||||
+#ifndef HAVE_FUNC3_STRLCAT
|
||||
+size_t strlcat(char *dst, const char *src, size_t size);
|
||||
+#endif
|
||||
+
|
||||
#define tempfree(x) do { if (istemp(x)) tfree(x); } while (/*CONSTCOND*/0)
|
||||
|
||||
void stdinit(void);
|
Loading…
Reference in a new issue