Import marsyas-0.2.16 as wip/marsyas.

Initial check-in of work-in-progress (does not build to completion yet).

MARSYAS is a software framework that was created as part of my
research in Princeton University as a Phd graduate student. It is a
collection of classes written in C++ and JAVA for various sound
analysis and synthesis tasks. It started my first year in graduate school
(1998) when I rewrote various tools that I had been using in order to
make my life easier and also to code them the way I wanted them to be.

This library is made by me for my own research purposes. Anyone who
finds anything useful is welcome to use it, but I have no
responsibility whatsoever. I will be happy to answer any questions and
I will try to keep developing the library/toolkit. Until now
development is guided by what my research needs and whenever I find
some free time other stuff.

The basic goal for MARSYAS has been to design a flexible and easily
extensible system that allows rapid prototyping of audio
applications. MARSYAS is released as free software under the GNU
public licence hoping that people will actively contribute to its
development. Please send bugs, comments, additions, problems and
anything else to gtzan@@cs.cmu.edu. This version 0.2 is the third 
major rewrite of Marsyas and is still in experimental stage. Feedback 
is more than welcome. 

(This is the software behind MoodLogic and similar technologies/services)
This commit is contained in:
Blair Sadewitz 2008-07-10 20:23:06 +00:00 committed by Thomas Klausner
parent d1cc755060
commit 2ef0af1feb
8 changed files with 215 additions and 0 deletions

0
marsyas/DESCR Normal file
View file

60
marsyas/Makefile Normal file
View file

@ -0,0 +1,60 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $
#
DISTNAME= marsyas-0.2.16
CATEGORIES= wip
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=marsyas/}
MAINTAINER= bjs@NetBSD.org
HOMEPAGE= http://marsyas.sourceforge.net/
COMMENT= Music Analysis, Retrieval and Synthesis for Audio Signals
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
CONFIGURE_ARGS+= --without-matlab
CONFIGURE_ARGS+= --with-readline=${BUILDLINK_PREFIX.readline:Q}
CONFIGURE_ARGS+= --enable-oss
CONFIGURE_ARGS+= --disable-midi
BROKEN_READLINE_DETECTION= yes
CHECK_PORTABILITY_SKIP= otherlibs/Qwt/admin/svn2package.sh
PTHREAD_OPTS= require native
SUBST_CLASSES+= pthread
SUBST_FILES.pthread= configure
SUBST_MESSAGE.pthread= adjusting pthread flags
SUBST_SED.pthread= -e 's,-lpthread,${PTHREAD_LDFLAGS} ${PTHREAD_LIBS},g'
SUBST_STAGE.pthread= pre-configure
CFLAGS+= ${PTHREAD_CFLAGS}
.include "../../mk/endian.mk"
.if ${MACHINE_ENDIAN} != "unknown"
CFLAGS+= -D__${MACHINE_ENDIAN:tu}_ENDIAN__
.else
BROKEN= Unknown endianness
.endif
.include "../../mk/bsd.prefs.mk"
MARSYAS_OPSYS_LINUX= Linux FreeBSD NetBSD OpenBSD DragonFly
.if !empty(MARSYAS_OPSYS_LINUX:M${OPSYS})
CFLAGS+= -DMARSYAS_LINUX
.endif
.include "options.mk"
post-extract:
${RUN} ${FIND} ${WRKSRC} -path \*.svn\* -rm
.include "../../audio/libmad/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

1
marsyas/PLIST Normal file
View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $

8
marsyas/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $
SHA1 (marsyas-0.2.16.tar.gz) = c96b4e9184300a4d0222fc72792ff08eac199396
RMD160 (marsyas-0.2.16.tar.gz) = bf5fb4f94afe20094969f2874363af1ed1edf579
Size (marsyas-0.2.16.tar.gz) = 48829911 bytes
SHA1 (patch-aa) = 516ecd5bc0f1684bc31868bad075349dc4ecb2c4
SHA1 (patch-ab) = cce518d18d5560bc34111fdcfb1b40c007d0ea26
SHA1 (patch-ac) = 59bb76de4a5e9d37972b4427d0a54e01435e8af0

21
marsyas/options.mk Normal file
View file

@ -0,0 +1,21 @@
PKG_OPTIONS_VAR= PKG_OPTIONS.marsyas
PKG_SUPPORTED_OPTIONS= mad vorbis
PKG_SUGGESTED_OPTIONS= mad
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mmad)
#
. include "../../audio/libmad/buildlink3.mk"
CONFIGURE_ARGS+= --with-mad=${BUILDLINK_PREFIX.libmad:Q}
.else
CONFIGURE_ARGS+= --without-mad
.endif
.if !empty(PKG_OPTIONS:Mvorbis)
#
. include "../../audio/libvorbis/buildlink3.mk"
CONFIGURE_ARGS+= --with-vorbis=${BUILDLINK_PREFIX.libvorbis:Q}
.else
CONFIGURE_ARGS+= --without-vorbis
.endif

17
marsyas/patches/patch-aa Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $
--- otherlibs/RtAudio/RtAudio3.cpp.orig 2008-06-09 12:29:25.000000000 -0400
+++ otherlibs/RtAudio/RtAudio3.cpp
@@ -500,7 +500,11 @@ bool RtApi :: probeDeviceOpen( int devic
#include <errno.h>
#include <math.h>
-#define DAC_NAME "/dev/dsp"
+#ifndef DEVOSSAUDIO
+#define DEVOSSAUDIO "/dev/dsp"
+#endif
+
+#define DAC_NAME DEVOSSAUDIO
#define MAX_DEVICES 16
#define MAX_CHANNELS 16

38
marsyas/patches/patch-ab Normal file
View file

@ -0,0 +1,38 @@
$NetBSD: patch-ab,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $
--- configure.in.orig 2008-07-09 23:58:19.000000000 -0400
+++ configure.in
@@ -28,7 +28,7 @@ AM_INIT_AUTOMAKE([marsyas], [0.2.16])
#Default CXXFLAGS
MARSYAS_DEFAULT_CXXFLAGS="-O3 -Wall -fPIC"
-if test "x$CXXFLAGS" == "x"; then
+if test "x$CXXFLAGS" = "x"; then
CXXFLAGS="$MARSYAS_DEFAULT_CXXFLAGS"
fi
AC_PROG_CC
@@ -281,13 +281,13 @@ AC_SUBST([MATLABLIBS])
AC_DEFUN([AC_MRS_LANG],
[
- if test "x$3" == "x" ; then
+ if test "x$3" = "x" ; then
APP=$2
else
APP=$3
fi
AC_PATH_PROG([$1],[$APP])
- if test "x$$1" == "x" ; then
+ if test "x$$1" = "x" ; then
AC_MSG_WARN([No $2 found.])
else
AC_SUBST([BINDINGS],["$BINDINGS $2"])
@@ -296,7 +296,7 @@ AC_DEFUN([AC_MRS_LANG],
AC_ARG_ENABLE([binding],[AC_HELP_STRING([--enable-bindings],[Enable SWIG generated bindings.])])
-if test "x${enable_bindings}" == "xyes" ; then
+if test "x${enable_bindings}" = "xyes" ; then
AC_MRS_LANG([RUBY],[ruby])
AC_MRS_LANG([PYTHON],[python])
AC_MRS_LANG([LUA],[lua])

70
marsyas/patches/patch-ac Normal file
View file

@ -0,0 +1,70 @@
$NetBSD: patch-ac,v 1.1.1.1 2008/07/10 20:23:06 bsadewitz Exp $
--- configure.orig 2008-07-09 23:59:47.000000000 -0400
+++ configure
@@ -1818,7 +1818,7 @@ INSTALL_STRIP_PROGRAM="\${SHELL} \$(inst
#Default CXXFLAGS
MARSYAS_DEFAULT_CXXFLAGS="-O3 -Wall -fPIC"
-if test "x$CXXFLAGS" == "x"; then
+if test "x$CXXFLAGS" = "x"; then
CXXFLAGS="$MARSYAS_DEFAULT_CXXFLAGS"
fi
ac_ext=c
@@ -3798,9 +3798,9 @@ if test "${enable_binding+set}" = set; t
enableval="$enable_binding"
fi;
-if test "x${enable_bindings}" == "xyes" ; then
+if test "x${enable_bindings}" = "xyes" ; then
- if test "x" == "x" ; then
+ if test "x" = "x" ; then
APP=ruby
else
APP=
@@ -3844,7 +3844,7 @@ else
echo "${ECHO_T}no" >&6
fi
- if test "x$RUBY" == "x" ; then
+ if test "x$RUBY" = "x" ; then
{ echo "$as_me:$LINENO: WARNING: No ruby found." >&5
echo "$as_me: WARNING: No ruby found." >&2;}
else
@@ -3853,7 +3853,7 @@ echo "$as_me: WARNING: No ruby found." >
fi
- if test "x" == "x" ; then
+ if test "x" = "x" ; then
APP=python
else
APP=
@@ -3897,7 +3897,7 @@ else
echo "${ECHO_T}no" >&6
fi
- if test "x$PYTHON" == "x" ; then
+ if test "x$PYTHON" = "x" ; then
{ echo "$as_me:$LINENO: WARNING: No python found." >&5
echo "$as_me: WARNING: No python found." >&2;}
else
@@ -3906,7 +3906,7 @@ echo "$as_me: WARNING: No python found."
fi
- if test "x" == "x" ; then
+ if test "x" = "x" ; then
APP=lua
else
APP=
@@ -3950,7 +3950,7 @@ else
echo "${ECHO_T}no" >&6
fi
- if test "x$LUA" == "x" ; then
+ if test "x$LUA" = "x" ; then
{ echo "$as_me:$LINENO: WARNING: No lua found." >&5
echo "$as_me: WARNING: No lua found." >&2;}
else