Update to 2.01.01a14:

All:

-	Fixed a bug in getvargs() that caused mkisofs -joliet-long to be
	declared as illegal option.

-	Several small format enhancements for getargs()

-	getavrgs() is now (like getargs()) able to correctly handle
	combinations of single char boolean flags

Mkisofs (By Jörg Schilling and James Pearson j.pearson@ge.ucl.ac.uk):

-	man page extended to include a description for the -find
	option.

-	Added $(LIB_ACL) tp the mkisofs Makefile to allow the code from
	libfind to link properly on all OS.

-	Fixed several small problems with option parsing caused by the
	change from GNU getopt_long to getvargs()
	Thanks to İsmail Dönmez & scdbackup@gmx.net & Sebastian Trüg

-	Changed '%' option format specifier to '%0' to reflect a small
	enhancement in libschily.

-	Better checks and better error messages for mkisofs -dvd-video
	Mkisofs now correectly checks for the existence of a directory
	"VIDEO_TS" in the root diretory of the media.

-	mkisofs -find now allows to use -graft-points

-	mkisofs -find now allows to use -path-list
This commit is contained in:
Thomas Klausner 2006-09-14 23:12:23 +00:00
parent 2272257a0d
commit 31d097fc6d
7 changed files with 30 additions and 30 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.13 2006/09/10 17:48:11 thomasklausner Exp $
# $NetBSD: Makefile,v 1.14 2006/09/14 23:12:23 thomasklausner Exp $
DISTNAME= cdrtools-2.01.01a13
DISTNAME= cdrtools-2.01.01a14
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/alpha/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,20 +1,20 @@
$NetBSD: distinfo,v 1.9 2006/09/10 17:48:11 thomasklausner Exp $
$NetBSD: distinfo,v 1.10 2006/09/14 23:12:23 thomasklausner Exp $
SHA1 (cdrtools-2.01.01a13.tar.bz2) = c2f24a028caa71427d485ba0ef998d6604f1723a
RMD160 (cdrtools-2.01.01a13.tar.bz2) = 0e56bf328c9088c47fb13b46ba57042ba007fe46
Size (cdrtools-2.01.01a13.tar.bz2) = 1517254 bytes
SHA1 (patch-aa) = 9bcbe6e3831ddf21c1554224fcebc3befa3a6e2a
SHA1 (cdrtools-2.01.01a14.tar.bz2) = c4ef63ce77359553d0b5ef3c9f15b217ae1923b9
RMD160 (cdrtools-2.01.01a14.tar.bz2) = 41947498bd2008fe86a4f6cb07afe5c9a9aa64cd
Size (cdrtools-2.01.01a14.tar.bz2) = 1519548 bytes
SHA1 (patch-aa) = d7b47bff71ae493f24713880a9f9f2ef891b5870
SHA1 (patch-ac) = 91ff4512fa599cf8ff9e4f36ae0e3410f6b1dfaf
SHA1 (patch-ah) = 1b873744755d375c7fbc22d5628a65110439db5c
SHA1 (patch-ai) = 17c9a5fad16d601ab5b430cdd108633e916b4373
SHA1 (patch-aj) = 53c48db3bd3af362a33df67ea5ec03cc79a845d1
SHA1 (patch-ba) = 752c028c2c8a0fdab5d7bc5617bce24f5a60abd2
SHA1 (patch-bb) = 528abe11c5a01615b4dbcd7304b39374f8d3c255
SHA1 (patch-bb) = e2d61535a75c11619ad59f940140b0adeaae6259
SHA1 (patch-ca) = c21c63b54398cd341e2784050f8ab96c795904a1
SHA1 (patch-cb) = c4cbb47f1a0cdc4bb87a4659337afd7306bbb869
SHA1 (patch-cc) = f1d45bf3a6bb71785cc46b325fe51d05179db6c7
SHA1 (patch-cd) = 6a15855bca936b75e5e6fceca4c54c1ef71ebaf7
SHA1 (patch-cd) = dd611d2f2c24e27d324d418205bf104175b6b020
SHA1 (patch-ce) = d1fd02987b095383266a29f16a24818e67a37820
SHA1 (patch-cf) = 50855c214fb718594837001e57fa0cdebb9b5cf0
SHA1 (patch-cg) = 686ac754c463ce37d15be19dcb8048741d8546f2
SHA1 (patch-cf) = d7e0f67445d1946dc85c826256e45c154dd8ef57
SHA1 (patch-cg) = c9713821415e0f8551bb41740b3306b20d38e1bb
SHA1 (patch-ci) = fca9bcc4d4a7480cea9c9f6011f72afdf691a9ef

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.1 2006/09/10 17:48:11 thomasklausner Exp $
$NetBSD: patch-aa,v 1.2 2006/09/14 23:12:23 thomasklausner Exp $
--- mkisofs/Makefile.orig 2006-09-08 09:07:51.000000000 +0000
--- mkisofs/Makefile.orig 2006-09-10 18:50:53.000000000 +0000
+++ mkisofs/Makefile
@@ -51,7 +51,7 @@ HFILES= apple.h bootinfo.h config.h def
ifo_read.h dvd_file.h dvd_reader.h bswap.h ifo_types.h \
@@ -52,7 +52,7 @@ HFILES= apple.h bootinfo.h config.h def
../cdrecord/defaults.h
-LIBS= -lhfs -lfile -lunls -lrscg -lscg $(LIB_VOLMGT) -ldeflt -lfind -lschily $(SCSILIB) $(LIB_SOCKET)
+LIBS= -lhfs -lfile -lunls -lrscg -lscg $(LIB_VOLMGT) -ldeflt -lfind -lschily $(SCSILIB) $(LIB_SOCKET) -lintl
LIBS= -lhfs -lfile -lunls -lrscg -lscg $(LIB_VOLMGT) -ldeflt -lfind -lschily \
- $(LIB_ACL) $(SCSILIB) $(LIB_SOCKET)
+ $(LIB_ACL) $(SCSILIB) $(LIB_SOCKET) -lintl
XMK_FILE= Makefile.man hybridman.mk
###########################################################################

View file

@ -1,8 +1,8 @@
$NetBSD: patch-bb,v 1.1.1.1 2006/01/31 17:31:43 thomasklausner Exp $
$NetBSD: patch-bb,v 1.2 2006/09/14 23:12:23 thomasklausner Exp $
--- mkisofs/mkisofs.c.orig 2006-01-12 00:29:46.000000000 +0000
--- mkisofs/mkisofs.c.orig 2006-09-12 09:44:33.000000000 +0000
+++ mkisofs/mkisofs.c
@@ -2412,12 +2412,12 @@ parse_input_files:
@@ -2163,12 +2163,12 @@ args_ok:
}
}
/* We don't need root privilleges anymore. */

View file

@ -1,8 +1,8 @@
$NetBSD: patch-cd,v 1.2 2006/05/16 17:08:36 thomasklausner Exp $
$NetBSD: patch-cd,v 1.3 2006/09/14 23:12:23 thomasklausner Exp $
--- include/schily.h.orig 2006-01-11 23:26:07.000000000 +0000
--- include/schily.h.orig 2006-06-27 09:16:46.000000000 +0000
+++ include/schily.h
@@ -112,7 +112,7 @@ extern int fspawnl __PR((FILE *, FILE *,
@@ -115,7 +115,7 @@ extern int fspawnl __PR((FILE *, FILE *,
extern int fspawnv_nowait __PR((FILE *, FILE *, FILE *,
const char *, int, char *const*));
extern int fgetline __PR((FILE *, char *, int));

View file

@ -1,8 +1,8 @@
$NetBSD: patch-cf,v 1.1.1.1 2006/01/31 17:31:43 thomasklausner Exp $
$NetBSD: patch-cf,v 1.2 2006/09/14 23:12:23 thomasklausner Exp $
--- mkisofs/tree.c.orig 2004-06-12 13:16:37.000000000 +0000
--- mkisofs/tree.c.orig 2006-09-08 09:13:14.000000000 +0000
+++ mkisofs/tree.c
@@ -1577,7 +1577,7 @@ insert_file_entry(this_dir, whole_path,
@@ -1598,7 +1598,7 @@ insert_file_entry(this_dir, whole_path,
/*
* >= is required by the large file summit standard.
*/

View file

@ -1,8 +1,8 @@
$NetBSD: patch-cg,v 1.1.1.1 2006/01/31 17:31:43 thomasklausner Exp $
$NetBSD: patch-cg,v 1.2 2006/09/14 23:12:23 thomasklausner Exp $
--- mkisofs/write.c.orig 2005-08-07 14:50:48.000000000 +0000
--- mkisofs/write.c.orig 2006-09-10 18:03:27.000000000 +0000
+++ mkisofs/write.c
@@ -463,7 +463,7 @@ write_one_file(filename, size, outfile)
@@ -469,7 +469,7 @@ write_one_file(filename, size, outfile)
static char buffer[SECTOR_SIZE * NSECT];
FILE *infile;
off_t remain;
@ -11,7 +11,7 @@ $NetBSD: patch-cg,v 1.1.1.1 2006/01/31 17:31:43 thomasklausner Exp $
if ((infile = fopen(filename, "rb")) == NULL) {
@@ -554,7 +554,10 @@ static char buffer[SECTOR_SIZE * NSECT]
@@ -560,7 +560,10 @@ static char buffer[SECTOR_SIZE * NSECT]
fflush(stderr);
}
#endif