Fix build after x11/openmotif upgrade.
This commit is contained in:
parent
c64259a51d
commit
323108f15c
4 changed files with 33 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.51 2011/10/30 18:56:10 noud4 Exp $
|
||||
# $NetBSD: Makefile,v 1.52 2012/04/21 15:33:37 ftigeot Exp $
|
||||
|
||||
.include "../../wip/jdk16/Makefile.common"
|
||||
|
||||
|
@ -198,6 +198,7 @@ do-install:
|
|||
# ${DESTDIR}${JAVA_HOME}/jre/javaws/cacerts
|
||||
|
||||
.include "../../mk/java-env.mk"
|
||||
.include "../../x11/libXft/buildlink3.mk"
|
||||
.include "../../x11/libXi/buildlink3.mk"
|
||||
.include "../../x11/libXtst/buildlink3.mk"
|
||||
.include "../../x11/xextproto/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.29 2011/07/21 19:15:31 ftigeot Exp $
|
||||
$NetBSD: distinfo,v 1.30 2012/04/21 15:33:37 ftigeot Exp $
|
||||
|
||||
SHA1 (bsd-jdk15-patches-9.tar.bz2) = 410de93e19d15a1f45b825b9751b0482b70bdf7f
|
||||
RMD160 (bsd-jdk15-patches-9.tar.bz2) = ff8cc31c3735b33ec8072e6764fd165a775f1fe6
|
||||
|
@ -44,5 +44,7 @@ SHA1 (patch-bm) = 79f011e4c2196efdbc59ee682df476cc9ee3a926
|
|||
SHA1 (patch-bn) = 6f2610391ab33b675e7560aa651d94110b29216c
|
||||
SHA1 (patch-hotspot_src_share_vm_adlc_adlc.hpp) = bc68d5bc27c28ed2b47498afc134b3418161c984
|
||||
SHA1 (patch-hotspot_src_share_vm_adlc_filebuff.hpp) = 50e232123bb114411e47f8a5595e0a6e243d7d5f
|
||||
SHA1 (patch-j2se_make_sun_awt_mawt.gmk) = b42d7230f1a8d12ce025f1c9ce65bfa7e0891550
|
||||
SHA1 (patch-j2se_make_sun_javac_recompile_library_Makefile) = 76b56626213195d2e9a1722d793711b2516f6052
|
||||
SHA1 (patch-j2se_make_sun_motif21_Makefile) = 3aca20acaca3933baee7469ef5b52df065658d66
|
||||
SHA1 (patch-j2se_src_share_classes_java_lang_ClassLoader_java) = 71c7cb8cbfc0cbb7d1f8eb00d73cd570bedc7d11
|
||||
|
|
13
jdk15/patches/patch-j2se_make_sun_awt_mawt.gmk
Normal file
13
jdk15/patches/patch-j2se_make_sun_awt_mawt.gmk
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-j2se_make_sun_awt_mawt.gmk,v 1.1 2012/04/21 15:33:38 ftigeot Exp $
|
||||
|
||||
--- j2se/make/sun/awt/mawt.gmk.orig 2012-04-21 08:24:01.973634000 +0000
|
||||
+++ j2se/make/sun/awt/mawt.gmk
|
||||
@@ -236,7 +236,7 @@ CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGD
|
||||
$(EVENT_MODEL)
|
||||
|
||||
ifeq ($(LINUX_OR_BSD), true)
|
||||
- X11DIR ?= /usr/X11R6
|
||||
+ X11DIR ?= $(X11BASE)
|
||||
LOCALDIR ?= /usr/local
|
||||
CPPFLAGS += -I$(X11DIR)/include -I$(X11DIR)/include/X11/extensions \
|
||||
-DX11DIR=\"$(X11DIR)\" -DLOCALDIR=\"$(LOCALDIR)\"
|
15
jdk15/patches/patch-j2se_make_sun_motif21_Makefile
Normal file
15
jdk15/patches/patch-j2se_make_sun_motif21_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-j2se_make_sun_motif21_Makefile,v 1.1 2012/04/21 15:33:38 ftigeot Exp $
|
||||
|
||||
--- j2se/make/sun/motif21/Makefile.orig 2008-05-28 07:06:43.000000000 +0000
|
||||
+++ j2se/make/sun/motif21/Makefile
|
||||
@@ -19,6 +19,10 @@ include $(BUILDDIR)/common/Defs.gmk
|
||||
|
||||
ifdef BUILD_MOTIF21
|
||||
include $(BUILDDIR)/sun/awt/mawt.gmk
|
||||
+
|
||||
+ ifeq ($(PLATFORM), bsd)
|
||||
+ OTHER_INCLUDES += -I$(X11DIR)/include/freetype2
|
||||
+ endif
|
||||
else
|
||||
all optimized debug clean clobber ::
|
||||
# do nothing case if older OS and new motif 2.1 not found in the boot dir
|
Loading…
Reference in a new issue