Version 0.17 - March 2015

* Upgraded to OCCT 6.8.0
* Build system changes
  - Remove OCE_DISABLE_BSPLINE_MESHER option, OCCT improved meshing
    in recent releases.

Version 0.16.1 - November 2014
* cppcheck fixes (memory leaks and parse errors)
* Fix LDOMBasicString assignment operator
* Mingw fixes (OpenGl compilation)
* Fix build failures with Mesa 10.3.1

Version 0.16 - July 2014
* Upgraded to OCCT 6.7.1
* Fix a numerical bug in ApproxAFunc2Var due to compiler optimization.
* Speed improvements in BOPTools_AlgoTools2D.
* Many bug and warning fixes detected by static analysis and compilers.
* Force 8 byte alignment in NCollection_IncAllocator to fix bus errors
  reported on RISC architectures.
* Build system improvements and additions
  - Readd OCE_DISABLE_TKSERVICE_FONT option, a solution has been found
    to build TKService without freetype.
  - Fix Standard_Construction_Error exception in BOP
  - Fix RPATH issues reported on openSUSE
  - Fix gl2ps libraries installation
  - Build improvements and fixes with Mingw
  - Fix compatibility with CMake 3.0
  - Enable support for OpenCL
  - New OCE_COPY_HEADERS_BUILD option to copy header files when building,
    to get rid of the long list of include directories on command line
This commit is contained in:
Filip Hajny 2015-06-25 12:41:09 +00:00 committed by Thomas Klausner
parent 64f097da71
commit 323cbd403a
11 changed files with 405 additions and 1775 deletions

View file

@ -1,26 +1,34 @@
# $NetBSD: Makefile,v 1.1 2014/05/30 11:21:00 fhajny Exp $
# $NetBSD: Makefile,v 1.2 2015/06/25 12:41:09 fhajny Exp $
DISTNAME= OCE-0.15
DISTNAME= OCE-0.17
PKGNAME= ${DISTNAME:tl}
CATEGORIES= cad
MASTER_SITES= https://github.com/tpaviot/oce/archive/
MASTER_SITES= ${MASTER_SITE_GITHUB:=tpaviot/}
MAINTAINER= filip@joyent.com
HOMEPAGE= http://github.com/tpaviot/oce/
COMMENT= Open CASCADE Community Edition
LICENSE= gnu-lgpl-v2.1
GITHUB_TAG= ${DISTNAME}
WRKSRC= ${WRKDIR}/oce-${DISTNAME}
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
CHECK_PORTABILITY_SKIP+= samples/qt/*
# mk/configure/cmake.mk disable rpath handling
# but we need it for a lib subpath
LDFLAGS+= ${COMPILER_RPATH_FLAG}${PREFIX}/lib/oce
CMAKE_ARGS+= -DOCE_INSTALL_PREFIX:PATH=${PREFIX}
##MAKE_FLAGS+= VERBOSE=1
LIBS.SunOS+= -lresolv
.include "options.mk"
.include "../../mk/bsd.pkg.mk"

2038
oce/PLIST

File diff suppressed because it is too large Load diff

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2014/05/30 11:21:00 fhajny Exp $
# $NetBSD: buildlink3.mk,v 1.2 2015/06/25 12:41:09 fhajny Exp $
BUILDLINK_TREE+= oce
.if !defined(OCE_BUILDLINK3_MK)
OCE_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.oce+= oce>=0.15
BUILDLINK_API_DEPENDS.oce+= oce>=0.17
BUILDLINK_PKGSRCDIR.oce?= ../../wip/oce
.if !empty(PKG_OPTIONS:Mx11)

View file

@ -1,10 +1,12 @@
$NetBSD: distinfo,v 1.1 2014/05/30 11:21:00 fhajny Exp $
$NetBSD: distinfo,v 1.2 2015/06/25 12:41:09 fhajny Exp $
SHA1 (OCE-0.15.tar.gz) = 3036ca47202bdffdef79a65c314a446424ac47f1
RMD160 (OCE-0.15.tar.gz) = be53cced4d5463d466fd17c3f721ae56fb89e32b
Size (OCE-0.15.tar.gz) = 24341270 bytes
SHA1 (OCE-0.17.tar.gz) = 4d5a7fd6e074e2a3c56e083b82fc0bb1aff1c998
RMD160 (OCE-0.17.tar.gz) = 5580bf57b6534a31809644a673ddb7008a001c1b
Size (OCE-0.17.tar.gz) = 24382694 bytes
SHA1 (patch-CMakeLists.txt) = 35c51b9a3f9620bb1caa121cc2fd251daab2dccc
SHA1 (patch-src_OSD_OSD__signal.cxx) = 1138a73e280f30edefdb532ec81e09865da781a2
SHA1 (patch-src_OpenGl_OpenGl__Context.hxx) = f603b285d5790ceebd7c3bf3f48697c3e24ffa0b
SHA1 (patch-src_Standard_Standard__CLocaleSentry.hxx) = 50e5bb748d23eb7e913d40e3c43dd4b50d8ace4a
SHA1 (patch-adm_cmake_TKernel_CMakeLists.txt) = 40752a95ba115a4869c6ff4c3ef906d70a34ff43
SHA1 (patch-src_MeshVS_MeshVS__MeshPrsBuilder.cxx) = d3974c716e7243f667ad3e026320dadd70c47db7
SHA1 (patch-src_OSD_OSD__signal.cxx) = 74f1291aae6872543a52b3202fa90432f6d328c6
SHA1 (patch-src_OpenGl_OpenGl__Context.hxx) = f5654287a239c8885923f36f0a34699788b0fdad
SHA1 (patch-src_Standard_Standard__Mutex.hxx) = ffea6f4a7a4b01663f71643276f9f94a94a5ab70
SHA1 (patch-src_Standard_Standard__PrimitiveTypes.hxx) = 791ad1d8120c43aadb3e321c72bf217dc1057e58

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.1 2014/05/30 11:21:00 fhajny Exp $
# $NetBSD: options.mk,v 1.2 2015/06/25 12:41:09 fhajny Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.oce
PKG_SUPPORTED_OPTIONS= draw x11
@ -6,11 +6,11 @@ PKG_SUGGESTED_OPTIONS= x11
.include "../../mk/bsd.options.mk"
PLIST_VARS+= draw x11
PLIST_SRC= ${PLIST_SRC_DFLT}
.if !empty(PKG_OPTIONS:Mx11)
CMAKE_ARGS+= -DFREETYPE_INCLUDE_DIRS:PATH=${BUILDLINK_PREFIX.freetype2}/include
PLIST.x11= yes
PLIST_SRC+= ${PKGDIR}/PLIST.x11
. include "../../graphics/Mesa/buildlink3.mk"
. include "../../graphics/freetype2/buildlink3.mk"
.else
@ -20,7 +20,7 @@ CMAKE_ARGS+= -DOCE_DISABLE_X11=ON
.if !empty(PKG_OPTIONS:Mdraw)
. if !empty(PKG_OPTIONS:Mx11)
CMAKE_ARGS+= -DOCE_DRAW:BOOL=ON
PLIST.draw= yes
PLIST_SRC+= ${PKGDIR}/PLIST.draw
. include "../../lang/tcl/buildlink3.mk"
. include "../../x11/tk/buildlink3.mk"
. else

View file

@ -0,0 +1,15 @@
$NetBSD: patch-adm_cmake_TKernel_CMakeLists.txt,v 1.1 2015/06/25 12:41:09 fhajny Exp $
SunOS needs libresolv here.
--- adm/cmake/TKernel/CMakeLists.txt.orig 2014-11-30 05:46:16.000000000 +0000
+++ adm/cmake/TKernel/CMakeLists.txt
@@ -41,6 +41,9 @@ else(WIN32)
set(TOOLKIT_LIBS ${TOOLKIT_LIBS} rt)
endif(NOT CLOCK_GETTIME_IN_LIBC)
endif(NOT APPLE)
+ if(CMAKE_SYSTEM_NAME STREQUAL SunOS)
+ set(TOOLKIT_LIBS ${TOOLKIT_LIBS} resolv)
+ endif(CMAKE_SYSTEM_NAME)
endif(WIN32)
# Adde-DHAVE_TBB in TKernel in order to benefit from Standard_MMgrTBBalloc

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_MeshVS_MeshVS__MeshPrsBuilder.cxx,v 1.1 2015/06/25 12:41:09 fhajny Exp $
SunOS needs alloca.h.
--- src/MeshVS/MeshVS_MeshPrsBuilder.cxx.orig 2015-03-08 22:19:42.000000000 +0000
+++ src/MeshVS/MeshVS_MeshPrsBuilder.cxx
@@ -56,6 +56,10 @@
#include <NCollection_Map.hxx>
#include <NCollection_Vector.hxx>
+#if defined(__sun)
+#include <alloca.h>
+#endif
+
//================================================================
// Function : Constructor MeshVS_MeshPrsBuilder
// Purpose :

View file

@ -1,9 +1,28 @@
$NetBSD: patch-src_OSD_OSD__signal.cxx,v 1.1 2014/05/30 11:21:00 fhajny Exp $
$NetBSD: patch-src_OSD_OSD__signal.cxx,v 1.2 2015/06/25 12:41:09 fhajny Exp $
Define SIGFPE macros on SunOS.
Respect the reality as CMake found it, there might not be libsunmath.
--- src/OSD/OSD_signal.cxx.orig 2014-02-12 20:06:33.000000000 +0000
--- src/OSD/OSD_signal.cxx.orig 2015-03-08 22:19:42.000000000 +0000
+++ src/OSD/OSD_signal.cxx
@@ -422,7 +422,7 @@ void OSD::SetSignal(const Standard_Boole
@@ -55,6 +55,17 @@ ACT_SIGIO_HANDLER *ADR_ACT_SIGIO_HANDLER
typedef void (* SIG_PFV) (int);
#endif
+#if defined(__sun)
+# include <sys/siginfo.h>
+# define FPE_FLTDIV_TRAP FPE_FLTDIV
+# define FPE_INTDIV_TRAP FPE_INTDIV
+# define FPE_FLTOVF_TRAP FPE_FLTOVF
+# define FPE_INTOVF_TRAP FPE_INTOVF
+# define FPE_FLTUND_TRAP FPE_FLTUND
+# define FPE_FLTRES_TRAP FPE_FLTRES
+# define FPE_FLTINV_TRAP FPE_FLTINV
+#endif
+
#ifdef __GNUC__
# include <stdlib.h>
# include <stdio.h>
@@ -379,7 +390,7 @@ void OSD::SetSignal(const Standard_Boole
if( aFloatingSignal ) {
//==== Enable the floating point exceptions ===============

View file

@ -1,16 +1,16 @@
$NetBSD: patch-src_OpenGl_OpenGl__Context.hxx,v 1.1 2014/05/30 11:21:00 fhajny Exp $
$NetBSD: patch-src_OpenGl_OpenGl__Context.hxx,v 1.2 2015/06/25 12:41:09 fhajny Exp $
We need alloca.h.
--- src/OpenGl/OpenGl_Context.hxx.orig 2014-02-12 20:06:33.000000000 +0000
--- src/OpenGl/OpenGl_Context.hxx.orig 2015-03-08 22:19:42.000000000 +0000
+++ src/OpenGl/OpenGl_Context.hxx
@@ -34,6 +34,10 @@
#include <Handle_OpenGl_Context.hxx>
#include <OpenGl_Clipping.hxx>
@@ -39,6 +39,10 @@
#include <OpenGl_GlCore11.hxx>
#include <OpenGl_Utils.hxx>
+#if defined(__sun)
+#if defined(__sun)
+#include <alloca.h>
+#endif
+
//! Forward declarations
struct OpenGl_GlCore12;
struct OpenGl_GlCore13;
struct OpenGl_GlFunctions;
struct OpenGl_ArbTBO;

View file

@ -1,14 +0,0 @@
$NetBSD: patch-src_Standard_Standard__CLocaleSentry.hxx,v 1.1 2014/05/30 11:21:00 fhajny Exp $
SunOS just doesn't have xlocale.h.
--- src/Standard/Standard_CLocaleSentry.hxx.orig 2014-02-12 20:06:33.000000000 +0000
+++ src/Standard/Standard_CLocaleSentry.hxx
@@ -25,7 +25,7 @@
//! Notice that this is impossible to test (_POSIX_C_SOURCE >= 200809L)
//! since POSIX didn't declared such identifier.
//! We check _GNU_SOURCE for glibc extensions here and it is always defined by g++ compiler.
-#if defined(__APPLE__) || defined(_GNU_SOURCE) || defined(HAVE_XLOCALE_H)
+#if defined(__APPLE__) || (defined(_GNU_SOURCE) && !defined(__sun)) || defined(HAVE_XLOCALE_H)
#include <xlocale.h>
#ifndef HAVE_XLOCALE_H
#define HAVE_XLOCALE_H

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_Standard_Standard__Mutex.hxx,v 1.1 2015/06/25 12:41:09 fhajny Exp $
Portability.
--- src/Standard/Standard_Mutex.hxx.orig 2015-03-08 22:19:42.000000000 +0000
+++ src/Standard/Standard_Mutex.hxx
@@ -24,7 +24,7 @@
#include <windows.h>
#else
#include <pthread.h>
- #include <sys/errno.h>
+ #include <errno.h>
#include <unistd.h>
#include <time.h>
#endif