Remove OdfConverter, imported into pkgsrc/textproc.

This commit is contained in:
Thomas Klausner 2009-04-14 18:34:36 +00:00
parent 1470867796
commit 338fae5df9
6 changed files with 1 additions and 87 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.3371 2009/04/13 22:11:32 pettai Exp $
# $Id: Makefile,v 1.3372 2009/04/14 18:34:36 thomasklausner Exp $
#
COMMENT= WIP pkgsrc packages
@ -20,7 +20,6 @@ SUBDIR+= InfoNES
SUBDIR+= LabPlot
SUBDIR+= Lucu
SUBDIR+= MissingH
SUBDIR+= OdfConverter
SUBDIR+= OpenGLUT
SUBDIR+= PPower4
SUBDIR+= PyBabelFish

View file

@ -1,18 +0,0 @@
The goal for this project is to provide translators to allow for
interoperability between applications based on ODF (OpenDocument)
1.0 standards and Microsoft OpenXML based Office applications. As
a part of this interoperability initiative, add-ins are being
developed that can be installed on top of Microsoft Office Word
(document processing), Excel (spreadsheet) and PowerPoint (presentation)
applications (Office 2007 / 2003 / XP version) to allow for opening
and saving OpenDocument format / ODF files (.odt, .ods and .odp)
that adheres to ODF 1.0 specifications. We also provide command
line translator utilities that allow doing batch conversions.
The converter is based on XSL transformations between two XML
formats, along with some pre- and post-processing to manage the
packaging (zip / unzip), schema incompatibility processings and
the integration into Microsoft Office applications like Word, Excel
and PowerPoint. We chose to use an Open Source development model
that allows developers from all around the world to participate &
contribute to the project.

View file

@ -1,41 +0,0 @@
# $NetBSD: Makefile,v 1.3 2009/04/13 08:20:59 thomasklausner Exp $
#
DISTNAME= OdfConverter--src-1.1
PKGNAME= OdfConverter-1.1
CATEGORIES= converters textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=odf-converter/}
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://odf-converter.sourceforge.net/
COMMENT= Converter between Microsoft Office 2007 and OpenOffice formats
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c
USE_TOOLS+= gmake pkg-config
BUILD_DIRS= source/Common/OdfZipUtils
BUILD_DIRS+= source/Common/OdfConverterLib
BUILD_DIRS+= source/Word/Converter
BUILD_DIRS+= source/Presentation/Converter
BUILD_DIRS+= source/Spreadsheet/Converter
BUILD_DIRS+= source/AdditionalTools/zlib123/contrib/minizip
BUILD_DIRS+= source/Shell/OdfConverterTest
MAKE_JOBS_SAFE= no
INSTALLATION_DIRS= bin share/doc/OdfConverter
post-extract:
cd ${WRKDIR} && mv "Copy of 4thMarch" ${DISTNAME:Q}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/source/Shell/OdfConverterTest/OdfConverter \
${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/source/Shell/OdfConverterTest/README.TXT \
${DESTDIR}${PREFIX}/share/doc/OdfConverter
.include "../../lang/mono/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/04/12 07:55:00 thomasklausner Exp $
bin/OdfConverter
share/doc/OdfConverter/README.TXT
@dirrm share/doc/OdfConverter

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2008/04/12 07:55:00 thomasklausner Exp $
SHA1 (OdfConverter--src-1.1.zip) = 7254502a15024a668a2c6d788a4ff4cc7cf4523e
RMD160 (OdfConverter--src-1.1.zip) = 57b10317453bd9a84cc787c9cb600844c88f7696
Size (OdfConverter--src-1.1.zip) = 46541334 bytes
SHA1 (patch-aa) = e880c861a9c7d0968ac10899c80c8bd05fa601f6

View file

@ -1,16 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/04/12 07:55:00 thomasklausner Exp $
--- source/Shell/OdfConverterTest/Makefile.orig 2007-12-19 15:16:04.000000000 +0100
+++ source/Shell/OdfConverterTest/Makefile
@@ -71,9 +71,9 @@ else
bundle.o \
$(EXPORTDYNAMIC) \
-Wl,--undefined=$(ZIPOPEN) -Wl,--undefined=$(UNZOPEN) \
- `pkg-config --libs-only-L mono` -L../../AdditionalTools/zlib123/contrib/minizip \
+ -L../../AdditionalTools/zlib123/contrib/minizip \
-Wl,-Bstatic -lmono -lzlibwapi -Wl,-Bdynamic \
- `pkg-config --libs-only-l mono | sed -e "s/\-lmono //"` \
+ `pkg-config --libs mono | sed -e "s/\-lmono //"` \
$(ZLIB) $(OTHERLIBS)
endif
ifeq ($(OS),Cygwin)