make this build with current pyqt/sip
(mostly http://websvn.kde.org/?view=rev&revision=959021)
This commit is contained in:
parent
fef651a8f2
commit
33b6535a4a
11 changed files with 135 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2009/02/11 22:55:20 mwdavies Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2009/06/17 17:33:19 drochner Exp $
|
||||
|
||||
PKGNAME= kdebindings4-python-${_KDE_VERSION}
|
||||
DISTNAME= kdebindings-${_KDE_VERSION}
|
||||
|
@ -24,6 +24,7 @@ PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX:Q}
|
|||
|
||||
.include "../../wip/kde4/kde4.mk"
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../wip/kdelibs4/buildlink3.mk"
|
||||
.include "../../wip/kdepimlibs4/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,16 @@
|
|||
$NetBSD: distinfo,v 1.7 2009/06/05 22:27:07 mwdavies Exp $
|
||||
$NetBSD: distinfo,v 1.8 2009/06/17 17:33:19 drochner Exp $
|
||||
|
||||
SHA1 (kdebindings-4.2.4.tar.bz2) = 5550b690d1c63fc63b3603ad73ba2b911158fe96
|
||||
RMD160 (kdebindings-4.2.4.tar.bz2) = 9ff4daaa52e14b109e5cab31321c861ebf86f282
|
||||
Size (kdebindings-4.2.4.tar.bz2) = 4736120 bytes
|
||||
SHA1 (patch-aa) = f01b1d350a8e79e639f46c797baf035684275158
|
||||
SHA1 (patch-ab) = cae51d216ad914009b4e9c80a17a172ec5a5eaec
|
||||
SHA1 (patch-ba) = 55c822d06f712647323810a08668748019cffc33
|
||||
SHA1 (patch-bb) = 5d84f3815a471505f5e411b38d2cf8bc2275948a
|
||||
SHA1 (patch-bc) = 3985c78a531574d953927747cb7cc22dc21463ee
|
||||
SHA1 (patch-bd) = 3f6f1c9e2509e62d9affb9f48e0b2030dd421c34
|
||||
SHA1 (patch-be) = dda53f69a7916424ffd791b25a5d19ea9eef2f67
|
||||
SHA1 (patch-bf) = ec6c3eed3dabd75a02b801dcd8e15938275f574a
|
||||
SHA1 (patch-bg) = 5e4f1249d97fc0f514f66601c4306df554ca5d48
|
||||
SHA1 (patch-bh) = 968e47a34dc99643f9d5abf27d022ef865360933
|
||||
SHA1 (patch-bi) = 57a2a63fbe7f95118c892a989aa0b27e6375d3c5
|
||||
|
|
13
kdebindings4-python/patches/patch-ba
Normal file
13
kdebindings4-python/patches/patch-ba
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ba,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/akonadi/messagethreadingattribute.sip.orig 2009-06-17 17:00:15.000000000 +0200
|
||||
+++ python/pykde4/sip/akonadi/messagethreadingattribute.sip
|
||||
@@ -30,7 +30,7 @@ class MessageThreadingAttribute : Akonad
|
||||
|
||||
public:
|
||||
MessageThreadingAttribute ();
|
||||
- MessageThreadingAttribute (const Akonadi::MessageThreadingAttribute& other);
|
||||
+// MessageThreadingAttribute (const Akonadi::MessageThreadingAttribute& other);
|
||||
QList<Akonadi::Entity::Id> perfectParents () const;
|
||||
void setPerfectParents (const QList<Akonadi::Entity::Id>& parents);
|
||||
QList<Akonadi::Entity::Id> unperfectParents () const;
|
13
kdebindings4-python/patches/patch-bb
Normal file
13
kdebindings4-python/patches/patch-bb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bb,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/dnssd/servicebase.sip.orig 2009-06-17 17:02:04.000000000 +0200
|
||||
+++ python/pykde4/sip/dnssd/servicebase.sip
|
||||
@@ -27,7 +27,7 @@ class ServiceBase : KShared
|
||||
%End
|
||||
|
||||
public:
|
||||
- typedef KSharedPtr<DNSSD::ServiceBase> Ptr;
|
||||
+// typedef KSharedPtr<DNSSD::ServiceBase> Ptr;
|
||||
|
||||
explicit ServiceBase (const QString& name = QString(), const QString& type = QString(), const QString& domain = QString(), const QString& host = QString(), unsigned short port = 0);
|
||||
QString serviceName () const;
|
17
kdebindings4-python/patches/patch-bc
Normal file
17
kdebindings4-python/patches/patch-bc
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-bc,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/kdecore/kptydevice.sip.orig 2008-07-08 11:27:48.000000000 +0200
|
||||
+++ python/pykde4/sip/kdecore/kptydevice.sip
|
||||
@@ -46,9 +46,9 @@ signals:
|
||||
void readEof ();
|
||||
|
||||
protected:
|
||||
- virtual qint64 readData (char*, qint64);
|
||||
- virtual qint64 readLineData (char*, qint64);
|
||||
- virtual qint64 writeData (const char*, qint64);
|
||||
+// virtual qint64 readData (char*, qint64);
|
||||
+// virtual qint64 readLineData (char*, qint64);
|
||||
+// virtual qint64 writeData (const char*, qint64);
|
||||
|
||||
}; // class KPtyDevice
|
||||
|
13
kdebindings4-python/patches/patch-bd
Normal file
13
kdebindings4-python/patches/patch-bd
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bd,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/kdecore/typedefs.sip.orig 2009-06-17 17:04:08.000000000 +0200
|
||||
+++ python/pykde4/sip/kdecore/typedefs.sip
|
||||
@@ -244,7 +244,7 @@ template <TYPE>
|
||||
return PyInstance_Check(sipPy);
|
||||
|
||||
int iserr = 0;
|
||||
- TYPE *cpp = (TYPE *)sipForceConvertTo_TYPE (sipPy, &iserr);
|
||||
+ TYPE *cpp = (TYPE *)sipForceConvertToInstance(sipPy, sipClass_TYPE, NULL, 0, NULL, &iserr);
|
||||
|
||||
if (iserr)
|
||||
{
|
15
kdebindings4-python/patches/patch-be
Normal file
15
kdebindings4-python/patches/patch-be
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-be,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/kio/global.sip.orig 2009-06-17 17:06:12.000000000 +0200
|
||||
+++ python/pykde4/sip/kio/global.sip
|
||||
@@ -243,8 +243,8 @@ KJobTrackerInterface* getJobTracker ()
|
||||
{
|
||||
int iserr = 0;
|
||||
|
||||
- acpp = (QString *)sipForceConvertTo_QString (aelem, &iserr);
|
||||
- bcpp = (QString *)sipForceConvertTo_QString (belem, &iserr);
|
||||
+ acpp = (QString *)sipForceConvertToInstance(aelem, sipClass_QString, NULL, 0, NULL, &iserr);
|
||||
+ bcpp = (QString *)sipForceConvertToInstance(belem, sipClass_QString, NULL, 0, NULL, &iserr);
|
||||
|
||||
if (iserr)
|
||||
{
|
13
kdebindings4-python/patches/patch-bf
Normal file
13
kdebindings4-python/patches/patch-bf
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bf,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/kio/kacl.sip.orig 2009-06-17 17:11:01.000000000 +0200
|
||||
+++ python/pykde4/sip/kio/kacl.sip
|
||||
@@ -144,7 +144,7 @@ typedef ACLUserPermissionsList ACLGroupP
|
||||
{
|
||||
PyObject *elem = PyList_GET_ITEM (sipPy, i);
|
||||
PyObject *pyp1 = PyTuple_GET_ITEM (elem, 0);
|
||||
- p1 = *(QString *)sipForceConvertTo_QString (pyp1, &iserr);
|
||||
+ p1 = *(QString *)sipForceConvertToInstance(pyp1, sipClass_QString, NULL, 0, NULL, &iserr);
|
||||
|
||||
if (iserr)
|
||||
{
|
13
kdebindings4-python/patches/patch-bg
Normal file
13
kdebindings4-python/patches/patch-bg
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bg,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/phonon/backendcapabilities.sip.orig 2009-06-17 17:12:31.000000000 +0200
|
||||
+++ python/pykde4/sip/phonon/backendcapabilities.sip
|
||||
@@ -26,7 +26,7 @@ namespace Phonon
|
||||
{
|
||||
namespace BackendCapabilities
|
||||
{
|
||||
-class Notifier : QObject /NoDefaultCtors,NoQMetaObject/
|
||||
+class Notifier : QObject /NoDefaultCtors,PyQt4NoQMetaObject/
|
||||
{
|
||||
|
||||
signals:
|
13
kdebindings4-python/patches/patch-bh
Normal file
13
kdebindings4-python/patches/patch-bh
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bh,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/plasma/abstractrunner.sip.orig 2009-06-17 17:13:32.000000000 +0200
|
||||
+++ python/pykde4/sip/plasma/abstractrunner.sip
|
||||
@@ -129,7 +129,7 @@ protected:
|
||||
void setHasRunOptions (bool hasRunOptions);
|
||||
void setSpeed (Plasma::AbstractRunner::Speed newSpeed);
|
||||
void setPriority (Plasma::AbstractRunner::Priority newPriority);
|
||||
- KService::List serviceQuery (const QString& serviceType, const QString& constraint = QString()) const;
|
||||
+// KService::List serviceQuery (const QString& serviceType, const QString& constraint = QString()) const;
|
||||
virtual QList<QAction*> actionsForMatch (const Plasma::QueryMatch& match);
|
||||
QAction* addAction (const QString& id, const QIcon& icon, const QString& text);
|
||||
void addAction (const QString& id, QAction* action);
|
13
kdebindings4-python/patches/patch-bi
Normal file
13
kdebindings4-python/patches/patch-bi
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-bi,v 1.1 2009/06/17 17:33:20 drochner Exp $
|
||||
|
||||
--- python/pykde4/sip/kparts/factory.sip.orig 2009-06-17 17:53:39.000000000 +0200
|
||||
+++ python/pykde4/sip/kparts/factory.sip
|
||||
@@ -37,7 +37,7 @@ public:
|
||||
|
||||
protected:
|
||||
virtual KParts::Part* createPartObject (QWidget* parentWidget = 0, QObject* parent /Transfer/ = 0, const char* classname = "KParts::Part", const QStringList& args = QStringList()) = 0;
|
||||
- virtual QObject* createObject (QObject* parent /Transfer/ = 0, const char* classname = "QObject", const QStringList& args = QStringList());
|
||||
+// virtual QObject* createObject (QObject* parent /Transfer/ = 0, const char* classname = "QObject", const QStringList& args = QStringList());
|
||||
}; // Factory
|
||||
|
||||
}; // KParts
|
Loading…
Reference in a new issue