Fix build a bit, until:
decoder.cc:(.text+0x83e): undefined reference to `pan::Mutex::mutex'
This commit is contained in:
parent
a52ef04dd3
commit
36edda71b3
3 changed files with 5 additions and 21 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2012/10/28 21:05:48 rhialto Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2013/01/22 22:12:45 thomasklausner Exp $
|
||||
|
||||
DISTNAME= pan2-git-2
|
||||
CATEGORIES= news
|
||||
|
@ -35,6 +35,8 @@ GNU_CONFIGURE= YES
|
|||
#CONFIGURE_ENV+= CXXFLAGS=-ggdb
|
||||
#CONFIGURE_ENV+= CFLAGS=-ggdb
|
||||
#CONFIGURE_ENV+= LDFLAGS=-ggdb
|
||||
CONFIGURE_ARGS+= ZLIB_CFLAGS=-I${BUILDLINK_PREFIX.zlib}/include
|
||||
CONFIGURE_ARGS+= ZLIB_LIBS="${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.zlib}/lib -L${BUILDLINK_PREFIX.zlib}/lib -lz"
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.if (${OPSYS} != "Darwin" && ${OPSYS} != "SunOS" && ${OPSYS} != "Linux")
|
||||
|
@ -46,6 +48,7 @@ BUILD_DEPENDS+= gnome-common>=3.6:../../devel/gnome-common
|
|||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mail/gmime24/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-gnutls
|
||||
.include "../../security/gnutls/buildlink3.mk" # optional
|
||||
|
|
|
@ -1,2 +1 @@
|
|||
$NetBSD: distinfo,v 1.2 2012/10/28 21:05:48 rhialto Exp $
|
||||
SHA1 (patch-pan_usenet-utils_mime-utils.cc) = 8e148bb2f67fccc0675ca529577eadbb6da333ca
|
||||
$NetBSD: distinfo,v 1.3 2013/01/22 22:12:46 thomasklausner Exp $
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-pan_usenet-utils_mime-utils.cc,v 1.1 2012/10/28 21:05:48 rhialto Exp $
|
||||
|
||||
Fix build with NetBSD's iconv().
|
||||
|
||||
--- pan/usenet-utils/mime-utils.cc.orig 2012-06-29 22:24:54.000000000 +0000
|
||||
+++ pan/usenet-utils/mime-utils.cc
|
||||
@@ -77,7 +77,11 @@ namespace pan
|
||||
outbuf = out + converted;
|
||||
outleft = outlen - converted;
|
||||
|
||||
+#if defined(__NetBSD__)
|
||||
+ converted = iconv (cd, &inbuf, &inleft, &outbuf, &outleft);
|
||||
+#else
|
||||
converted = iconv (cd, (char **) &inbuf, &inleft, &outbuf, &outleft);
|
||||
+#endif
|
||||
|
||||
if (converted != (size_t) -1 && errno == 0) {
|
||||
/*
|
Loading…
Reference in a new issue