scratch one item off the TODO list. While here update to 3.2.3 which
contains a crash fix.
This commit is contained in:
parent
b73ff52017
commit
38255953b5
5 changed files with 6 additions and 64 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.11 2014/12/19 22:10:31 tnn2 Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2015/03/05 22:50:47 tnn2 Exp $
|
||||
|
||||
DISTNAME= dbmail-3.2.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= dbmail-3.2.3
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.dbmail.org/download/3.2/
|
||||
|
||||
|
|
|
@ -1,10 +1,3 @@
|
|||
MD5 user authentication currently duesn't work on NetBSD
|
||||
because libmhash.so (security/mhash) pollutes the libc namespace which breaks
|
||||
crypt(3).
|
||||
|
||||
You can fix this by applying mhash.diff to pkgsrc/security/mhash/Makefile
|
||||
and reinstalling it.
|
||||
|
||||
The imap server sometimes gets wedged due to some libevent issue.
|
||||
Causing random file descriptor activity is enough to unwedge it.
|
||||
I keep a script running in the background for now:
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.11 2014/12/19 22:10:31 tnn2 Exp $
|
||||
$NetBSD: distinfo,v 1.12 2015/03/05 22:50:48 tnn2 Exp $
|
||||
|
||||
SHA1 (dbmail-3.2.1.tar.gz) = ebb68b64371347dd08143a3acd82870d13846f15
|
||||
RMD160 (dbmail-3.2.1.tar.gz) = e9e124c19de21c59ae88aa40365d42897a9fa865
|
||||
Size (dbmail-3.2.1.tar.gz) = 2425039 bytes
|
||||
SHA1 (dbmail-3.2.3.tar.gz) = f954675246c54d80ad667ab69af5915881db5b59
|
||||
RMD160 (dbmail-3.2.3.tar.gz) = 136d9ab8ffb1a6bfd720c9f56b230c6848968758
|
||||
Size (dbmail-3.2.3.tar.gz) = 2444227 bytes
|
||||
SHA1 (patch-aa) = a88c25d08cb8d5f786d41c4d9c5a3eb6d87a75fa
|
||||
SHA1 (patch-src_dm__db.c) = d67b98bfccc3e6ddd356cba7b17bee53293588e9
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
Index: Makefile
|
||||
===================================================================
|
||||
RCS file: /cvsroot/pkgsrc/security/mhash/Makefile,v
|
||||
retrieving revision 1.26
|
||||
diff -u -r1.26 Makefile
|
||||
--- Makefile 23 Oct 2012 18:16:36 -0000 1.26
|
||||
+++ Makefile 13 Mar 2013 21:28:59 -0000
|
||||
@@ -1,7 +1,7 @@
|
||||
# $NetBSD: mhash.diff,v 1.1 2013/03/13 21:33:00 tnn2 Exp $
|
||||
|
||||
DISTNAME= mhash-0.9.9
|
||||
-PKGREVISION= 3
|
||||
+PKGREVISION= 4
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=mhash/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
@@ -19,6 +19,17 @@
|
||||
|
||||
INSTALLATION_DIRS= include/mutils
|
||||
|
||||
+POLLUTING_SYMS= MD4Final MD4Init MD4Transform MD4Update \
|
||||
+ MD5Final MD5Init MD5Transform MD5Update
|
||||
+
|
||||
+SUBST_CLASSES+= ns
|
||||
+SUBST_STAGE.ns= pre-configure
|
||||
+SUBST_MESSAGE.ns= Prefixing symbols to avoid libc namespace pollution
|
||||
+SUBST_FILES.ns= lib/*.c lib/*.h src/*.c src/*.h
|
||||
+.for sym in ${POLLUTING_SYMS}
|
||||
+SUBST_SED.ns+= -e 's,\(${sym}\),mhash_\1,g'
|
||||
+.endfor
|
||||
+
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoconf -v -f
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_dm__db.c,v 1.1 2014/12/19 22:10:31 tnn2 Exp $
|
||||
|
||||
commit a0c2d6fe4684d3abde76d6428237feafdbe07ba9
|
||||
|
||||
--- src/dm_db.c.orig 2014-11-02 14:18:42.000000000 +0000
|
||||
+++ src/dm_db.c
|
||||
@@ -3695,6 +3695,8 @@ int db_user_validate(ClientBase_T *ci, c
|
||||
else
|
||||
is_validated = (strcmp(dbpass, password) == 0) ? 1 : 0;
|
||||
}
|
||||
+ else if (ci && ci->auth) // CRAM-MD5 auth but storage is encrypted
|
||||
+ is_validated = 0;
|
||||
|
||||
else if (SMATCH(encode, "crypt")) {
|
||||
TRACE(TRACE_DEBUG, "validating using crypt() encryption");
|
Loading…
Reference in a new issue