micro_httpd is a very small HTTP server. It runs from inetd, which means

its performance is poor. But for low-traffic sites, it's quite adequate.
It implements all the basic features of an HTTP server, including:

 *  Security against ".." filename snooping.
 *  The common MIME types.
 *  Trailing-slash redirection.
 *  index.html
 *  Directory listings.

All in 150 lines of code.
This commit is contained in:
Bruce J.A. Nourish 2004-01-07 23:46:24 +00:00 committed by Thomas Klausner
parent 4c70df7008
commit 388af0caeb
5 changed files with 50 additions and 0 deletions

11
micro_httpd/DESCR Normal file
View file

@ -0,0 +1,11 @@
micro_httpd is a very small HTTP server. It runs from inetd, which means
its performance is poor. But for low-traffic sites, it's quite adequate.
It implements all the basic features of an HTTP server, including:
* Security against ".." filename snooping.
* The common MIME types.
* Trailing-slash redirection.
* index.html
* Directory listings.
All in 150 lines of code.

13
micro_httpd/Makefile Normal file
View file

@ -0,0 +1,13 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/01/07 23:46:24 bjan2 Exp $
DISTNAME= micro_http-20011214
WRKSRC= ${WRKDIR}/micro_httpd
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/micro_httpd/
DISTFILES= micro_httpd_14dec2001.tar.gz
MAINTAINER= bjan+pkgsrc@bjan.freeshell.org
HOMEPAGE= http://www.acme.com/software/micro_httpd
COMMENT= Tiny inetd(8) web server
.include "../../mk/bsd.pkg.mk"

3
micro_httpd/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/07 23:46:24 bjan2 Exp $
man/man8/micro_httpd.8
sbin/micro_httpd

5
micro_httpd/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/01/07 23:46:24 bjan2 Exp $
SHA1 (micro_httpd_14dec2001.tar.gz) = 52a8bd4489424c43055a714ac144d44f8a07f52c
Size (micro_httpd_14dec2001.tar.gz) = 4665 bytes
SHA1 (patch-aa) = 1b5cd5291649fd1813a0c8fe315fd07668ecfcef

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/01/07 23:46:24 bjan2 Exp $
--- Makefile.orig 1999-09-17 00:17:18.000000000 -0700
+++ Makefile
@@ -1,11 +1,5 @@
-BINDIR = /usr/local/sbin
-MANDIR = /usr/local/man/man8
-CC = gcc
-CFLAGS = -O
-#CFLAGS = -g
-#SYSVLIBS = -lnsl -lsocket
-LDFLAGS = -s ${SYSVLIBS}
-#LDFLAGS = -g ${SYSVLIBS}
+BINDIR = ${LOCALBASE}/sbin
+MANDIR = ${LOCALBASE}/man/man8
all: micro_httpd