*** empty log message ***

This commit is contained in:
X400 2010-01-13 13:21:04 +00:00 committed by Thomas Klausner
parent 322a85b440
commit 3a55fec357
5 changed files with 39 additions and 5 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2009/10/15 16:19:32 x400 Exp $
@comment $NetBSD: PLIST,v 1.6 2010/01/13 13:21:04 x400 Exp $
bin/callweaver
sbin/streamplayer
include/callweaver/acl.h
@ -213,6 +213,7 @@ ${PLIST.mysql}lib/callweaver/modules/res_config_mysql.la
${PLIST.pgsql}lib/callweaver/modules/app_sql_postgres.la
${PLIST.pgsql}lib/callweaver/modules/cdr_pgsql.la
${PLIST.pgsql}lib/callweaver/modules/res_config_pgsql.la
${PLIST.snmp}lib/callweaver/modules/res_snmp.la
man/man8/callweaver.8
man/man8/safe_callweaver.8
sbin/callweaver_cli

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2009/05/29 13:29:21 x400 Exp $
$NetBSD: distinfo,v 1.3 2010/01/13 13:21:04 x400 Exp $
SHA1 (callweaver-1.2.1.tgz) = f84cc3575879a89fa602e45978272bc522177ed1
RMD160 (callweaver-1.2.1.tgz) = 89f94fdca876e9126732e3e725a4ab30fdc272fc
Size (callweaver-1.2.1.tgz) = 5795528 bytes
SHA1 (patch-aa) = 661b7565ab9de1e9c10ba69bb5fe03a186b847c8
SHA1 (patch-ab) = a827290d6055b8e2660429991cf4c5d70aedf29f
SHA1 (patch-ac) = 7524d64116941f8ae86f4b0fe9ae7cdc8833517e

View file

@ -1,11 +1,11 @@
# $NetBSD: options.mk,v 1.4 2009/10/15 16:19:32 x400 Exp $
# $NetBSD: options.mk,v 1.5 2010/01/13 13:21:04 x400 Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.callweaver
PKG_SUPPORTED_OPTIONS= jabber mysql pgsql sipsecurity
PKG_SUPPORTED_OPTIONS= jabber mysql pgsql sipsecurity snmp
.include "../../mk/bsd.options.mk"
PLIST_VARS+= jabber mysql pgsql sipsecurity
PLIST_VARS+= jabber mysql pgsql sipsecurity snmp
.if !empty(PKG_OPTIONS:Mjabber)
.include "../../chat/loudmouth/buildlink3.mk"
@ -29,3 +29,9 @@ CONFIGURE_ARGS+= --enable-postgresql --with-app_sql_postgres --with-cdr_pgsql --
PLIST.sipsecurity= yes
CONFIGURE_ARGS+= --enable-sip-tcp-support --enable-srtp
.endif
.if !empty(PKG_OPTIONS:Msnmp)
.include "../../net/net-snmp/buildlink3.mk"
PLIST.snmp= yes
CONFIGURE_ARGS+= --with-res_snmp
.endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2010/01/13 13:22:20 x400 Exp $
--- configure.orig 2010-01-13 14:39:12.000000000 +0300
+++ configure
@@ -43183,7 +43183,7 @@
# [ --with-net_snmp enable snmp [will check /usr /usr/local ]
# ],
#[ AC_MSG_RESULT(yes)
- for dir in $withval /usr/local /usr ; do
+ for dir in $withval /usr/local /usr /usr/pkg ; do
snmpdir="$dir"
if test -f "$dir/include/net-snmp/net-snmp-config.h"; then

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1 2010/01/13 13:22:20 x400 Exp $
--- corelib/pbx.c.orig 2010-01-13 14:39:27.000000000 +0300
+++ corelib/pbx.c
@@ -3040,6 +3040,7 @@
if (cw_pthread_create(&t, &attr, pbx_thread, c))
{
cw_log(LOG_WARNING, "Failed to create new channel thread\n");
+ decrease_call_count();
return CW_PBX_FAILED;
}