Make this compile with a recent version of Python.

This commit is contained in:
Min Sik Kim 2012-03-06 23:48:46 +00:00 committed by Thomas Klausner
parent 1d7f31b7fa
commit 3c68c8273f
3 changed files with 25 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.19 2012/03/06 23:30:19 minskim Exp $
# $NetBSD: Makefile,v 1.20 2012/03/06 23:48:46 minskim Exp $
#
DISTNAME= pointless-0.5
@ -22,6 +22,7 @@ DEPENDS+= ghostscript>=7.0:../../print/ghostscript
USE_PKGLOCALEDIR= yes
CPPFLAGS= -DHAVE_PYTHON${PYVERSSUFFIX:S/./_/}
CONFIGURE_ARGS+= --enable-sdl=no
INSTALL_TARGET= ${INSTALL} install-modules

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2012/03/06 23:37:42 minskim Exp $
$NetBSD: distinfo,v 1.5 2012/03/06 23:48:46 minskim Exp $
SHA1 (pointless-0.5.tar.gz) = 74b57bbd4382f1a79d1d88c265ae6d82feec5062
RMD160 (pointless-0.5.tar.gz) = 48db4ef73ef353f71771cd5f0d78cad964d158f2
Size (pointless-0.5.tar.gz) = 1090920 bytes
SHA1 (patch-src_nodecontroller.h) = f0d7045cf409f4c9281aca4a393d47b0a75e79c1
SHA1 (patch-src_primitive.h) = 226e121fcffce11da0a82d701e7e57c4743e5018

View file

@ -0,0 +1,21 @@
$NetBSD: patch-src_nodecontroller.h,v 1.1 2012/03/06 23:48:46 minskim Exp $
--- src/nodecontroller.h.orig 2012-03-06 23:45:28.000000000 +0000
+++ src/nodecontroller.h
@@ -34,6 +34,16 @@
# include <python2.2/Python.h>
#elif HAVE_PYTHON2_3
# include <python2.3/Python.h>
+#elif HAVE_PYTHON2_4
+# include <python2.4/Python.h>
+#elif HAVE_PYTHON2_5
+# include <python2.5/Python.h>
+#elif HAVE_PYTHON2_6
+# include <python2.6/Python.h>
+#elif HAVE_PYTHON2_7
+# include <python2.7/Python.h>
+#elif HAVE_PYTHON3_1
+# include <python3.1/Python.h>
#endif
#include "common.h"