PolicyKit is a framework for defining policy for system-wide components and
for desktop pieces to configure it. It is used by HAL.
This commit is contained in:
parent
c1e54194f2
commit
3d7a1a788c
9 changed files with 187 additions and 0 deletions
2
policykit/DESCR
Normal file
2
policykit/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
PolicyKit is a framework for defining policy for system-wide components and
|
||||
for desktop pieces to configure it. It is used by HAL.
|
63
policykit/Makefile
Normal file
63
policykit/Makefile
Normal file
|
@ -0,0 +1,63 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/03/09 08:23:56 ondratu Exp $
|
||||
#
|
||||
|
||||
DISTNAME= PolicyKit-20060821
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://www.blackmouse.biz/policykit/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc@blackmouse.biz
|
||||
HOMEPAGE= http://www.marcuscom.com/downloads/
|
||||
COMMENT= Framework for defining policy for system-wide components
|
||||
|
||||
# docbook-doc needs xmlto, and thats crash on Linux :(
|
||||
#BUILD_DEPENDS+= xmlto-[0-9]*:../../textproc/xmlto
|
||||
CONFIGURE_ARGS+= --disable-docbook-docs
|
||||
|
||||
# i'm not sure which pams are acceptable
|
||||
#PAM_ACCEPTED= linux-pam
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
USE_LANGUAGES+= c c++
|
||||
|
||||
POLKID_USER?= polkit
|
||||
POLKID_GROUP?= polkit
|
||||
|
||||
PKG_GROUPS= ${POLKID_GROUP}
|
||||
PKG_USERS= ${POLKID_USER}:${POLKID_GROUP}
|
||||
BUILD_DEFS+= POLKID_USER POLKID_GROUP
|
||||
|
||||
CONFIGURE_ARGS+= --with-os-type=${LOWER_VENDOR}
|
||||
CONFIGURE_ARGS+= --with-polkit-user=${POLKID_USER}
|
||||
CONFIGURE_ARGS+= --with-polkit-group=${POLKID_GROUP}
|
||||
CONFIGURE_ARGS+= --with-pam-module-dir=${PAM_INSTMODULEDIR}
|
||||
CONFIGURE_ARGS+= --with-pid-file=/var/run/polkitd.pid
|
||||
CONFIGURE_ARGS+= --localstatedir=/var
|
||||
|
||||
|
||||
PKGCONFIG_OVERRIDE+= polkit.pc.in
|
||||
|
||||
RCD_SCRIPTS+= polkitd
|
||||
|
||||
DBUS_DIR= ${PKG_SYSCONFDIR}/dbus-1
|
||||
PAM_DIR= ${PKG_SYSCONFDIR}/pam
|
||||
|
||||
MAKE_DIRS= ${PKG_SYSCONFDIR}/PolicyKit/privilege.d
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/policykit
|
||||
CONF_FILES= ${EGDIR}/desktop-console.privilege ${PKG_SYSCONFDIR}/PolicyKit/privilege.d/desktop-console.privilege
|
||||
CONF_FILES+= ${EGDIR}/PolicyKit.conf ${DBUS_DIR}/system.d/PolicyKit.conf
|
||||
CONF_FILES+= ${EGDIR}/policy-kit ${PAM_DIR}/policy-kit
|
||||
|
||||
WRKSRC= ${WRKDIR}/PolicyKit
|
||||
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../mk/pam.buildlink3.mk"
|
||||
.include "../../security/PAM/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
31
policykit/PLIST
Normal file
31
policykit/PLIST
Normal file
|
@ -0,0 +1,31 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/03/09 08:23:56 ondratu Exp $
|
||||
bin/polkit-grant-privilege
|
||||
bin/polkit-is-privileged
|
||||
bin/polkit-list-privileges
|
||||
bin/polkit-revoke-privilege
|
||||
include/libpolkit/libpolkit.h
|
||||
include/libpolkit/libpolkit-grant.h
|
||||
lib/libpolkit.la
|
||||
lib/libpolkit-grant.la
|
||||
lib/pkgconfig/polkit.pc
|
||||
lib/security/pam_polkit_console.la
|
||||
sbin/polkitd
|
||||
share/examples/policykit/desktop-console.privilege
|
||||
share/examples/policykit/policy-kit
|
||||
share/examples/policykit/PolicyKit.conf
|
||||
share/examples/rc.d/polkitd
|
||||
@comment "I need xmlto :("
|
||||
@comment share/gtk-doc/html/polkit/home.png
|
||||
@comment share/gtk-doc/html/polkit/ch01.html
|
||||
@comment share/gtk-doc/html/polkit/index.html
|
||||
@comment share/gtk-doc/html/polkit/index.sgml
|
||||
@comment share/gtk-doc/html/polkit/left.png
|
||||
@comment share/gtk-doc/html/polkit/polkit.devhelp
|
||||
@comment share/gtk-doc/html/polkit/polkit.devhelp2
|
||||
@comment share/gtk-doc/html/polkit/polkit-libpolkit.html
|
||||
@comment share/gtk-doc/html/polkit/right.png
|
||||
@comment share/gtk-doc/html/polkit/style.css
|
||||
@comment share/gtk-doc/html/polkit/up.png
|
||||
@comment @dirrm share/gtk-doc/html/polkit
|
||||
@dirrm share/examples/policykit
|
||||
@dirrm include/libpolkit
|
23
policykit/buildlink3.mk
Normal file
23
policykit/buildlink3.mk
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2007/03/09 08:23:57 ondratu Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
POLICYKIT_BUILDLINK3_MK:= ${POLICYKIT_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= PolicyKit
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:NPolicyKit}
|
||||
BUILDLINK_PACKAGES+= PolicyKit
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}PolicyKit
|
||||
|
||||
.if ${POLICYKIT_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.PolicyKit+= PolicyKit>=20060821
|
||||
BUILDLINK_PKGSRCDIR.PolicyKit?= ../../wip/policykit.import
|
||||
.endif # POLICYKIT_BUILDLINK3_MK
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
8
policykit/distinfo
Normal file
8
policykit/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/03/09 08:23:56 ondratu Exp $
|
||||
|
||||
SHA1 (PolicyKit-20060821.tar.bz2) = 8706a52cd96fb68513c5a5b7ec3cb3356ac987d9
|
||||
RMD160 (PolicyKit-20060821.tar.bz2) = b2ead7ee1d6542d33a8b9ea8b0768a4503dd85f5
|
||||
Size (PolicyKit-20060821.tar.bz2) = 585242 bytes
|
||||
SHA1 (patch-aa) = b4033d43b38bdbe82660e495fced95a5442bd841
|
||||
SHA1 (patch-ab) = 7d3c311367463dbc000a9402339b93f1ff4e2b05
|
||||
SHA1 (patch-ac) = 1e9a8462a92ea50c9bfdd0e83b7c7ff31848517a
|
18
policykit/files/polkitd.sh
Normal file
18
policykit/files/polkitd.sh
Normal file
|
@ -0,0 +1,18 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: polkitd.sh,v 1.1.1.1 2007/03/09 08:23:57 ondratu Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: policykit
|
||||
# REQUIRE: DAEMON
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="polkitd"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/sbin/polkitd"
|
||||
pidfile=/var/run/${name}.pid
|
||||
required_files="@PKG_SYSCONFDIR@/dbus-1/system.d/PolicyKit.conf"
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
14
policykit/patches/patch-aa
Normal file
14
policykit/patches/patch-aa
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/03/09 08:23:57 ondratu Exp $
|
||||
|
||||
--- Makefile.in.orig 2007-03-08 21:55:20.000000000 +0100
|
||||
+++ Makefile.in
|
||||
@@ -222,7 +222,8 @@ target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
SUBDIRS = libpolkit pam-polkit-console polkitd doc tools privileges
|
||||
-pamdir = $(sysconfdir)/pam.d
|
||||
+#pamdir = $(sysconfdir)/pam.d
|
||||
+pamdir = $(prefix)/share/examples/policykit
|
||||
pam_DATA = policy-kit
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = polkit.pc
|
14
policykit/patches/patch-ab
Normal file
14
policykit/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/03/09 08:23:57 ondratu Exp $
|
||||
|
||||
--- polkitd/Makefile.in.orig 2007-03-08 21:55:19.000000000 +0100
|
||||
+++ polkitd/Makefile.in
|
||||
@@ -261,7 +261,8 @@ SCRIPT_IN_FILES = PolicyKit.in
|
||||
|
||||
# D-BUS configuration file
|
||||
#
|
||||
-dbusdir = $(sysconfdir)/dbus-1/system.d
|
||||
+#dbusdir = $(sysconfdir)/dbus-1/system.d
|
||||
+dbusdir = $(prefix)/share/examples/policykit
|
||||
dist_dbus_DATA = PolicyKit.conf
|
||||
BUILT_SOURCES = polkit-interface-manager-glue.h \
|
||||
polkit-interface-session-glue.h polkit-marshal.c \
|
14
policykit/patches/patch-ac
Normal file
14
policykit/patches/patch-ac
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/03/09 08:23:57 ondratu Exp $
|
||||
|
||||
--- privileges/Makefile.in.orig 2007-03-08 21:55:19.000000000 +0100
|
||||
+++ privileges/Makefile.in
|
||||
@@ -192,7 +192,8 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-privilegedir = $(sysconfdir)/PolicyKit/privilege.d
|
||||
+#privilegedir = $(sysconfdir)/PolicyKit/privilege.d
|
||||
+privilegedir = $(prefix)/share/examples/policykit
|
||||
dist_privilege_DATA = desktop-console.privilege
|
||||
all: all-am
|
||||
|
Loading…
Reference in a new issue