PyPE (Python Programmers Editor) was written in order to offer a lightweight
but powerful editor for those of you who think emacs is too much and idle is too little. Syntax highlighting is included out of the box, as is multiple open documents via tabs.
This commit is contained in:
parent
875d39c7bb
commit
3f56299040
6 changed files with 80 additions and 0 deletions
4
py-PyPE/DESCR
Normal file
4
py-PyPE/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
PyPE (Python Programmers Editor) was written in order to offer a lightweight
|
||||
but powerful editor for those of you who think emacs is too much and idle is
|
||||
too little. Syntax highlighting is included out of the box, as is multiple
|
||||
open documents via tabs.
|
33
py-PyPE/Makefile
Normal file
33
py-PyPE/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/12/19 23:17:45 mpasternak Exp $
|
||||
#
|
||||
|
||||
DISTNAME= PyPE1.8.1
|
||||
PKGNAME= ${PYPKGPREFIX}-PyPE-1.8.1
|
||||
WRKSRC= ${WRKDIR}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pype/}
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= dotz@irc.pl
|
||||
HOMEPAGE= http://pype.sourceforge.net/
|
||||
COMMENT= Lightweight, but powerful editor for Python
|
||||
|
||||
PYTHON_PATCH_SCRIPTS= pype.py
|
||||
NO_BUILD= # defined
|
||||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/${PYSITELIB}/pype
|
||||
${INSTALL_DATA} ${WRKSRC}/configuration.py \
|
||||
${PREFIX}/${PYSITELIB}/pype/configuration.py
|
||||
${INSTALL_DATA} ${WRKSRC}/parsers.py \
|
||||
${PREFIX}/${PYSITELIB}/pype/parsers.py
|
||||
${INSTALL_DATA} ${FILESDIR}/__init__.py \
|
||||
${PREFIX}/${PYSITELIB}/pype/__init__.py
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/pype.py ${PREFIX}/bin/pype.py-${PYVERSSUFFIX}
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../x11/py-wxWindows/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
py-PyPE/PLIST
Normal file
6
py-PyPE/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/19 23:17:45 mpasternak Exp $
|
||||
bin/pype.py-${PYVERSSUFFIX}
|
||||
${PYSITELIB}/pype/configuration.py
|
||||
${PYSITELIB}/pype/parsers.py
|
||||
${PYSITELIB}/pype/__init__.py
|
||||
@dirrm ${PYSITELIB}/pype
|
5
py-PyPE/distinfo
Normal file
5
py-PyPE/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/12/19 23:17:45 mpasternak Exp $
|
||||
|
||||
SHA1 (PyPE1.8.1.zip) = 1e266fb061d18ce1670985fceb40d372fd13f9ca
|
||||
Size (PyPE1.8.1.zip) = 89962 bytes
|
||||
SHA1 (patch-aa) = 33b71eb92893280b650b09b5f0ce337bf093a11f
|
1
py-PyPE/files/__init__.py
Normal file
1
py-PyPE/files/__init__.py
Normal file
|
@ -0,0 +1 @@
|
|||
__all__ = ["configuration", "parsers"]
|
31
py-PyPE/patches/patch-aa
Normal file
31
py-PyPE/patches/patch-aa
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/12/19 23:17:45 mpasternak Exp $
|
||||
|
||||
--- pype.py~ Tue Dec 16 11:07:08 2003
|
||||
+++ pype.py Sat Dec 20 00:12:23 2003
|
||||
@@ -11,7 +11,7 @@
|
||||
if (len(sys.argv) > 1):
|
||||
if (sys.argv[1] == '--parse'):
|
||||
del sys.argv[1]
|
||||
- from parsers import main
|
||||
+ from pype.parsers import main
|
||||
main()
|
||||
sys.exit(0)
|
||||
elif (sys.argv[1] == '--exec'):
|
||||
@@ -50,7 +50,7 @@
|
||||
from wxPython.lib.dialogs import wxScrolledMessageDialog
|
||||
|
||||
#--------------------------- configuration import ----------------------------
|
||||
-from configuration import *
|
||||
+from pype.configuration import *
|
||||
#--------- The two most useful links for constructing this editor... ---------
|
||||
# http://www.pyframe.com/wxdocs/stc/index.html
|
||||
# http://personalpages.tds.net/~edream/out2.htm
|
||||
@@ -60,7 +60,7 @@
|
||||
#under an if so that I can collapse the declarations
|
||||
|
||||
VERSION = "1.8.1"
|
||||
- VREQ = '2.4.2.4'
|
||||
+ VREQ = '2.4.1.2'
|
||||
|
||||
import string
|
||||
STRINGPRINTABLE = string.printable[:]
|
Loading…
Reference in a new issue