Fix rpath handling based on clang patch, and add another fix from lang/clang.
This commit is contained in:
parent
32295cba45
commit
3fe5242f23
3 changed files with 55 additions and 7 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.5 2009/11/05 22:18:00 christtrekker Exp $
|
||||
$NetBSD: distinfo,v 1.6 2009/12/08 10:29:50 thomasklausner Exp $
|
||||
|
||||
SHA1 (llvm-2.6.tar.gz) = 547471147cbf6d3e49539e01196ffada2c79c250
|
||||
RMD160 (llvm-2.6.tar.gz) = 24d58cb052ab5879aae59eaf4885ec41186ee22a
|
||||
Size (llvm-2.6.tar.gz) = 7790380 bytes
|
||||
SHA1 (patch-ac) = ef735eef5ee27f5ac9b4ff022cf86d2990ed0b32
|
||||
SHA1 (patch-aa) = 9d40cbc0a103e49abe2a312bba63465f959a5313
|
||||
SHA1 (patch-ac) = a89847ffac13a10a72f5b87a612837cb6f6f9482
|
||||
SHA1 (patch-ad) = b7f4da294510666063b655540991f51c9044d618
|
||||
|
|
22
llvm/patches/patch-aa
Normal file
22
llvm/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.4 2009/12/08 10:29:50 thomasklausner Exp $
|
||||
|
||||
--- lib/System/Unix/Path.inc.orig 2009-12-08 10:01:09.000000000 +0000
|
||||
+++ lib/System/Unix/Path.inc
|
||||
@@ -283,7 +283,7 @@ Path::GetCurrentDirectory() {
|
||||
return Path(pathname);
|
||||
}
|
||||
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
static int
|
||||
test_dir(char buf[PATH_MAX], char ret[PATH_MAX],
|
||||
const char *dir, const char *bin)
|
||||
@@ -351,7 +351,7 @@ Path Path::GetMainExecutable(const char
|
||||
if (realpath(exe_path, link_path))
|
||||
return Path(std::string(link_path));
|
||||
}
|
||||
-#elif defined(__FreeBSD__)
|
||||
+#elif defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
char exe_path[PATH_MAX];
|
||||
|
||||
if (getprogpath(exe_path, argv0) != NULL)
|
|
@ -1,8 +1,33 @@
|
|||
$NetBSD: patch-ac,v 1.2 2009/07/18 08:19:29 asau Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2009/12/08 10:29:50 thomasklausner Exp $
|
||||
|
||||
--- Makefile.rules.orig 2009-02-14 04:07:49.000000000 +0300
|
||||
+++ Makefile.rules 2009-03-05 16:52:31.000000000 +0300
|
||||
@@ -560,9 +560,6 @@
|
||||
--- Makefile.rules.orig 2009-12-08 10:01:35.000000000 +0000
|
||||
+++ Makefile.rules
|
||||
@@ -576,12 +576,6 @@ ifdef LOADABLE_MODULE
|
||||
LD.Flags += -module
|
||||
endif
|
||||
|
||||
-ifdef SHARED_LIBRARY
|
||||
-ifneq ($(DARWIN_MAJVERS),4)
|
||||
- LD.Flags += $(RPATH) -Wl,$(LibDir)
|
||||
-endif
|
||||
-endif
|
||||
-
|
||||
ifdef TOOL_VERBOSE
|
||||
C.Flags += -v
|
||||
CXX.Flags += -v
|
||||
@@ -610,9 +604,9 @@ ifneq ($(HOST_OS),Darwin)
|
||||
ifneq ($(DARWIN_MAJVERS),4)
|
||||
ifdef TOOLNAME
|
||||
ifdef EXAMPLE_TOOL
|
||||
- LD.Flags += $(RPATH) -Wl,$(ExmplDir) $(RDYNAMIC)
|
||||
+ LD.Flags += $(RDYNAMIC)
|
||||
else
|
||||
- LD.Flags += $(RPATH) -Wl,$(ToolDir) $(RDYNAMIC)
|
||||
+ LD.Flags += $(RDYNAMIC)
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -768,9 +762,6 @@ ObjectsBC := $(BaseNameSources:%=$(ObjDi
|
||||
# in the file so they get built before dependencies
|
||||
#---------------------------------------------------------
|
||||
|
||||
|
@ -12,7 +37,7 @@ $NetBSD: patch-ac,v 1.2 2009/07/18 08:19:29 asau Exp $
|
|||
# To create other directories, as needed, and timestamp their creation
|
||||
%/.dir:
|
||||
$(Verb) $(MKDIR) $* > /dev/null
|
||||
@@ -682,7 +679,9 @@
|
||||
@@ -891,7 +882,9 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) UnInstall circumvented with NO_INSTALL
|
||||
else
|
||||
|
|
Loading…
Reference in a new issue