Add golly, a game-of-life visualizer.

Builds and runs for me, but does not show the world.
Since this program uses GL and that often seems to have problems, maybe
this is another GL problem.
This commit is contained in:
Olaf Seibert 2017-09-22 23:19:25 +02:00
parent 60643fca7d
commit 40fdd684f5
5 changed files with 664 additions and 0 deletions

21
golly/DESCR Normal file
View file

@ -0,0 +1,21 @@
Golly is an open source, cross-platform application for exploring
Conway's Game of Life and many other types of cellular automata.
Golly's key features:
Supports bounded and unbounded universes, with cells of up to 256
states. Supports multiple algorithms, including Bill Gosper's super
fast hashlife algorithm. Many different types of CA are included: John
von Neumann's 29-state CA, Wolfram's 1D rules, WireWorld, Generations,
Paterson's Worms, Larger than Life, etc. The RuleLoader algorithm lets
you plug in new rules. Responsive even while generating or garbage
collecting. Reads RLE, macrocell, Life 1.05/1.06, dblife, and MCell
files. Can also read common graphic formats: BMP, PNG, GIF, TIFF. Can
extract patterns, rules and scripts from zip files. Can download
patterns, rules and scripts from online archives. Includes a
state-of-the-art pattern collection. Can paste in patterns from the
clipboard. Unlimited undo/redo. Configurable keyboard shortcuts. Auto
fit option keeps patterns sized to the window. Full screen option (no
menu/status/tool/scroll bars). Supports multiple layers, including
cloned layers. HTML-based help with an integrated Life Lexicon.
Scriptable via Lua or Python.

30
golly/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $NetBSD$
PKGVERSION= 3.0
PKGNAME= golly-${PKGVERSION}
DISTNAME= ${PKGNAME}-src
#PKGREVISION= 0
CATEGORIES= x11
# MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=golly/} results in http://downloads.sourceforge.net/sourceforge/golly/golly-3.0.tar.gz
# we want https://sourceforge.net/projects/golly/files/golly/golly-3.0/golly-3.0-src.tar.gz
MASTER_SITES= https://sourceforge.net/projects/golly/files/golly/${PKGNAME}/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://golly.sourceforge.net/
COMMENT= Fast Game-Of-Life (and similar automata) program
LICENSE= gnu-gpl-v2
USE_LANGUAGES= c c++
USE_TOOLS= make
CONFIGURE_DIRS= gui-wx/configure
#CONFIGURE_SCRIPT=./configure
GNU_CONFIGURE= YES
CONFIGURE_ARGS+="CFLAGS=--std=c99" # for long long in luaconf.h -> limits.h
.include "../../mk/bsd.pkg.debug.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
#.include "../../lang/lua/buildlink3.mk" # uses its own built-in version 5.2
.include "../../lang/python27/buildlink3.mk"
.include "../../x11/wxGTK28/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

573
golly/PLIST Normal file
View file

@ -0,0 +1,573 @@
@comment $NetBSD$
bin/golly
bin/bgolly
share/doc/golly/License.html
share/doc/golly/ReadMe.html
share/golly/Patterns/Life/Rakes/2c5-engineless-rake-p185.rle
share/golly/Patterns/Life/Rakes/2c5-spaceship-rake-p240.rle
share/golly/Patterns/Life/Rakes/basic-rakes.rle
share/golly/Patterns/Life/Rakes/c2-Cordership-rake.rle
share/golly/Patterns/Life/Rakes/c3-forward-rake-p333.rle
share/golly/Patterns/Life/Rakes/c4-sideways-rake.rle
share/golly/Patterns/Life/Rakes/c5-adjustable-rake.rle
share/golly/Patterns/Life/Rakes/forward-LWSS-rake-p90.rle
share/golly/Patterns/Life/Rakes/p270-frothing-puffer-rake.rle
share/golly/Patterns/Life/Rakes/spider-rake.rle
share/golly/Patterns/Life/Methuselahs/acorn.lif
share/golly/Patterns/Life/Methuselahs/ark1.rle
share/golly/Patterns/Life/Methuselahs/ark2.rle
share/golly/Patterns/Life/Methuselahs/blom.rle
share/golly/Patterns/Life/Methuselahs/iwona.rle
share/golly/Patterns/Life/Methuselahs/justyna.rle
share/golly/Patterns/Life/Methuselahs/lidka-predecessor.rle
share/golly/Patterns/Life/Methuselahs/natural-LWSS.rle
share/golly/Patterns/Life/Methuselahs/rabbits.lif
share/golly/Patterns/Life/Methuselahs/rabbits-relation-17423.rle
share/golly/Patterns/Life/Methuselahs/rabbits-relation-17465.rle
share/golly/Patterns/Life/Methuselahs/temp-pulsars-big-s.rle
share/golly/Patterns/Life/Oscillators/billiard-table.rle
share/golly/Patterns/Life/Oscillators/DRH-oscillators.rle
share/golly/Patterns/Life/Oscillators/extensible-low-period.rle
share/golly/Patterns/Life/Oscillators/glider-stream-crystal.rle
share/golly/Patterns/Life/Oscillators/low-period.rle
share/golly/Patterns/Life/Oscillators/p103079214841.rle
share/golly/Patterns/Life/Oscillators/p138.rle
share/golly/Patterns/Life/Oscillators/p59-glider-loop.lua
share/golly/Patterns/Life/Oscillators/queen-bee-turn.rle
share/golly/Patterns/Life/Oscillators/traffic-light-hasslers.rle
share/golly/Patterns/Life/Oscillators/unique-high-period.rle
share/golly/Patterns/Life/Signal-Circuitry/advancer.rle
share/golly/Patterns/Life/Signal-Circuitry/chase-the-glider.rle
share/golly/Patterns/Life/Signal-Circuitry/constructor-memory-loop.rle
share/golly/Patterns/Life/Signal-Circuitry/constructor-memory-tape.rle
share/golly/Patterns/Life/Signal-Circuitry/heisenblinker-30.rle
share/golly/Patterns/Life/Signal-Circuitry/heisenburp-30.rle
share/golly/Patterns/Life/Signal-Circuitry/heisenburp-46-natural.rle
share/golly/Patterns/Life/Signal-Circuitry/heisenburp-46.rle
share/golly/Patterns/Life/Signal-Circuitry/high-bandwidth-telegraph.rle.gz
share/golly/Patterns/Life/Signal-Circuitry/h-to-h-collection-26Aug2017.zip
share/golly/Patterns/Life/Signal-Circuitry/p30-racetrack.rle
share/golly/Patterns/Life/Signal-Circuitry/p46racetrack.rle
share/golly/Patterns/Life/Signal-Circuitry/reflectors2.rle
share/golly/Patterns/Life/Signal-Circuitry/reflectors.rle
share/golly/Patterns/Life/Signal-Circuitry/signal-turn.rle
share/golly/Patterns/Life/Signal-Circuitry/stargate.rle
share/golly/Patterns/Life/Signal-Circuitry/single-channel-spiral-growth.rle.gz
share/golly/Patterns/Life/Signal-Circuitry/traffic-lights-extruder.rle
share/golly/Patterns/Life/Signal-Circuitry/Turing-Machine-3-state.rle
share/golly/Patterns/Life/Signal-Circuitry/Unit-Life-Cell-512x512.rle
share/golly/Patterns/Life/Signal-Circuitry/Unit-Life-Deep-Cell.rle
share/golly/Patterns/Life/Puffers/c4-diagonal-puffer.rle
share/golly/Patterns/Life/Puffers/line-puffer-superstable.rle
share/golly/Patterns/Life/Puffers/line-puffer-unstable.rle
share/golly/Patterns/Life/Puffers/p100-H-track-puffer.rle
share/golly/Patterns/Life/Puffers/pi-fuse-puffer.rle
share/golly/Patterns/Life/Puffers/puffer-2c5.rle
share/golly/Patterns/Life/Puffers/puffer-train.rle
share/golly/Patterns/Life/Puffers/zigzag-wickstretcher.rle
share/golly/Patterns/Life/Still-Lifes/1998-eater-stamp-collection.rle
share/golly/Patterns/Life/Still-Lifes/eaters-misc.rle
share/golly/Patterns/Life/Still-Lifes/eaters.rle
share/golly/Patterns/Life/Still-Lifes/random.rle
share/golly/Patterns/Life/Still-Lifes/ss-eaters.rle
share/golly/Patterns/Life/Still-Lifes/stripey.rle
share/golly/Patterns/Life/Breeders/breeder.lif
share/golly/Patterns/Life/Breeders/c4-diag-switch-engines.rle
share/golly/Patterns/Life/Breeders/LWSS-breeder.rle
share/golly/Patterns/Life/Breeders/p100-H-channel-breeder.rle
share/golly/Patterns/Life/Breeders/p90-rake-factory.rle
share/golly/Patterns/Life/Breeders/pi-blink-breeder1.rle
share/golly/Patterns/Life/Breeders/pi-blink-breeder2.rle
share/golly/Patterns/Life/Breeders/rake-breeder.rle
share/golly/Patterns/Life/Breeders/slide-breeder.rle
share/golly/Patterns/Life/Breeders/spacefiller.rle
share/golly/Patterns/Life/Breeders/switch-engine-breeder-MR.rle
share/golly/Patterns/Life/Breeders/switch-engine-breeder.rle
share/golly/Patterns/Life/Bounded-Grids/agar-p3.rle
share/golly/Patterns/Life/Bounded-Grids/cross-surface.rle
share/golly/Patterns/Life/Bounded-Grids/herringbone-agar-p14.rle
share/golly/Patterns/Life/Bounded-Grids/Klein-bottle.rle
share/golly/Patterns/Life/Bounded-Grids/lightspeed-bubble.rle
share/golly/Patterns/Life/Bounded-Grids/pulsars-in-tube.rle
share/golly/Patterns/Life/Bounded-Grids/sphere.rle
share/golly/Patterns/Life/Bounded-Grids/torus.rle
share/golly/Patterns/Life/Bounded-Grids/torus-with-shift.rle
share/golly/Patterns/Life/Guns/2c5-spaceship-gun-p416.rle
share/golly/Patterns/Life/Guns/2c5-spaceship-gun-p690.rle
share/golly/Patterns/Life/Guns/7-in-a-row-Cordership-V-gun.rle
share/golly/Patterns/Life/Guns/Cordership-gun-p784.rle
share/golly/Patterns/Life/Guns/golly-ticker.rle
share/golly/Patterns/Life/Guns/gun-p165mwss.rle
share/golly/Patterns/Life/Guns/loafer-gun-p210.rle
share/golly/Patterns/Life/Guns/p59-gun-with-Snark-reflectors.rle
share/golly/Patterns/Life/Guns/p690-PT-Cordership-gun.rle
share/golly/Patterns/Life/Guns/pseudo-p34-gun.rle
share/golly/Patterns/Life/Guns/vacuum-cleaner.rle
share/golly/Patterns/Life/Spaceships/2c5-orthogonal.rle
share/golly/Patterns/Life/Spaceships/adjustable-Corder-lineship.rle
share/golly/Patterns/Life/Spaceships/c3-orthogonal.rle
share/golly/Patterns/Life/Spaceships/c4-diagonal.rle
share/golly/Patterns/Life/Spaceships/c4-orthogonal.rle
share/golly/Patterns/Life/Spaceships/Corder-lineship.rle
share/golly/Patterns/Life/Spaceships/Cordership-boat-burner.rle
share/golly/Patterns/Life/Spaceships/Cordership-LWSS-freeze-tag.rle
share/golly/Patterns/Life/Spaceships/corderships.rle
share/golly/Patterns/Life/Spaceships/diagonal.rle
share/golly/Patterns/Life/Spaceships/orthogonal.rle
share/golly/Patterns/Life/Spaceships/short-thin-race.rle
share/golly/Patterns/Life/Spaceships/smallest-low-period.rle
share/golly/Patterns/Life/Spaceships/spaceship-types.rle
share/golly/Patterns/Life/Syntheses/109-still-lifes.rle
share/golly/Patterns/Life/Syntheses/29-still-lifes.rle
share/golly/Patterns/Life/Syntheses/blockish-and-blockic-seeds.rle
share/golly/Patterns/Life/Syntheses/life-integer-constructions.rle
share/golly/Patterns/Life/Syntheses/make-harbor.rle
share/golly/Patterns/Life/Syntheses/make-lightbulb.rle
share/golly/Patterns/Life/Syntheses/make-osc-p3.rle
share/golly/Patterns/Life/Syntheses/make-osc-p4.rle
share/golly/Patterns/Life/Syntheses/make-osc-p5-plus.rle
share/golly/Patterns/Life/Syntheses/make-p11.rle
share/golly/Patterns/Life/Syntheses/make-p18.rle
share/golly/Patterns/Life/Syntheses/make-p33.rle
share/golly/Patterns/Life/Syntheses/oscillator-syntheses.rle
share/golly/Patterns/Life/Syntheses/slow-salvo-eater-recipes.rle
share/golly/Patterns/Life/Syntheses/two-glider-collisions.rle
share/golly/Patterns/Life/Miscellaneous/blockstacker.rle
share/golly/Patterns/Life/Miscellaneous/Calcyman-primer.zip
share/golly/Patterns/Life/Miscellaneous/Cambrian-Explosion.rle
share/golly/Patterns/Life/Miscellaneous/diagfuse1.rle
share/golly/Patterns/Life/Miscellaneous/die658.rle
share/golly/Patterns/Life/Miscellaneous/elbow-ladders.rle
share/golly/Patterns/Life/Miscellaneous/fermat-primes.rle
share/golly/Patterns/Life/Miscellaneous/four-primers.rle.gz
share/golly/Patterns/Life/Miscellaneous/infinity-hotel0.rle
share/golly/Patterns/Life/Miscellaneous/infinity-hotel1.rle
share/golly/Patterns/Life/Miscellaneous/infinity-hotel2.rle
share/golly/Patterns/Life/Miscellaneous/infinity-hotel3.rle
share/golly/Patterns/Life/Miscellaneous/lightspeed.rle
share/golly/Patterns/Life/Miscellaneous/loggrow-corder.rle
share/golly/Patterns/Life/Miscellaneous/sawtooth6b.rle
share/golly/Patterns/Life/Miscellaneous/tubstretch-c124b.rle
share/golly/Patterns/Life/Miscellaneous/twinprimes.rle
share/golly/Patterns/Life/Miscellaneous/wicks-DRH-2002.rle
share/golly/Patterns/Patersons-Worms/worm-1040512.rle
share/golly/Patterns/Patersons-Worms/worm-1042015.rle
share/golly/Patterns/Patersons-Worms/worm-1042020.rle
share/golly/Patterns/Patersons-Worms/worm-1252121.rle
share/golly/Patterns/Patersons-Worms/worm-1525115.rle
share/golly/Patterns/Self-Rep/Banks/Banks-I-demo.rle
share/golly/Patterns/Self-Rep/Banks/Banks-II-demo.rle
share/golly/Patterns/Self-Rep/Banks/Banks-III-demo.rle
share/golly/Patterns/Self-Rep/Banks/Banks-IV-constructor.rle.gz
share/golly/Patterns/Self-Rep/Banks/Banks-IV-demo.rle
share/golly/Patterns/Self-Rep/JvN/Boustrophedon-replicator.rle
share/golly/Patterns/Self-Rep/JvN/cell-coders-demo.rle
share/golly/Patterns/Self-Rep/JvN/codon4-auto-retract.rle
share/golly/Patterns/Self-Rep/JvN/codon5-auto-retract.rle
share/golly/Patterns/Self-Rep/JvN/construction-arm-demo.rle
share/golly/Patterns/Self-Rep/JvN/counter-demo.rle
share/golly/Patterns/Self-Rep/JvN/golly-constructor.rle
share/golly/Patterns/Self-Rep/JvN/Hutton-replicator.rle
share/golly/Patterns/Self-Rep/JvN/JvN-loop-replicator.rle.gz
share/golly/Patterns/Self-Rep/JvN/N-compressed-replicator.rle
share/golly/Patterns/Self-Rep/JvN/NP-mutation.rle.gz
share/golly/Patterns/Self-Rep/JvN/NP-replicator.rle.gz
share/golly/Patterns/Self-Rep/JvN/partial-constructor.mc.gz
share/golly/Patterns/Self-Rep/JvN/read-arm-demo.rle
share/golly/Patterns/Self-Rep/JvN/sphinx.mc.gz
share/golly/Patterns/Self-Rep/JvN/sphinx-midpoint.mc.gz
share/golly/Patterns/Self-Rep/JvN/sphinx-spark.mc.gz
share/golly/Patterns/Self-Rep/Codd/clocking-on-demo.rle
share/golly/Patterns/Self-Rep/Codd/coders-demo.rle
share/golly/Patterns/Self-Rep/Codd/construction-arm-demo.rle
share/golly/Patterns/Self-Rep/Codd/crossover-unidir-demo.rle
share/golly/Patterns/Self-Rep/Codd/decoder-4bit-demo.rle.gz
share/golly/Patterns/Self-Rep/Codd/echo-discriminator.rle
share/golly/Patterns/Self-Rep/Codd/echo-switch-demo.rle
share/golly/Patterns/Self-Rep/Codd/extend-coder-demo.rle
share/golly/Patterns/Self-Rep/Codd/gates-demo.rle
share/golly/Patterns/Self-Rep/Codd/golly-constructor.rle.gz
share/golly/Patterns/Self-Rep/Codd/Goucher-replicator.mc.gz
share/golly/Patterns/Self-Rep/Codd/repeater-emitter-demo.rle
share/golly/Patterns/Self-Rep/Codd/sensing-demo.rle
share/golly/Patterns/Self-Rep/Codd/sheathing-demo.rle
share/golly/Patterns/Self-Rep/Codd/sheathing-problems.rle
share/golly/Patterns/Self-Rep/Codd/signals-demo.rle
share/golly/Patterns/Self-Rep/Codd/tape-reader-demo.rle
share/golly/Patterns/Self-Rep/Devore/crossover.rle
share/golly/Patterns/Self-Rep/Devore/Devore-body.rle
share/golly/Patterns/Self-Rep/Devore/Devore-rep.rle
share/golly/Patterns/Self-Rep/Devore/discriminator.rle
share/golly/Patterns/Other-Rules/Ed-rep.rle
share/golly/Patterns/Other-Rules/factorize-84.zip
share/golly/Patterns/Other-Rules/golly-ants.rle
share/golly/Patterns/Other-Rules/HPP-demo.rle
share/golly/Patterns/Other-Rules/HPP-demo-small.rle
share/golly/Patterns/Other-Rules/Langtons-Ant.rle
share/golly/Patterns/Other-Rules/life-on-the-edge.rle
share/golly/Patterns/Other-Rules/life-on-the-slope.rle
share/golly/Patterns/Non-Totalistic/horiship-guns.rle
share/golly/Patterns/Non-Totalistic/infinite-binary-ruler-generator.rle
share/golly/Patterns/Non-Totalistic/intergalactic-cruise-ship-factory.rle
share/golly/Patterns/Non-Totalistic/limited-spacefiller.rle
share/golly/Patterns/Non-Totalistic/p42-knightship.rle
share/golly/Patterns/Non-Totalistic/reflectorless-rotating-oscillator-puffer.rle
share/golly/Patterns/Non-Totalistic/rr14gun.rle
share/golly/Patterns/Non-Totalistic/Sierpinski-builder.rle
share/golly/Patterns/Non-Totalistic/unit-fraction-orthogonal-spaceships.zip
share/golly/Patterns/Non-Totalistic/JustFriends/oscillators.rle
share/golly/Patterns/Non-Totalistic/JustFriends/p137loop.rle
share/golly/Patterns/Non-Totalistic/JustFriends/p384drifter.rle
share/golly/Patterns/Non-Totalistic/JustFriends/p8256c4dirtyrake.rle
share/golly/Patterns/Non-Totalistic/JustFriends/spaceships.rle
share/golly/Patterns/HashLife/broken-lines.mc
share/golly/Patterns/HashLife/catacryst.mc
share/golly/Patterns/HashLife/gotts-dots.mc
share/golly/Patterns/HashLife/hashlife-oddity1.mc
share/golly/Patterns/HashLife/hashlife-oddity2.mc
share/golly/Patterns/HashLife/hexadecimal.mc.gz
share/golly/Patterns/HashLife/jagged2.mc
share/golly/Patterns/HashLife/jagged.mc
share/golly/Patterns/HashLife/linear-propagator-p237228340.mc.gz
share/golly/Patterns/HashLife/loafer-gun-p8388608-linear.mc.gz
share/golly/Patterns/HashLife/logarithmic-width.mc
share/golly/Patterns/HashLife/metacatacryst.mc
share/golly/Patterns/HashLife/metapixel-galaxy.mc.gz
share/golly/Patterns/HashLife/metapixel-p216-gun.mc.gz
share/golly/Patterns/HashLife/metapixel-parity64.mc.gz
share/golly/Patterns/HashLife/mosquito5.mc
share/golly/Patterns/HashLife/nick-gotts-1.mc
share/golly/Patterns/HashLife/nick-gotts-2.mc
share/golly/Patterns/HashLife/puzzle.mc
share/golly/Patterns/HashLife/ruler.mc
share/golly/Patterns/HashLife/totalperiodic.mc
share/golly/Patterns/HashLife/triple-Snark-wick-extruder.rle.gz
share/golly/Patterns/HashLife/unlimited-novelty.mc
share/golly/Patterns/HashLife/wedge-grow.mc
share/golly/Patterns/HashLife/wolfram22.mc
share/golly/Patterns/Larger-than-Life/Blinkers.mcl
share/golly/Patterns/Larger-than-Life/Bosco.mcl
share/golly/Patterns/Larger-than-Life/BugCollection.rle
share/golly/Patterns/Larger-than-Life/BugGun.rle
share/golly/Patterns/Larger-than-Life/BugReactions.rle
share/golly/Patterns/Larger-than-Life/Butterfly.rle
share/golly/Patterns/Larger-than-Life/Globe.mcl
share/golly/Patterns/Larger-than-Life/Gnarl.mcl
share/golly/Patterns/Larger-than-Life/GunCollection.rle
share/golly/Patterns/Larger-than-Life/Jitterbug.rle
share/golly/Patterns/Larger-than-Life/Majority.mcl
share/golly/Patterns/Larger-than-Life/ModernArt.mcl
share/golly/Patterns/Larger-than-Life/R100-alien-bug.rle
share/golly/Patterns/Larger-than-Life/R100-NN-bug.rle
share/golly/Patterns/Larger-than-Life/R500-alien-bug.rle
share/golly/Patterns/Larger-than-Life/SlowShip.rle
share/golly/Patterns/Larger-than-Life/SoldierBugs.rle
share/golly/Patterns/Larger-than-Life/Waffle.mcl
share/golly/Patterns/Life-Like/alt-wicks.lua
share/golly/Patterns/Life-Like/coral.rle
share/golly/Patterns/Life-Like/Day-and-Night-gun-and-antigun.rle
share/golly/Patterns/Life-Like/ice-nine.rle
share/golly/Patterns/Life-Like/p168-knightship.rle
share/golly/Patterns/Life-Like/persian-rugs.lif
share/golly/Patterns/Life-Like/replicator.rle
share/golly/Patterns/Life-Like/spiral-growth.rle
share/golly/Patterns/Life-Like/white-whale.rle
share/golly/Patterns/Life-Like/Morley/breeder2.rle
share/golly/Patterns/Life-Like/Morley/enterprise-gun.rle
share/golly/Patterns/Life-Like/Morley/growing-ship.rle
share/golly/Patterns/Margolus/BBM.rle
share/golly/Patterns/Margolus/CrittersCircle.rle
share/golly/Patterns/Margolus/CrittersOscillators.rle
share/golly/Patterns/Margolus/DLA.rle
share/golly/Patterns/Margolus/HPP_large.rle
share/golly/Patterns/Margolus/HPP.rle
share/golly/Patterns/Margolus/Sand.rle
share/golly/Patterns/Margolus/Sand-Test.rle
share/golly/Patterns/Margolus/TMGas_largeWithHole.rle
share/golly/Patterns/Margolus/TMGas.rle
share/golly/Patterns/Margolus/TripATron_BlockAligned.rle
share/golly/Patterns/Margolus/TripATron.rle
share/golly/Patterns/Generations/Banner.mcl
share/golly/Patterns/Generations/Bloomerang.mcl
share/golly/Patterns/Generations/Burst.mcl
share/golly/Patterns/Generations/Caterpillars.mcl
share/golly/Patterns/Generations/Delta.rle
share/golly/Patterns/Generations/Ebb-and-Flow.mcl
share/golly/Patterns/Generations/Fireworks.mcl
share/golly/Patterns/Generations/Lava.mcl
share/golly/Patterns/Generations/Lines.mcl
share/golly/Patterns/Generations/MeteorGuns.mcl
share/golly/Patterns/Generations/Nova.mcl
share/golly/Patterns/Generations/Perfect-spiral.mcl
share/golly/Patterns/Generations/Sawfish.rle
share/golly/Patterns/Generations/SediMental.mcl
share/golly/Patterns/Generations/Steeplechase.mcl
share/golly/Patterns/Generations/Transers.mcl
share/golly/Patterns/Generations/What-a-mess.mcl
share/golly/Patterns/Loops/Byl-Loop.rle
share/golly/Patterns/Loops/Chou-Reggia-Loop-1.rle
share/golly/Patterns/Loops/Chou-Reggia-Loop-2.rle
share/golly/Patterns/Loops/Evoloop-finite.rle
share/golly/Patterns/Loops/Evoloop.rle
share/golly/Patterns/Loops/Langtons-Loops.rle
share/golly/Patterns/Loops/Perrier-Loop.rle
share/golly/Patterns/Loops/Perrier-Parenthesis-Checker.rle
share/golly/Patterns/Loops/SDSR-Loop.rle
share/golly/Patterns/Loops/Tempesti-Loop.rle
share/golly/Patterns/WireWorld/circuit.mcl
share/golly/Patterns/WireWorld/clocks.mcl
share/golly/Patterns/WireWorld/flip-flop.mcl
share/golly/Patterns/WireWorld/gate-AND.mcl
share/golly/Patterns/WireWorld/gate-NOT.mcl
share/golly/Patterns/WireWorld/gate-OR.mcl
share/golly/Patterns/WireWorld/gate-XOR.mcl
share/golly/Patterns/WireWorld/Langtons-ant.zip
share/golly/Patterns/WireWorld/memory-cell.mcl
share/golly/Patterns/WireWorld/NickGardner.mcl
share/golly/Patterns/WireWorld/NylesHeise.mcl
share/golly/Patterns/WireWorld/primes.mc
share/golly/Patterns/WireWorld/unary-multiplier.mcl
share/golly/Patterns/Turmites/AlienCounter.rle
share/golly/Patterns/Turmites/ComputerArt.rle
share/golly/Patterns/Turmites/Extinction.rle
share/golly/Patterns/Turmites/FibonacciSpiral.rle
share/golly/Patterns/Turmites/Highway2074575.rle
share/golly/Patterns/Turmites/LangtonsAnt_LLRR.rle
share/golly/Patterns/Turmites/Perfectionist.rle
share/golly/Patterns/Turmites/TriangularAnt_period92.rle
share/golly/Patterns/Turmites/TriangularLangtonsAnt.rle
share/golly/Patterns/Turmites/WormTrails.rle
share/golly/Rules/AbsoluteTurmite_0N21S10E00S01W11N2.rule
share/golly/Rules/AbsoluteTurmite_0S11W11E21S21W00N0.rule
share/golly/Rules/AbsoluteTurmite_1N10S11S30N21W01N11S20E1.rule
share/golly/Rules/Banks-III.rule
share/golly/Rules/Banks-II.rule
share/golly/Rules/Banks-I.rule
share/golly/Rules/Banks-IV.rule
share/golly/Rules/BBM-Margolus-emulated.rule
share/golly/Rules/BriansBrain.rule
share/golly/Rules/Byl-Loop.rule
share/golly/Rules/Caterpillars.rule
share/golly/Rules/Chou-Reggia-1.rule
share/golly/Rules/Chou-Reggia-2.rule
share/golly/Rules/Codd2.rule
share/golly/Rules/Codd.rule
share/golly/Rules/Devore.rule
share/golly/Rules/CrittersMargolus_emulated.rule
share/golly/Rules/DLA-Margolus-emulated.rule
share/golly/Rules/Ed-rep.rule
share/golly/Rules/Evoloop-finite.rule
share/golly/Rules/Evoloop.rule
share/golly/Rules/HPPMargolus_emulated.rule
share/golly/Rules/HPP.rule
share/golly/Rules/LangtonsAnt_LLRR.rule
share/golly/Rules/Langtons-Ant.rule
share/golly/Rules/Langtons-Loops.rule
share/golly/Rules/LifeHistory.rule
share/golly/Rules/LifeOnTheEdge.rule
share/golly/Rules/LifeOnTheSlope.rule
share/golly/Rules/Life.rule
share/golly/Rules/Perrier.rule
share/golly/Rules/Sand-Margolus-emulated.rule
share/golly/Rules/Sand-square4cyclic_emulated.rule
share/golly/Rules/SDSR-Loop.rule
share/golly/Rules/StarWars.rule
share/golly/Rules/Tempesti.rule
share/golly/Rules/TMGasMargolus_emulated.rule
share/golly/Rules/TripATronMargolus_emulated.rule
share/golly/Rules/TriTurmite_120010.rule
share/golly/Rules/Turmite_1202822111121111812a0281282.rule
share/golly/Rules/TableGenerators/make-ruletable.cpp
share/golly/Rules/Turmite_121181121020.rule
share/golly/Rules/Turmite_180121020081.rule
share/golly/Rules/Turmite_181181121010.rule
share/golly/Rules/WireWorld.rule
share/golly/Rules/Worm-1040512.rule
share/golly/Rules/Worm-1042015.rule
share/golly/Rules/Worm-1042020.rule
share/golly/Rules/Worm-1252121.rule
share/golly/Rules/Worm-1525115.rule
share/golly/Rules/Worm-complement.rule
share/golly/Rules/Worm-shared.rule
share/golly/Rules/TreeGenerators/LifeOnTheEdge.cpp
share/golly/Rules/TreeGenerators/LifeOnTheSlope.cpp
share/golly/Rules/TreeGenerators/RuleTreeGen.cpp
share/golly/Rules/TreeGenerators/RuleTreeGen.java
share/golly/Rules/TreeGenerators/RuleTreeGen.lua
share/golly/Rules/TreeGenerators/RuleTreeGen.pl
share/golly/Rules/TreeGenerators/RuleTreeGen.py
share/golly/Scripts/Python/Margolus/convert-MCell-string.py
share/golly/Scripts/Python/Margolus/export.py
share/golly/Scripts/Python/Margolus/import.py
share/golly/Scripts/Python/bricklayer.py
share/golly/Scripts/Python/density.py
share/golly/Scripts/Python/draw-lines.py
share/golly/Scripts/Python/envelope.py
share/golly/Scripts/Python/flood-fill.py
share/golly/Scripts/Python/goto_expression.py
share/golly/Scripts/Python/goto.py
share/golly/Scripts/Python/gun-demo.py
share/golly/Scripts/Python/heisenburp.py
share/golly/Scripts/Python/invert.py
share/golly/Scripts/Python/life-integer-gun30.py
share/golly/Scripts/Python/make-Banks-IV-constructor.py
share/golly/Scripts/Python/make-Codd-constructor.py
share/golly/Scripts/Python/make-Devore-tape.py
share/golly/Scripts/Python/make-torus.py
share/golly/Scripts/Python/metafier.py
share/golly/Scripts/Python/move-object.py
share/golly/Scripts/Python/move-selection.py
share/golly/Scripts/Python/tile.py
share/golly/Scripts/Python/oscar.py
share/golly/Scripts/Python/p1100-MWSS-gun.py
share/golly/Scripts/Python/pd-glider.py
share/golly/Scripts/Python/pop-plot.py
share/golly/Scripts/Python/shift.py
share/golly/Scripts/Python/slide-show.py
share/golly/Scripts/Python/tile-with-clip.py
share/golly/Scripts/Python/Rule-Generators/AbsoluteHexTurmite-gen.py
share/golly/Scripts/Python/Rule-Generators/AbsoluteTurmite-gen.py
share/golly/Scripts/Python/Rule-Generators/FredkinModN-gen.py
share/golly/Scripts/Python/Rule-Generators/HexTurmite-gen.py
share/golly/Scripts/Python/Rule-Generators/icon-exporter.py
share/golly/Scripts/Python/Rule-Generators/icon-importer.py
share/golly/Scripts/Python/Rule-Generators/Langtons-Ant-gen.py
share/golly/Scripts/Python/Rule-Generators/make-ruletree.py
share/golly/Scripts/Python/Rule-Generators/RuleTableToTree.py
share/golly/Scripts/Python/Rule-Generators/TriTurmite-gen.py
share/golly/Scripts/Python/Rule-Generators/Turmite-gen.py
share/golly/Scripts/Python/glife/base.py
share/golly/Scripts/Python/glife/base.pyc
share/golly/Scripts/Python/glife/BuiltinIcons.py
share/golly/Scripts/Python/glife/BuiltinIcons.pyc
share/golly/Scripts/Python/glife/EmulateHexagonal.py
share/golly/Scripts/Python/glife/EmulateMargolus.py
share/golly/Scripts/Python/glife/EmulateOneDimensional.py
share/golly/Scripts/Python/glife/EmulateTriangular.py
share/golly/Scripts/Python/glife/gun24.py
share/golly/Scripts/Python/glife/gun24.pyc
share/golly/Scripts/Python/glife/gun256.py
share/golly/Scripts/Python/glife/gun30.py
share/golly/Scripts/Python/glife/gun30.pyc
share/golly/Scripts/Python/glife/gun46.py
share/golly/Scripts/Python/glife/gun46.pyc
share/golly/Scripts/Python/glife/herschel.py
share/golly/Scripts/Python/glife/__init__.py
share/golly/Scripts/Python/glife/__init__.pyc
share/golly/Scripts/Python/glife/ReadRuleTable.py
share/golly/Scripts/Python/glife/RuleTree.py
share/golly/Scripts/Python/glife/text.py
share/golly/Scripts/Python/glife/text.pyc
share/golly/Scripts/Python/glife/WriteBMP.py
share/golly/Scripts/Python/glife/WriteRuleTable.py
share/golly/Scripts/Lua/oplus/images/lifeviewer.png
share/golly/Scripts/Lua/oplus/sounds/README.txt
share/golly/Scripts/Lua/oplus/init.lua
share/golly/Scripts/Lua/oplus/init.lua~
share/golly/Scripts/Lua/gplus/guns.lua
share/golly/Scripts/Lua/gplus/init.lua
share/golly/Scripts/Lua/gplus/objects.lua
share/golly/Scripts/Lua/gplus/strict.lua
share/golly/Scripts/Lua/gplus/text.lua
share/golly/Scripts/Lua/breakout.lua
share/golly/Scripts/Lua/bricklayer.lua
share/golly/Scripts/Lua/browse-patterns.lua
share/golly/Scripts/Lua/density.lua
share/golly/Scripts/Lua/draw-lines.lua
share/golly/Scripts/Lua/envelope.lua
share/golly/Scripts/Lua/flood-fill.lua
share/golly/Scripts/Lua/giffer.lua
share/golly/Scripts/Lua/goto.lua
share/golly/Scripts/Lua/gun-demo.lua
share/golly/Scripts/Lua/heisenburp.lua
share/golly/Scripts/Lua/hexgrid.lua
share/golly/Scripts/Lua/invert.lua
share/golly/Scripts/Lua/life-integer-gun30.lua
share/golly/Scripts/Lua/lifeviewer.lua
share/golly/Scripts/Lua/make-torus.lua
share/golly/Scripts/Lua/metafier.lua
share/golly/Scripts/Lua/move-object.lua
share/golly/Scripts/Lua/move-selection.lua
share/golly/Scripts/Lua/oscar.lua
share/golly/Scripts/Lua/overlay-demo.lua
share/golly/Scripts/Lua/p1100-MWSS-gun.lua
share/golly/Scripts/Lua/pd-glider.lua
share/golly/Scripts/Lua/pop-plot.lua
share/golly/Scripts/Lua/shift.lua
share/golly/Scripts/Lua/slide-show.lua
share/golly/Scripts/Lua/tile.lua
share/golly/Scripts/Lua/tile-with-clip.lua
share/golly/Scripts/Lua/toLifeHistory.lua
share/golly/Scripts/Lua/toLife.lua
share/golly/Help/images/about.gif
share/golly/Help/images/blend0.png
share/golly/Help/images/blend1.png
share/golly/Help/images/clips.png
share/golly/Help/images/hex.png
share/golly/Help/images/layers.png
share/golly/Help/images/lifeviewer.png
share/golly/Help/images/theme.png
share/golly/Help/images/transforms.png
share/golly/Help/Lexicon/lex_1.htm
share/golly/Help/Lexicon/lex_a.htm
share/golly/Help/Lexicon/lex_b.htm
share/golly/Help/Lexicon/lex_bib.htm
share/golly/Help/Lexicon/lex_c.htm
share/golly/Help/Lexicon/lex_d.htm
share/golly/Help/Lexicon/lex_e.htm
share/golly/Help/Lexicon/lex_f.htm
share/golly/Help/Lexicon/lex_g.htm
share/golly/Help/Lexicon/lex_h.htm
share/golly/Help/Lexicon/lex.htm
share/golly/Help/Lexicon/lex_i.htm
share/golly/Help/Lexicon/lex_j.htm
share/golly/Help/Lexicon/lex_k.htm
share/golly/Help/Lexicon/lex_l.htm
share/golly/Help/Lexicon/lex_m.htm
share/golly/Help/Lexicon/lex_n.htm
share/golly/Help/Lexicon/lex_o.htm
share/golly/Help/Lexicon/lex_p.htm
share/golly/Help/Lexicon/lex_q.htm
share/golly/Help/Lexicon/lex_r.htm
share/golly/Help/Lexicon/lex_s.htm
share/golly/Help/Lexicon/lex_t.htm
share/golly/Help/Lexicon/lex_u.htm
share/golly/Help/Lexicon/lex_v.htm
share/golly/Help/Lexicon/lex_w.htm
share/golly/Help/Lexicon/lex_x.htm
share/golly/Help/Lexicon/lex_y.htm
share/golly/Help/Lexicon/lex_z.htm
share/golly/Help/Lexicon/modify.pl
share/golly/Help/about.html
share/golly/Help/algos.html
share/golly/Help/archives.html
share/golly/Help/bounded.html
share/golly/Help/changes.html
share/golly/Help/changes.html~
share/golly/Help/control.html
share/golly/Help/credits.html
share/golly/Help/edit.html
share/golly/Help/file.html
share/golly/Help/formats.html
share/golly/Help/help.html
share/golly/Help/index.html
share/golly/Help/intro.html
share/golly/Help/layer.html
share/golly/Help/lifeviewer.html
share/golly/Help/lua.html
share/golly/Help/lua.html~
share/golly/Help/mouse.html
share/golly/Help/overlay.html
share/golly/Help/python.html
share/golly/Help/problems.html
share/golly/Help/refs.html
share/golly/Help/tips.html
share/golly/Help/view.html
share/golly/Help/Algorithms/extended.png
share/golly/Help/Algorithms/Generations.html
share/golly/Help/Algorithms/HashLife.html
share/golly/Help/Algorithms/hensel.png
share/golly/Help/Algorithms/JvN.html
share/golly/Help/Algorithms/Larger_than_Life.html
share/golly/Help/Algorithms/QuickLife.html
share/golly/Help/Algorithms/RuleLoader.html

7
golly/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (golly-3.0-src.tar.gz) = 61ba555428be9772e8a270edce9ced4994253632
RMD160 (golly-3.0-src.tar.gz) = 0418dba6dffef4c8764842e8282286d83e93a997
SHA512 (golly-3.0-src.tar.gz) = 6c89d621b42ab9118592127c493c8a44730744d75b4ae07452d9ab1729e9109fb43812062c0db47fb42bc3b0b7fc1d8242492ccb72d7a1a5c0da77c2ae26e716
Size (golly-3.0-src.tar.gz) = 4745596 bytes
SHA1 (patch-cmdline_bgolly.cpp) = 15dda14dabffe6e79c125f439c01022257b532ab

View file

@ -0,0 +1,33 @@
$NetBSD$
popcount() is declared in <strings.h> included from <string.h>.
--- cmdline/bgolly.cpp.orig 2017-08-19 04:39:59.000000000 +0000
+++ cmdline/bgolly.cpp
@@ -115,7 +115,7 @@ struct options {
} ;
bigint maxgen = -1, inc = 0 ;
int maxmem = 256 ;
-int hyper, render, autofit, quiet, popcount, progress ;
+int hyper, render, autofit, quiet, xpopcount, progress ;
int hashlife ;
char *algoName = 0 ;
int verbose ;
@@ -143,7 +143,7 @@ options options[] = {
{ "-t", "--timeline", "Use timeline", 'b', &timeline },
{ "", "--render", "Render (benchmarking)", 'b', &render },
{ "", "--progress", "Render during progress dialog (debugging)", 'b', &progress },
- { "", "--popcount", "Popcount (benchmarking)", 'b', &popcount },
+ { "", "--popcount", "Popcount (benchmarking)", 'b', &xpopcount },
{ "", "--scale", "Rendering scale", 's', &renderscale },
//{ "", "--stepthreshold", "Stepsize >= gencount/this (default 1)",
// 'i', &stepthresh },
@@ -627,7 +627,7 @@ case 's':
else
cout << endl ;
}
- if (popcount)
+ if (xpopcount)
imp->getPopulation() ;
if (autofit)
imp->fit(viewport, 1) ;