Import hyperrogue-35.

You are a lone outsider in a strange, non-Euclidean world. You can
move with the numpad, vi keys (hjklyubn), or mouse. You can also
skip turns by pressing ".".

As a Rogue, your goal is to collect as many treasures as possible.
However, collecting treasures attracts dangerous monsters (on the
other hand, killing the monsters allows more treasures to be
generated).

You can kill most monsters by moving into them. Similarly, if the
monster was next to you at the end of your turn, it would kill you.
The game protects you from getting yourself killed accidentally by
ignoring moves which lead to instant death (similar to the check
rule from Chess).

Ultimately, you will probably run into a situation where monsters
surround you. That means that your adventure is over, and you will
have to teleport back to the Euclidean world to survive by pressing
Escape (quit).

Collecting enough treasure also allows you to find rare magical
orbs, which grant you one-time or time-limited special abilities.

TODO:

Dumps core on startup somewhere in SDL_TTF.
This commit is contained in:
Thomas Klausner 2012-05-07 11:09:31 +00:00
parent 98e6c8c7af
commit 441a9449f1
6 changed files with 71 additions and 0 deletions

22
hyperrogue/DESCR Normal file
View file

@ -0,0 +1,22 @@
You are a lone outsider in a strange, non-Euclidean world. You can
move with the numpad, vi keys (hjklyubn), or mouse. You can also
skip turns by pressing ".".
As a Rogue, your goal is to collect as many treasures as possible.
However, collecting treasures attracts dangerous monsters (on the
other hand, killing the monsters allows more treasures to be
generated).
You can kill most monsters by moving into them. Similarly, if the
monster was next to you at the end of your turn, it would kill you.
The game protects you from getting yourself killed accidentally by
ignoring moves which lead to instant death (similar to the check
rule from Chess).
Ultimately, you will probably run into a situation where monsters
surround you. That means that your adventure is over, and you will
have to teleport back to the Euclidean world to survive by pressing
Escape (quit).
Collecting enough treasure also allows you to find rare magical
orbs, which grant you one-time or time-limited special abilities.

29
hyperrogue/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1.1.1 2012/05/07 11:09:31 thomasklausner Exp $
#
DISTNAME= hyperrogue-35
CATEGORIES= games
MASTER_SITES= http://www.roguetemple.com/z/
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.roguetemple.com/z/hyper.php
COMMENT= Rogue clone in a strange, non-Euclidean world
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c++
USE_TOOLS+= gmake pkg-config
BUILD_TARGET= hyper
INSTALLATION_DIRS= bin share/doc/hyperrogue
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hyper ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/hyperrogue.html ${DESTDIR}${PREFIX}/share/doc/hyperrogue
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/SDL_gfx/buildlink3.mk"
.include "../../devel/SDL_ttf/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
hyperrogue/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2012/05/07 11:09:31 thomasklausner Exp $
bin/hyper
share/doc/hyperrogue/hyperrogue.html

1
hyperrogue/TODO Normal file
View file

@ -0,0 +1 @@
Dumps core on startup somewhere in SDL_TTF.

6
hyperrogue/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2012/05/07 11:09:31 thomasklausner Exp $
SHA1 (hyperrogue-35.zip) = 867393f85c2d72dac0d07c908e45d617a893ae5c
RMD160 (hyperrogue-35.zip) = 268be944ea6bd23dd82fb4b13f675d371da1c095
Size (hyperrogue-35.zip) = 588364 bytes
SHA1 (patch-Makefile) = b175e10285e1acafccbabacb81bc78dbf31b731d

View file

@ -0,0 +1,10 @@
$NetBSD: patch-Makefile,v 1.1.1.1 2012/05/07 11:09:31 thomasklausner Exp $
Fix linking with support libraries (missing rpath).
--- Makefile.orig 2012-05-03 12:14:38.000000000 +0000
+++ Makefile
@@ -1,2 +1,2 @@
hyper: hyper.cpp graph.cpp hyperpoint.cpp geometry.cpp cell.cpp heptagon.cpp game.cpp classes.cpp polygons.cpp
- g++ hyper.cpp -o hyper -lSDL -lSDL_ttf -DFHS -Wall -g -lSDL_gfx -O3
+ g++ hyper.cpp -o hyper `pkg-config --libs sdl` `pkg-config --libs SDL_ttf` -DFHS -Wall -g `pkg-config --libs SDL_gfx` -O3