Import p5-AI-Prolog-0.739 as wip/p5-AI-Prolog.
AI::Prolog is a pure Perl predicate logic engine. In predicate logic, instead of telling the computer how to do something, you tell the computer what something is and let it figure out how to do it. Conceptually this is similar to regular expressions.
This commit is contained in:
parent
5bcb66f1de
commit
4ad5c9778a
6 changed files with 76 additions and 0 deletions
5
p5-AI-Prolog/DESCR
Normal file
5
p5-AI-Prolog/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
AI::Prolog is a pure Perl predicate logic engine.
|
||||
In predicate logic, instead of telling the computer
|
||||
how to do something, you tell the computer what
|
||||
something is and let it figure out how to do it.
|
||||
Conceptually this is similar to regular expressions.
|
27
p5-AI-Prolog/Makefile
Normal file
27
p5-AI-Prolog/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/08/08 11:25:35 athaba Exp $
|
||||
#
|
||||
|
||||
DISTNAME= AI-Prolog-0.739
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= perl5 lang
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=AI/}
|
||||
|
||||
MAINTAINER= athaba@inode.at
|
||||
HOMEPAGE= http://search.cpan.org/dist/AI-Prolog
|
||||
COMMENT= Pure Perl predicate logic engine
|
||||
|
||||
DEPENDS+= p5-Clone>=0.15:../../devel/p5-Clone
|
||||
DEPENDS+= p5-Exporter-Tidy>=0.06:../../wip/p5-Exporter-Tidy
|
||||
DEPENDS+= p5-Hash-AsObject>=0.05:../../wip/p5-Hash-AsObject
|
||||
DEPENDS+= p5-Regexp-Common>=2.119:../../textproc/p5-Regexp-Common
|
||||
DEPENDS+= p5-Term-ReadKey>=2.21:../../devel/p5-Term-ReadKey
|
||||
DEPENDS+= p5-Term-ReadLine>=1.01:../../devel/p5-Term-ReadLine
|
||||
DEPENDS+= p5-Text-Balanced>=1.95:../../textproc/p5-Text-Balanced
|
||||
DEPENDS+= p5-Text-Quote>=0.03:../../wip/p5-Text-Quote
|
||||
DEPENDS+= p5-aliased>=0.11:../../wip/p5-aliased
|
||||
|
||||
PERL5_PACKLIST= auto/AI/Prolog/.packlist
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
p5-AI-Prolog/PLIST
Normal file
2
p5-AI-Prolog/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2008/08/08 11:25:35 athaba Exp $
|
||||
bin/aiprolog
|
4
p5-AI-Prolog/TODO
Normal file
4
p5-AI-Prolog/TODO
Normal file
|
@ -0,0 +1,4 @@
|
|||
TODO:
|
||||
|
||||
Add an options.mk to handle the
|
||||
installation of bin/aiprolog
|
6
p5-AI-Prolog/distinfo
Normal file
6
p5-AI-Prolog/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/08/08 11:25:35 athaba Exp $
|
||||
|
||||
SHA1 (AI-Prolog-0.739.tar.gz) = 0329feeb965e1b5d77a10f45d121a5d752c7654e
|
||||
RMD160 (AI-Prolog-0.739.tar.gz) = 8afe8d1a00424809d710b72952e52bba11b4f6c6
|
||||
Size (AI-Prolog-0.739.tar.gz) = 69954 bytes
|
||||
SHA1 (patch-aa) = d1c06727e4f705140fd3ec6b5d7c16f0f05391cd
|
32
p5-AI-Prolog/patches/patch-aa
Normal file
32
p5-AI-Prolog/patches/patch-aa
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/08/08 11:25:35 athaba Exp $
|
||||
|
||||
--- Makefile.PL.orig 2007-05-03 06:31:18.000000000 +0200
|
||||
+++ Makefile.PL
|
||||
@@ -1,22 +1,12 @@
|
||||
use ExtUtils::MakeMaker;
|
||||
-use ExtUtils::MakeMaker qw/WriteMakefile prompt/;
|
||||
|
||||
my ( @program, @extra_modules );
|
||||
-print <<"END_NOTE";
|
||||
|
||||
-The 'aiprolog' shell is optional. If you choose to install it, Term::ReadLine
|
||||
-and Term::ReadKey will be added to your list of prerequisites.
|
||||
-
|
||||
-END_NOTE
|
||||
-
|
||||
-if (prompt( "Do you wish to install the 'aiprolog' shell?", "y" ) =~ /^[Yy]/ )
|
||||
-{
|
||||
- @program = ( EXE_FILES => ["bin/aiprolog"] );
|
||||
- @extra_modules = (
|
||||
- 'Term::ReadLine' => 1.01,
|
||||
- 'Term::ReadKey' => 2.21,
|
||||
- );
|
||||
-}
|
||||
+@program = ( EXE_FILES => ["bin/aiprolog"] );
|
||||
+@extra_modules = (
|
||||
+ 'Term::ReadLine' => 1.01,
|
||||
+ 'Term::ReadKey' => 2.21,
|
||||
+);
|
||||
|
||||
WriteMakefile(
|
||||
'NAME' => 'AI::Prolog',
|
Loading…
Reference in a new issue