Initial import of AlphaMail 1.0.44:

AlphaMail is a mod_perl webmail solution with a C++ middleware component
that is intended to make the system highly scalable. It is written using
C++, perl, and HTML::Mason, and accesses mail stores through IMAPS. It
is in active production use at the University of Oregon, and currently
supports many *NIX variants with any RFC-compliant IMAP server including
UW, Cyrus, and Dovecot.
This commit is contained in:
Sergey Svishchev 2008-02-12 11:36:28 +00:00 committed by Thomas Klausner
parent f8f102424a
commit 4cf9cfcbbd
10 changed files with 494 additions and 0 deletions

6
alphamail/DESCR Normal file
View file

@ -0,0 +1,6 @@
AlphaMail is a mod_perl webmail solution with a C++ middleware component
that is intended to make the system highly scalable. It is written using
C++, perl, and HTML::Mason, and accesses mail stores through IMAPS. It
is in active production use at the University of Oregon, and currently
supports many *NIX variants with any RFC-compliant IMAP server including
UW, Cyrus, and Dovecot.

48
alphamail/Makefile Normal file
View file

@ -0,0 +1,48 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/02/12 11:36:28 shattered Exp $
#
DISTNAME= alphamail-1.0.44
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=alphamail/}
MAINTAINER= shattered@users.sourceforge.net
HOMEPAGE= http://alphamail.sourceforge.net/
COMMENT= Highly scalable webmail with middleware component
DEPENDS+= p5-HTML-Mason>=1.30:../../www/p5-HTML-Mason
DEPENDS+= p5-CGI>=3.20:../../www/p5-CGI
# hacked
DEPENDS+= p5-Apache-AuthCookie>=3.10:../../www/p5-Apache-AuthCookie
DEPENDS+= p5-Apache-Session>=1.6:../../www/p5-Apache-Session
DEPENDS+= p5-MIME-tools>=5.4:../../mail/p5-MIME-tools
DEPENDS+= p5-MIME-Types>=1.16:../../mail/p5-MIME-Types
DEPENDS+= p5-HTML-Parser>=3.45:../../www/p5-HTML-Parser
DEPENDS+= p5-Log-Log4perl>=0.47:../../wip/p5-Log-Log4perl
DEPENDS+= p5-Unicode-String>=2.0:../../converters/p5-Unicode-String
DEPENDS+= p5-Unicode-Collate>=0.52:../../wip/p5-Unicode-Collate
DEPENDS+= p5-Crypt-CBC>=2.14:../../security/p5-Crypt-CBC
DEPENDS+= p5-Crypt-CAST5>=0.04:../../wip/p5-Crypt-CAST5
DEPENDS+= p5-Text-Aspell>=0.04:../../wip/p5-Text-Aspell
DEPENDS+= p5-Time-HiRes>=1.59:../../time/p5-Time-HiRes
DEPENDS+= p5-Digest-MD5>=2.0:../../security/p5-Digest-MD5
DEPENDS+= p5-Date-Calc>=5.4:../../devel/p5-Date-Calc
DEPENDS+= p5-Email-Date>=1.03:../../mail/p5-Email-Date
DEPENDS+= p5-Email-AddressParser>=0.04:../../wip/p5-Email-AddressParser
DEPENDS+= p5-Encode-IMAPUTF7>=1.00:../../wip/p5-Encode-IMAPUTF7
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= perl
PTHREAD_AUTO_VARS= yes
REPLACE_PERL= util/alphamail_genconfig util/alphamail_stats \
util/garbage_sweeper util/hang_detector
RCD_SCRIPTS= imap_webcache
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../www/ap2-perl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

289
alphamail/PLIST Normal file
View file

@ -0,0 +1,289 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
lib/alphamail/AlphaMail.pm
lib/alphamail/AlphaMail/AddressBook.pm
lib/alphamail/AlphaMail/AdminAccessRule.pm
lib/alphamail/AlphaMail/AdminUsers.pm
lib/alphamail/AlphaMail/Config.pm
lib/alphamail/AlphaMail/Filter.pm
lib/alphamail/AlphaMail/HTMLHelper.pm
lib/alphamail/AlphaMail/MailTool.pm
lib/alphamail/AlphaMail/Message.pm
lib/alphamail/AlphaMail/Middleware.pm
lib/alphamail/AlphaMail/Preferences.pm
lib/alphamail/AlphaMail/Quota.pm
lib/alphamail/AlphaMail/RequestHandler.pm
lib/alphamail/AlphaMail/SAPMConfig.pm
lib/alphamail/AlphaMail/SessionUtil.pm
lib/alphamail/AlphaMail/Signature.pm
lib/alphamail/AlphaMail/SpamConfig.pm
lib/alphamail/Apache2/SiteControl.pm
lib/alphamail/Apache2/SiteControl/GrantAllRule.pm
lib/alphamail/Apache2/SiteControl/ManagerFactory.pm
lib/alphamail/Apache2/SiteControl/PermissionManager.pm
lib/alphamail/Apache2/SiteControl/Rule.pm
lib/alphamail/Apache2/SiteControl/User.pm
lib/alphamail/Apache2/SiteControl/UserFactory.pm
lib/alphamail/Encode/IMAPUTF7.pm
lib/alphamail/IMAPAuth.pm
lib/alphamail/ManagerFactory.pm
libexec/sandbox
sbin/alphamail_genconfig
sbin/alphamail_stats
sbin/garbage_sweeper
sbin/imap_webcache
share/alphamail/conf/README
share/alphamail/conf/alphamail.conf
share/alphamail/conf/init.pl
share/alphamail/conf/log4perl.conf
share/alphamail/docs/About
share/alphamail/docs/AlphamailAdmin.pod
share/alphamail/docs/Dependencies
share/alphamail/docs/build.sh
share/alphamail/docs/caching_algorithm
share/alphamail/docs/certificate_authorities.pem
share/alphamail/docs/middleware_protocol.txt
share/alphamail/docs/notes/OSX
share/alphamail/docs/notes/SunStudio
share/alphamail/docs/notes/debugging
share/alphamail/htdocs/download.html
share/alphamail/htdocs/error.html
share/alphamail/htdocs/filevault.html
share/alphamail/htdocs/index.html
share/alphamail/htdocs/mail/address_mail.html
share/alphamail/htdocs/mail/addressbook/edit.mhtml
share/alphamail/htdocs/mail/addressbook/export_csv.html
share/alphamail/htdocs/mail/addressbook/import.mhtml
share/alphamail/htdocs/mail/addressbook/import_complete.html
share/alphamail/htdocs/mail/addressbook/import_csv.html
share/alphamail/htdocs/mail/addressbook/import_csv_save.html
share/alphamail/htdocs/mail/addressbook/import_fname.html
share/alphamail/htdocs/mail/addressbook/import_imho.html
share/alphamail/htdocs/mail/addressbook/import_lname.html
share/alphamail/htdocs/mail/addressbook/index.html
share/alphamail/htdocs/mail/addressbook/lists.mhtml
share/alphamail/htdocs/mail/addressbook/process_edit.html
share/alphamail/htdocs/mail/addressbook/process_lists.html
share/alphamail/htdocs/mail/addressbook/process_take.html
share/alphamail/htdocs/mail/addressbook/take.html
share/alphamail/htdocs/mail/addresslist.html
share/alphamail/htdocs/mail/admin/autohandler
share/alphamail/htdocs/mail/admin/guide.html
share/alphamail/htdocs/mail/admin/index.html
share/alphamail/htdocs/mail/admin/quotas.jpg
share/alphamail/htdocs/mail/admin/show_stats.mhtml
share/alphamail/htdocs/mail/admin/test.mhtml
share/alphamail/htdocs/mail/autohandler
share/alphamail/htdocs/mail/check_spelling.html
share/alphamail/htdocs/mail/compose.html
share/alphamail/htdocs/mail/docs/faq/attach1.gif
share/alphamail/htdocs/mail/docs/faq/attach2.gif
share/alphamail/htdocs/mail/docs/faq/attach3.gif
share/alphamail/htdocs/mail/docs/faq/colors.gif
share/alphamail/htdocs/mail/docs/faq/dates1.gif
share/alphamail/htdocs/mail/docs/faq/drafts.gif
share/alphamail/htdocs/mail/docs/faq/filter.gif
share/alphamail/htdocs/mail/docs/faq/index.html
share/alphamail/htdocs/mail/docs/faq/notrash1.gif
share/alphamail/htdocs/mail/docs/faq/notrash2.gif
share/alphamail/htdocs/mail/docs/faq/notrash3.gif
share/alphamail/htdocs/mail/docs/faq/other.html
share/alphamail/htdocs/mail/docs/faq/sort.gif
share/alphamail/htdocs/mail/docs/faq/timeout.gif
share/alphamail/htdocs/mail/docs/index.html
share/alphamail/htdocs/mail/docs/new_features.html
share/alphamail/htdocs/mail/feedback.html
share/alphamail/htdocs/mail/first_login.html
share/alphamail/htdocs/mail/fix_spelling.html
share/alphamail/htdocs/mail/folderlist.mhtml
share/alphamail/htdocs/mail/footer.mhtml
share/alphamail/htdocs/mail/get_attachment.html
share/alphamail/htdocs/mail/header.mhtml
share/alphamail/htdocs/mail/help.html
share/alphamail/htdocs/mail/index.html
share/alphamail/htdocs/mail/logout.html
share/alphamail/htdocs/mail/menu.mhtml
share/alphamail/htdocs/mail/other_folders.html
share/alphamail/htdocs/mail/process_compose.html
share/alphamail/htdocs/mail/process_first_login.html
share/alphamail/htdocs/mail/process_messages.html
share/alphamail/htdocs/mail/process_read_message.html
share/alphamail/htdocs/mail/process_search.html
share/alphamail/htdocs/mail/quota.html
share/alphamail/htdocs/mail/quota_graph.html
share/alphamail/htdocs/mail/raw.html
share/alphamail/htdocs/mail/read.html
share/alphamail/htdocs/mail/remove_attachment.html
share/alphamail/htdocs/mail/renew_session.html
share/alphamail/htdocs/mail/resume_compose.html
share/alphamail/htdocs/mail/sanitized.html
share/alphamail/htdocs/mail/search.html
share/alphamail/htdocs/mail/search_results.html
share/alphamail/htdocs/mail/settings/add_filter.html
share/alphamail/htdocs/mail/settings/altfolder_update.html
share/alphamail/htdocs/mail/settings/altprefix_update.html
share/alphamail/htdocs/mail/settings/edit_folders.html
share/alphamail/htdocs/mail/settings/export.mhtml
share/alphamail/htdocs/mail/settings/export_mail.html
share/alphamail/htdocs/mail/settings/export_verify.html
share/alphamail/htdocs/mail/settings/filters.mhtml
share/alphamail/htdocs/mail/settings/folders.mhtml
share/alphamail/htdocs/mail/settings/general.mhtml
share/alphamail/htdocs/mail/settings/index.html
share/alphamail/htdocs/mail/settings/share.mhtml
share/alphamail/htdocs/mail/settings/sharing_agree.html
share/alphamail/htdocs/mail/settings/signatures.mhtml
share/alphamail/htdocs/mail/settings/spam.mhtml
share/alphamail/htdocs/mail/settings/update_filters.html
share/alphamail/htdocs/mail/settings/update_folderlist.html
share/alphamail/htdocs/mail/settings/update_general.html
share/alphamail/htdocs/mail/settings/update_signatures.html
share/alphamail/htdocs/mail/settings/update_spam.html
share/alphamail/htdocs/mail/share_options.html
share/alphamail/htdocs/mail/share_upload.html
share/alphamail/htdocs/mail/verify_password.html
share/alphamail/htdocs/mail/view_attachment.html
share/alphamail/htdocs/mail/viewers/excel.html
share/alphamail/htdocs/mail/viewers/html.html
share/alphamail/htdocs/mail/viewers/targz.html
share/alphamail/htdocs/mail/viewers/text.html
share/alphamail/htdocs/mail/viewers/word.html
share/alphamail/htdocs/mail/viewers/zip.html
share/alphamail/htdocs/static/amail_icon.jpg
share/alphamail/htdocs/static/amail_large.jpg
share/alphamail/htdocs/static/bell.wav
share/alphamail/htdocs/static/default.css
share/alphamail/htdocs/static/paperclip.png
share/alphamail/htdocs/static/rte/blank.htm
share/alphamail/htdocs/static/rte/html2xhtml.js
share/alphamail/htdocs/static/rte/images/bgcolor.gif
share/alphamail/htdocs/static/rte/images/blackdot.gif
share/alphamail/htdocs/static/rte/images/bold.gif
share/alphamail/htdocs/static/rte/images/centre.gif
share/alphamail/htdocs/static/rte/images/copy.gif
share/alphamail/htdocs/static/rte/images/cut.gif
share/alphamail/htdocs/static/rte/images/email.gif
share/alphamail/htdocs/static/rte/images/hr.gif
share/alphamail/htdocs/static/rte/images/hyperlink.gif
share/alphamail/htdocs/static/rte/images/image.gif
share/alphamail/htdocs/static/rte/images/indent.gif
share/alphamail/htdocs/static/rte/images/insert_table.gif
share/alphamail/htdocs/static/rte/images/italic.gif
share/alphamail/htdocs/static/rte/images/justifyfull.gif
share/alphamail/htdocs/static/rte/images/left_just.gif
share/alphamail/htdocs/static/rte/images/list.gif
share/alphamail/htdocs/static/rte/images/numbered_list.gif
share/alphamail/htdocs/static/rte/images/outdent.gif
share/alphamail/htdocs/static/rte/images/paste.gif
share/alphamail/htdocs/static/rte/images/redo.gif
share/alphamail/htdocs/static/rte/images/right_just.gif
share/alphamail/htdocs/static/rte/images/smiley.gif
share/alphamail/htdocs/static/rte/images/spellcheck.gif
share/alphamail/htdocs/static/rte/images/textcolor.gif
share/alphamail/htdocs/static/rte/images/underline.gif
share/alphamail/htdocs/static/rte/images/undo.gif
share/alphamail/htdocs/static/rte/insert_link.htm
share/alphamail/htdocs/static/rte/insert_table.htm
share/alphamail/htdocs/static/rte/multi.htm
share/alphamail/htdocs/static/rte/palette.htm
share/alphamail/htdocs/static/rte/richtext.js
share/alphamail/htdocs/static/rte/richtext_compressed.js
share/alphamail/htdocs/static/rte/rte.css
share/alphamail/htdocs/static/wick.css
share/alphamail/htdocs/static/wick.js
share/alphamail/htdocs/static/wz_tooltip.js
share/alphamail/tests/Makefile
share/alphamail/tests/README
share/alphamail/tests/cache/append
share/alphamail/tests/cache/clear_inbox
share/alphamail/tests/cache/filters
share/alphamail/tests/cache/folders
share/alphamail/tests/cache/messagelists
share/alphamail/tests/cache/messagemoves
share/alphamail/tests/cache/search
share/alphamail/tests/cache/setup
share/alphamail/tests/cache/test
share/alphamail/tests/interface/addlist
share/alphamail/tests/interface/attachments
share/alphamail/tests/interface/autobcc
share/alphamail/tests/interface/compose
share/alphamail/tests/interface/contacts
share/alphamail/tests/interface/drafts
share/alphamail/tests/interface/faq.txt
share/alphamail/tests/interface/first_login
share/alphamail/tests/interface/flagstest
share/alphamail/tests/interface/folders
share/alphamail/tests/interface/forwardtest
share/alphamail/tests/interface/helplink
share/alphamail/tests/interface/index
share/alphamail/tests/interface/init
share/alphamail/tests/interface/largefile
share/alphamail/tests/interface/leftmenu
share/alphamail/tests/interface/linkify
share/alphamail/tests/interface/login
share/alphamail/tests/interface/logout
share/alphamail/tests/interface/multiplesessions
share/alphamail/tests/interface/njs_login
share/alphamail/tests/interface/readoptions
share/alphamail/tests/interface/sendtest
share/alphamail/tests/interface/sorting
share/alphamail/tests/interface/soundnotification
share/alphamail/tests/interface/spellcheck
share/alphamail/tests/interface/test
share/alphamail/tests/interface/util.pm
share/alphamail/tests/lib/TestUser.pm
share/alphamail/tests/lib/address_book
share/alphamail/tests/lib/mail_tools
share/alphamail/tests/lib/message/base
share/alphamail/tests/lib/message/resources/html
share/alphamail/tests/lib/message/resources/iso2022-jp
share/alphamail/tests/lib/message/resources/tarfile
share/alphamail/tests/lib/message/resources/utf8-body
share/alphamail/tests/lib/message/resources/utf8-jp
share/alphamail/tests/lib/message/resources/utf8-jp-img
share/alphamail/tests/lib/message/runtests
share/alphamail/tests/lib/message/send_fails
share/alphamail/tests/lib/signatures
share/alphamail/tests/lib/spam_config
share/alphamail/tests/lib/test
share/alphamail/tests/lib/urlbuilder
share/alphamail/tests/resources/hurricane.gif
share/alphamail/tests/resources/hurricane.jpg
share/alphamail/tests/resources/lightning.gif
share/alphamail/tests/resources/lightning.jpg
share/alphamail/tests/resources/lightning.png
share/alphamail/tests/resources/lightning.tif
share/alphamail/tests/resources/splash.gif
share/alphamail/tests/resources/splash.jpg
share/alphamail/tests/test
share/alphamail/util/hang_detector
share/alphamail/util/init.d/alphamail_tmpfs
share/alphamail/util/init.d/imap_webcache
share/examples/rc.d/imap_webcache
@dirrm share/alphamail/util/init.d
@dirrm share/alphamail/util
@dirrm share/alphamail/tests/resources
@dirrm share/alphamail/tests/lib/message/resources
@dirrm share/alphamail/tests/lib/message
@dirrm share/alphamail/tests/lib
@dirrm share/alphamail/tests/interface
@dirrm share/alphamail/tests/cache
@dirrm share/alphamail/tests
@dirrm share/alphamail/htdocs/static/rte/images
@dirrm share/alphamail/htdocs/static/rte
@dirrm share/alphamail/htdocs/static
@dirrm share/alphamail/htdocs/mail/viewers
@dirrm share/alphamail/htdocs/mail/settings
@dirrm share/alphamail/htdocs/mail/docs/faq
@dirrm share/alphamail/htdocs/mail/docs
@dirrm share/alphamail/htdocs/mail/admin
@dirrm share/alphamail/htdocs/mail/addressbook
@dirrm share/alphamail/htdocs/mail
@dirrm share/alphamail/htdocs
@dirrm share/alphamail/docs/notes
@dirrm share/alphamail/docs
@dirrm share/alphamail/conf
@dirrm lib/alphamail/Encode
@dirrm lib/alphamail/Apache2/SiteControl
@dirrm lib/alphamail/Apache2
@dirrm lib/alphamail/AlphaMail
@dirrm lib/alphamail

1
alphamail/TODO Normal file
View file

@ -0,0 +1 @@
- requires modified www/p5-Apache-AuthCookie (one that depends on apache 2)

9
alphamail/distinfo Normal file
View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
SHA1 (alphamail-1.0.44.tar.gz) = c45c09da9acc56f974fe314f6cd0d1d4e92ad683
RMD160 (alphamail-1.0.44.tar.gz) = 6f033b51328e6d31ff9d768e00bccce42024c1f5
Size (alphamail-1.0.44.tar.gz) = 1820218 bytes
SHA1 (patch-aa) = c2aef91e89d5bca1e43a037983fac3ca404ef901
SHA1 (patch-ab) = 4896c0cf9e43d26dc9332fee7cfef7ff1f0a19e2
SHA1 (patch-ac) = a5e21c79b640884dd1d601576dfb0a9d23f1c5f9
SHA1 (patch-ad) = e8cf09a562cbbce39e1bce93a3c2e00b4045503e

View file

@ -0,0 +1,29 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: imap_webcache.sh,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
#
# AlphaMail IMAP cache daemon
#
# PROVIDE: imap_webcache
# REQUIRE: DAEMON
# BEFORE: apache
# KEYWORD: shutdown
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
fi
name="imap_webcache"
rcvar=$name
command="@PREFIX@/sbin/${name}"
pidfile="@VARBASE@/run/${name}.pid"
command_args="--pidfile $pidfile"
if [ -f /etc/rc.subr -a -f /etc/rc.conf \
-a -d /etc/rc.d -a -f /etc/rc.d/DAEMON ]; then
load_rc_config $name
run_rc_command "$1"
else
@ECHO@ -n " ${name}"
${command} ${command_args}
fi

View file

@ -0,0 +1,58 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
--- configure.orig Fri Jul 13 13:34:26 2007
+++ configure
@@ -7107,7 +7107,7 @@ if test "${ac_cv_lib_boost_thread_abort+
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lboost_thread $LIBS"
+LIBS="-lboost_thread-mt $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -7170,7 +7170,7 @@ if test $ac_cv_lib_boost_thread_abort =
#define HAVE_LIBBOOST_THREAD 1
_ACEOF
- LIBS="-lboost_thread $LIBS"
+ LIBS="-lboost_thread-mt $LIBS"
fi
@@ -7181,7 +7181,7 @@ if test "${ac_cv_lib_boost_regex_abort+s
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lboost_regex $LIBS"
+LIBS="-lboost_regex-mt $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -7244,7 +7244,7 @@ if test $ac_cv_lib_boost_regex_abort = y
#define HAVE_LIBBOOST_REGEX 1
_ACEOF
- LIBS="-lboost_regex $LIBS"
+ LIBS="-lboost_regex-mt $LIBS"
fi
@@ -7255,7 +7255,7 @@ if test "${ac_cv_lib_boost_date_time_abo
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lboost_date_time $LIBS"
+LIBS="-lboost_date_time-mt $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -7318,7 +7318,7 @@ if test $ac_cv_lib_boost_date_time_abort
#define HAVE_LIBBOOST_DATE_TIME 1
_ACEOF
- LIBS="-lboost_date_time $LIBS"
+ LIBS="-lboost_date_time-mt $LIBS"
fi

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
--- imap_webcache/Makefile.in.orig Mon Apr 23 21:22:11 2007
+++ imap_webcache/Makefile.in
@@ -185,7 +185,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
uninstall-info-am:
install-nobase_dist_alphamailDATA: $(nobase_dist_alphamail_DATA)
@$(NORMAL_INSTALL)
- test -z "$(alphamaildir)" || $(mkdir_p) "$(DESTDIR)$(alphamaildir)"
+ test -z "$(alphamaildir)/docs" || $(mkdir_p) "$(DESTDIR)$(alphamaildir)/docs"
@$(am__vpath_adj_setup) \
list='$(nobase_dist_alphamail_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ac,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
--- lib/Makefile.in.orig Mon Apr 23 21:22:12 2007
+++ lib/Makefile.in
@@ -202,7 +202,9 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
uninstall-info-am:
install-nobase_dist_alphamaillibDATA: $(nobase_dist_alphamaillib_DATA)
@$(NORMAL_INSTALL)
- test -z "$(alphamaillibdir)" || $(mkdir_p) "$(DESTDIR)$(alphamaillibdir)"
+ for dir in AlphaMail Apache2 Apache2/SiteControl Unicode; do \
+ test -z "$(DESTDIR)$(alphamaillibdir)/$$dir" || $(mkdir_p) "$(DESTDIR)$(alphamaillibdir)/$$dir"; \
+ done
@$(am__vpath_adj_setup) \
list='$(nobase_dist_alphamaillib_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
@@ -258,8 +260,8 @@ check-am: all-am
check: check-am
all-am: Makefile $(DATA)
installdirs:
- for dir in "$(DESTDIR)$(alphamaillibdir)"; do \
- test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ for dir in AlphaMail Apache2 Apache2/SiteControl Unicode; do \
+ test -z "$$dir" || $(mkdir_p) "$(DESTDIR)$(alphamaillibdir)/$$dir"; \
done
install: install-am
install-exec: install-exec-am

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ad,v 1.1.1.1 2008/02/12 11:36:29 shattered Exp $
--- Makefile.in.orig Mon Apr 23 21:22:12 2007
+++ Makefile.in
@@ -451,7 +451,9 @@ uninstall-dist_sbinSCRIPTS:
uninstall-info-am:
install-nobase_dist_alphamailDATA: $(nobase_dist_alphamail_DATA)
@$(NORMAL_INSTALL)
- test -z "$(alphamaildir)" || $(mkdir_p) "$(DESTDIR)$(alphamaildir)"
+ for m in aux conf docs docs/notes htdocs htdocs/mail htdocs/mail/addressbook htdocs/mail/admin htdocs/mail/docs htdocs/mail/docs/faq htdocs/mail/settings htdocs/mail/viewers htdocs/static htdocs/static/rte htdocs/static/rte/images tests tests/cache tests/interface tests/lib tests/lib/message tests/lib/message/resources tests/resources util util/init.d; do \
+ test -z "$(alphamaildir)/$$m" || $(mkdir_p) "$(DESTDIR)$(alphamaildir)/$$m"; \
+ done
@$(am__vpath_adj_setup) \
list='$(nobase_dist_alphamail_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \