Import thrift-0.9.3 as wip/thrift.
The Apache Thrift software framework, for scalable cross-language services development, combines a software stack with a code generation engine to build services that work efficiently and seamlessly between C++, Java, Python, PHP, Ruby, Erlang, Perl, Haskell, C#, Cocoa, JavaScript, Node.js, Smalltalk, OCaml and Delphi and other languages.
This commit is contained in:
parent
cdbdf14e78
commit
4df556ea4f
6 changed files with 83 additions and 0 deletions
5
thrift/DESCR
Normal file
5
thrift/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
The Apache Thrift software framework, for scalable cross-language services
|
||||
development, combines a software stack with a code generation engine to build
|
||||
services that work efficiently and seamlessly between C++, Java, Python, PHP,
|
||||
Ruby, Erlang, Perl, Haskell, C#, Cocoa, JavaScript, Node.js, Smalltalk, OCaml
|
||||
and Delphi and other languages.
|
33
thrift/Makefile
Normal file
33
thrift/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# $NetBSD$
|
||||
|
||||
DISTNAME= thrift-0.9.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://archive.apache.org/dist/thrift/${PKGVERSION_NOREV}/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://thrift.apache.org/
|
||||
COMMENT= Framework for cross-language services development
|
||||
LICENSE= apache-2.0
|
||||
|
||||
USE_TOOLS+= pkg-config automake autoconf aclocal lex yacc gmake autoscan autoheader
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
PKGCONFIG_OVERRIDE+= lib/c_glib/thrift_c_glib.pc.in
|
||||
PKGCONFIG_OVERRIDE+= lib/cpp/thrift-nb.pc.in
|
||||
PKGCONFIG_OVERRIDE+= lib/cpp/thrift-qt.pc.in
|
||||
PKGCONFIG_OVERRIDE+= lib/cpp/thrift-z.pc.in
|
||||
PKGCONFIG_OVERRIDE+= lib/cpp/thrift.pc.in
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
pre-configure:
|
||||
${RUN} cd ${WRKSRC} && \
|
||||
autoscan && \
|
||||
libtoolize --copy --automake && \
|
||||
aclocal -I ./aclocal && \
|
||||
autoheader && \
|
||||
autoconf && \
|
||||
automake --copy --add-missing --foreign
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
7
thrift/PLIST
Normal file
7
thrift/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD$
|
||||
bin/thrift
|
||||
include/src/socket.h
|
||||
lib/libluabitwise.la
|
||||
lib/libluabpack.la
|
||||
lib/liblualongnumber.la
|
||||
lib/libluasocket.la
|
8
thrift/distinfo
Normal file
8
thrift/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD$
|
||||
|
||||
SHA1 (thrift-0.9.3.tar.gz) = f1421a0d1e0e107aa549fa83177b965e4d61199d
|
||||
RMD160 (thrift-0.9.3.tar.gz) = 238dfe898808bf2a1c509a565f6678858237d94c
|
||||
SHA512 (thrift-0.9.3.tar.gz) = 743131b276155c2d178404e190bdebcc12cedf42956f3d83177ebb4e4b85768b111a999dcf054594e92c120431323769a9641fc2ff2efade983191afd0786c2c
|
||||
Size (thrift-0.9.3.tar.gz) = 2161165 bytes
|
||||
SHA1 (patch-aclocal_ax__dmd.m4) = f9e0c8d11ae4bf2052adfccc93b0601daf9724e4
|
||||
SHA1 (patch-configure.ac) = 6ec3cf58be687868c42e043c675726332b99124c
|
15
thrift/patches/patch-aclocal_ax__dmd.m4
Normal file
15
thrift/patches/patch-aclocal_ax__dmd.m4
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD$
|
||||
|
||||
Fix portability.
|
||||
|
||||
--- aclocal/ax_dmd.m4.orig 2015-10-01 17:16:28.000000000 +0000
|
||||
+++ aclocal/ax_dmd.m4
|
||||
@@ -67,7 +67,7 @@ AC_DEFUN([AX_DMD],
|
||||
|
||||
# Test whether OPTLINK is used by trying if DMD accepts -L/? without
|
||||
# erroring out.
|
||||
- if test "$success" == "yes" ; then
|
||||
+ if test "$success" = "yes" ; then
|
||||
AC_MSG_CHECKING(whether DMD uses OPTLINK)
|
||||
echo "Running \”$DMD -L/? configtest_ax_dmd.d\"" >&AS_MESSAGE_LOG_FD
|
||||
if $DMD -L/? configtest_ax_dmd.d >&AS_MESSAGE_LOG_FD 2>&1 ; then
|
15
thrift/patches/patch-configure.ac
Normal file
15
thrift/patches/patch-configure.ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD$
|
||||
|
||||
Fix portability.
|
||||
|
||||
--- configure.ac.orig 2015-10-01 17:16:28.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -199,7 +199,7 @@ AM_CONDITIONAL(WITH_C_GLIB, [test "$have
|
||||
AX_THRIFT_LIB(csharp, [C#], yes)
|
||||
if test "$with_csharp" = "yes"; then
|
||||
PKG_CHECK_MODULES(MONO, mono >= 2.11.0, mono_2_11=yes, mono_2_11=no)
|
||||
- if test "$mono_2_11" == "yes"; then
|
||||
+ if test "$mono_2_11" = "yes"; then
|
||||
AC_PATH_PROG([MCS], [mcs])
|
||||
if test "x$MCS" != "x"; then
|
||||
mono_mcs="yes"
|
Loading…
Reference in a new issue