jabberd2 moved to pkgsrc finally! wohooo
This commit is contained in:
parent
ceced4bba6
commit
4f2f7d369b
17 changed files with 0 additions and 698 deletions
|
@ -1,5 +0,0 @@
|
|||
Jabber is an open XML protocol for real-time exchange of messages and
|
||||
presence notification between any two points on the Internet. The first
|
||||
application of Jabber technology is an asynchronous, extensible instant
|
||||
messaging platform, and an IM network that offers functionality similar
|
||||
to legacy IM systems such as AIM, ICQ, MSN, and Yahoo.
|
|
@ -1,181 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.35 2004/03/24 06:47:31 xtraeme Exp $
|
||||
#
|
||||
|
||||
DISTNAME= jabberd-2.0s2
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= http://www.jabberstudio.org/files/jabberd2/
|
||||
|
||||
MAINTAINER= xtraeme@NetBSD.org
|
||||
HOMEPAGE= http://jabberd.jabberstudio.org/2/
|
||||
COMMENT= Instant messaging server (version 2)
|
||||
|
||||
CONFLICTS= jabberd-[0-9]*:../../chat/jabberd
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGINSTALL= yes
|
||||
|
||||
BUILDLINK_DEPENDS.openssl+= openssl>=0.9.6b
|
||||
BUILDLINK_TRANSFORM.db4= -e "s,/db4/,/,g"
|
||||
|
||||
SUBST_CLASSES= path
|
||||
SUBST_STAGE.path= post-patch
|
||||
SUBST_FILES.path= configure
|
||||
SUBST_MESSAGE.path= "Fixing configure script."
|
||||
SUBST_SED.path= -e "s,/usr/local,${PREFIX},g" \
|
||||
-e "s,\$sysconfdir/jabberd,\$sysconfdir,g"
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
#CONFIGURE_ARGS+= --enable-debug
|
||||
|
||||
REPLACE_PERL= tools/pipe-auth.pl
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
BUILD_DEFS+= JABBERD_USER JABBERD_STATIC \
|
||||
JABBERD_AUTH_METHOD JABBERD_STORAGE_METHOD \
|
||||
JABBERD_LOGDIR JABBERD_DBDIR JABBERD_PIDDIR
|
||||
|
||||
# This specify the actual method which will be used for authenticate
|
||||
# the users/accounts.
|
||||
#
|
||||
# JABBERD_AUTH_METOD has 4 available options:
|
||||
#
|
||||
# db (by default)
|
||||
# mysql (MySQL)
|
||||
# openldap (OpenLDAP)
|
||||
# pam (Pluggable Authentication Module)
|
||||
# pgsql (PostgreSQL)
|
||||
|
||||
JABBERD_AUTH_METHOD?= db
|
||||
AUTHREG_MODS="anon pipe ${JABBERD_AUTH_METHOD}"
|
||||
|
||||
.if !empty(JABBERD_AUTH_METHOD:Mdb)
|
||||
CONFIGURE_ARGS+= --enable-authreg=${AUTHREG_MODS}
|
||||
CONFIGURE_ARGS+= --with-berkeley-db=${BUILDLINK_DIR}/include
|
||||
. include "../../databases/db4/buildlink3.mk"
|
||||
. elif !empty(JABBERD_AUTH_METHOD:Mopenldap)
|
||||
CONFIGURE_ARGS+= --enable-authreg=${AUTHREG_MODS}
|
||||
CONFIGURE_ARGS+= --with-openldap=${BUILDLINK_PREFIX.openldap}
|
||||
. include "../../databases/openldap/buildlink3.mk"
|
||||
. elif !empty(JABBERD_AUTH_METHOD:Mpgsql)
|
||||
CONFIGURE_ARGS+= --enable-authreg=${AUTHREG_MODS}
|
||||
CONFIGURE_ARGS+= --with-pgsql=${BUILDLINK_PREFIX.postgresql-lib}
|
||||
. include "../../databases/postgresql-lib/buildlink3.mk"
|
||||
. elif !empty(JABBERD_AUTH_METHOD:Mmysql)
|
||||
CONFIGURE_ARGS+= --enable-authreg=${AUTHREG_MODS}
|
||||
CONFIGURE_ARGS+= --with-mysql=${BUILDLINK_PREFIX.mysql-server}
|
||||
. include "../../databases/mysql-client/buildlink3.mk"
|
||||
. elif !empty(JABBERD_AUTH_METHOD:Mpam)
|
||||
CONFIGURE_ARGS+= --enable-authreg=${AUTHREG_MODS}
|
||||
CONFIGURE_ARGS+= --with-pam=${BUILDLINK_PREFIX.PAM}
|
||||
. include "../../security/PAM/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
# This specify the actual method which will be used to store the accounts
|
||||
# and related information.
|
||||
#
|
||||
# JABBERD_STORAGE_METHOD has 3 available options:
|
||||
#
|
||||
# db (by default)
|
||||
# mysql (MySQL)
|
||||
# pgsql (PostgreSQL)
|
||||
|
||||
JABBERD_STORAGE_METHOD?= db
|
||||
|
||||
.if !empty(JABBERD_STORAGE_METHOD:Mdb)
|
||||
CONFIGURE_ARGS+= --enable-storage=db
|
||||
CONFIGURE_ARGS+= --with-berkeley-db=${BUILDLINK_DIR}/include
|
||||
. include "../../databases/db4/buildlink3.mk"
|
||||
. elif !empty(JABBERD_STORAGE_METHOD:Mmysql)
|
||||
CONFIGURE_ARGS+= --enable-storage=mysql
|
||||
CONFIGURE_ARGS+= --with-mysql=${BUILDLINK_PREFIX.mysql-server}
|
||||
. include "../../databases/mysql-client/buildlink3.mk"
|
||||
. elif !empty(JABBERD_STORAGE_METHOD:Mpgsql)
|
||||
CONFIGURE_ARGS+= --enable-storage=pgsql
|
||||
CONFIGURE_ARGS+= --with-pgsql=${BUILDLINK_PREFIX.postgresql-lib}
|
||||
. include "../../databases/postgresql-lib/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.if defined(JABBERD_STATIC) && !empty(JABBERD_STATIC:M[Yy][Ee][Ss])
|
||||
CONFIGURE_ARGS+= --enable-all-static
|
||||
.endif
|
||||
|
||||
PKG_SYSCONFSUBDIR= jabberd
|
||||
RCD_SCRIPTS= jabberd c2s sm resolver router s2s
|
||||
JABBERD_USER?= jabberd
|
||||
JABBERD_GROUP?= jabberd
|
||||
FILES_SUBST+= JABBERD_USER=${JABBERD_USER}
|
||||
FILES_SUBST+= JABBERD_GROUP=${JABBERD_GROUP}
|
||||
FILES_SUBST+= JABBERD_PIDDIR=${JABBERD_PIDDIR}
|
||||
FILES_SUBST+= JABBERD_LOGDIR=${JABBERD_LOGDIR}
|
||||
PKG_GROUPS= ${JABBERD_GROUP}
|
||||
PKG_USERS= ${JABBERD_USER}:${JABBERD_GROUP}
|
||||
|
||||
BINDIR= ${PREFIX}/bin
|
||||
EGDIR= ${PREFIX}/share/examples/jabberd
|
||||
SUPPORT_FILES= ${EGDIR}/jabberd.cfg ${PKG_SYSCONFDIR}/jabberd.cfg
|
||||
|
||||
FILES= c2s.xml resolver.xml router.xml \
|
||||
router-users.xml s2s.xml sm.xml
|
||||
DBFILES= db-setup.mysql db-setup.pgsql
|
||||
|
||||
.for f in ${FILES}
|
||||
CONF_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
|
||||
.endfor
|
||||
CONF_FILES+= ${EGDIR}/roster.xml ${PKG_SYSCONFDIR}/roster.xml
|
||||
.undef f
|
||||
|
||||
# Directory to store the log files
|
||||
JABBERD_LOGDIR?= /var/log/jabberd
|
||||
# Directory to store the database files
|
||||
JABBERD_DBDIR?= /var/db/jabberd
|
||||
# Directory to store the pid files
|
||||
JABBERD_PIDDIR?= /var/run/jabberd
|
||||
|
||||
.for f in ${JABBERD_LOGDIR} ${JABBERD_DBDIR} ${JABBERD_PIDDIR}
|
||||
OWN_DIRS_PERMS+= ${f} ${JABBERD_USER} ${JABBERD_GROUP} 770
|
||||
.endfor
|
||||
.undef f
|
||||
|
||||
post-extract:
|
||||
.for f in jabberd.cfg ${FILES}
|
||||
@${MV} ${WRKSRC}/etc/${f}.dist.in ${WRKSRC}/etc/${f}.in
|
||||
.endfor
|
||||
.undef f
|
||||
|
||||
pre-configure:
|
||||
.for f in ${FILES}
|
||||
@${SED} \
|
||||
-e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" \
|
||||
-e "s|@PIDDIR@|${JABBERD_PIDDIR}|g" \
|
||||
-e "s|@LOGDIR@|${JABBERD_LOGDIR}|g" \
|
||||
-e "s|@SSLCERTS@|${SSLCERTS}|g" \
|
||||
-e "s|@BINDIR@|${PREFIX}/bin|g" \
|
||||
-e "s|@DBDIR@|${JABBERD_DBDIR}|g" \
|
||||
${WRKSRC}/etc/${f}.in > ${WRKSRC}/etc/${f}
|
||||
.endfor
|
||||
.undef f
|
||||
@${SED} \
|
||||
-e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" \
|
||||
-e "s|@BINDIR@|${PREFIX}/bin|g " \
|
||||
${WRKSRC}/etc/jabberd.cfg.in > ${WRKSRC}/etc/jabberd.cfg
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/etc/templates/roster.xml.dist.in \
|
||||
${EGDIR}/roster.xml
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/tools/pipe-auth.pl ${BINDIR}
|
||||
.for f in ${DBFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/tools/${f} ${EGDIR}
|
||||
.endfor
|
||||
.undef f
|
||||
.for f in jabberd.cfg ${FILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/etc/${f} ${EGDIR}
|
||||
.endfor
|
||||
.undef f
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,31 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2004/03/17 02:19:12 xtraeme Exp $
|
||||
bin/c2s
|
||||
bin/jabberd
|
||||
bin/pipe-auth.pl
|
||||
bin/resolver
|
||||
bin/router
|
||||
bin/s2s
|
||||
bin/sm
|
||||
etc/rc.d/jabberd
|
||||
etc/rc.d/c2s
|
||||
etc/rc.d/resolver
|
||||
etc/rc.d/router
|
||||
etc/rc.d/s2s
|
||||
etc/rc.d/sm
|
||||
man/man8/c2s.8
|
||||
man/man8/jabberd.8
|
||||
man/man8/resolver.8
|
||||
man/man8/router.8
|
||||
man/man8/s2s.8
|
||||
man/man8/sm.8
|
||||
share/examples/jabberd/c2s.xml
|
||||
share/examples/jabberd/db-setup.mysql
|
||||
share/examples/jabberd/db-setup.pgsql
|
||||
share/examples/jabberd/jabberd.cfg
|
||||
share/examples/jabberd/resolver.xml
|
||||
share/examples/jabberd/roster.xml
|
||||
share/examples/jabberd/router-users.xml
|
||||
share/examples/jabberd/router.xml
|
||||
share/examples/jabberd/s2s.xml
|
||||
share/examples/jabberd/sm.xml
|
||||
@dirrm share/examples/jabberd
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.12 2004/03/17 02:19:12 xtraeme Exp $
|
||||
|
||||
SHA1 (jabberd-2.0s2.tar.gz) = bec5f3ab50e383d4d3282fe472e27b049b41badd
|
||||
Size (jabberd-2.0s2.tar.gz) = 780944 bytes
|
||||
SHA1 (patch-aa) = 210389798690b21879282bba64f2e35d47814193
|
||||
SHA1 (patch-ab) = de1c8ec12b55117223bcca2071499c42ab145a34
|
||||
SHA1 (patch-ac) = 312a07fa6772956297789e15025e0ca0fad9ebb7
|
||||
SHA1 (patch-ad) = b7776cbd6553f3b3b2f9b20250b1368f196cb85d
|
||||
SHA1 (patch-ae) = a5edb31af022b682c96ceacee615999f6439662e
|
||||
SHA1 (patch-af) = aad84cbfba7c0519e32df1ed6f31fa8383d73393
|
||||
SHA1 (patch-ag) = 385b520d815368516ceef2383f53ba19ed65961e
|
|
@ -1,35 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: c2s.sh,v 1.3 2004/03/17 05:20:42 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: c2s
|
||||
# REQUIRE: DAEMON
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="c2s"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.xml"
|
||||
extra_commands="reload"
|
||||
command_args="2>&1 >/dev/null &"
|
||||
c2s_user="@JABBERD_USER@"
|
||||
pidfile="@JABBERD_PIDDIR@/${name}.pid"
|
||||
stop_postcmd="remove_pidfile"
|
||||
|
||||
remove_pidfile()
|
||||
{
|
||||
if [ -f @JABBERD_PIDDIR@/${name}.pid ]; then
|
||||
rm -f @JABBERD_PIDDIR@/${name}.pid
|
||||
fi
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${c2s_flags} ${command_args}
|
||||
fi
|
|
@ -1,54 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: jabberd.sh,v 1.7 2004/03/17 02:19:12 xtraeme Exp $
|
||||
#
|
||||
# KEYWORD: nostart
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
rcd_dir=`@DIRNAME@ $0`
|
||||
|
||||
# NOTE: run_rc_command sets $rc_arg
|
||||
#
|
||||
forward_commands()
|
||||
{
|
||||
# Backward compat with NetBSD <1.6:
|
||||
[ -z "$rc_arg" ] && rc_arg=$_arg
|
||||
|
||||
for file in $COMMAND_LIST; do
|
||||
$rcd_dir/$file $rc_arg
|
||||
done
|
||||
}
|
||||
|
||||
reverse_commands()
|
||||
{
|
||||
# Backward compat with NetBSD <1.6:
|
||||
[ -z "$rc_arg" ] && rc_arg=$_arg
|
||||
|
||||
REVCOMMAND_LIST=
|
||||
for file in $COMMAND_LIST; do
|
||||
REVCOMMAND_LIST="$file $REVCOMMAND_LIST"
|
||||
done
|
||||
for file in $REVCOMMAND_LIST; do
|
||||
$rcd_dir/$file $rc_arg
|
||||
done
|
||||
}
|
||||
|
||||
COMMAND_LIST="c2s resolver router s2s sm"
|
||||
|
||||
name="jabberd"
|
||||
start_cmd="forward_commands"
|
||||
stop_cmd="reverse_commands"
|
||||
reload_cmd="forward_commands"
|
||||
status_cmd="forward_commands"
|
||||
extra_commands="reload status"
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
_arg="$1"
|
||||
${start_cmd}
|
||||
fi
|
|
@ -1,35 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: resolver.sh,v 1.3 2004/03/17 05:20:42 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: resolver
|
||||
# REQUIRE: DAEMON c2s
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="resolver"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.xml"
|
||||
extra_commands="reload"
|
||||
command_args="2>&1 > /dev/null &"
|
||||
resolver_user="@JABBERD_USER@"
|
||||
pidfile="@JABBERD_PIDDIR@/${name}.pid"
|
||||
stop_postcmd="remove_pidfile"
|
||||
|
||||
remove_pidfile()
|
||||
{
|
||||
if [ -f @JABBERD_PIDDIR@/${name}.pid ]; then
|
||||
rm -f @JABBERD_PIDDIR@/${name}.pid
|
||||
fi
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${resolver_flags} ${command_args}
|
||||
fi
|
|
@ -1,35 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: router.sh,v 1.3 2004/03/17 05:20:42 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: router
|
||||
# REQUIRE: DAEMON c2s
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="router"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.xml"
|
||||
extra_commands="reload"
|
||||
command_args="2>&1 > /dev/null &"
|
||||
router_user="@JABBERD_USER@"
|
||||
pidfile="@JABBERD_PIDDIR@/${name}.pid"
|
||||
stop_postcmd="remove_pidfile"
|
||||
|
||||
remove_pidfile()
|
||||
{
|
||||
if [ -f @JABBERD_PIDDIR@/${name}.pid ]; then
|
||||
rm -f @JABBERD_PIDDIR@/${name}.pid
|
||||
fi
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${router_flags} ${command_args}
|
||||
fi
|
|
@ -1,35 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: s2s.sh,v 1.3 2004/03/17 05:20:42 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: s2s
|
||||
# REQUIRE: DAEMON c2s
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="s2s"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.xml"
|
||||
extra_commands="reload"
|
||||
command_args="2>&1 > /dev/null &"
|
||||
s2s_user="@JABBERD_USER@"
|
||||
pidfile="@JABBERD_PIDDIR@/${name}.pid"
|
||||
stop_postcmd="remove_pidfile"
|
||||
|
||||
remove_pidfile()
|
||||
{
|
||||
if [ -f @JABBERD_PIDDIR@/${name}.pid ]; then
|
||||
rm -f @JABBERD_PIDDIR@/${name}.pid
|
||||
fi
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${s2s_flags} ${command_args}
|
||||
fi
|
|
@ -1,35 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: sm.sh,v 1.3 2004/03/17 05:20:42 xtraeme Exp $
|
||||
#
|
||||
# PROVIDE: sm
|
||||
# REQUIRE: DAEMON c2s
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="sm"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/${name}.xml"
|
||||
extra_commands="reload"
|
||||
command_args="2>&1 > /dev/null &"
|
||||
sm_user="@JABBERD_USER@"
|
||||
pidfile="@JABBERD_PIDDIR@/${name}.pid"
|
||||
stop_postcmd="remove_pidfile"
|
||||
|
||||
remove_pidfile()
|
||||
{
|
||||
if [ -f @JABBERD_PIDDIR@/${name}.pid ]; then
|
||||
rm -f @JABBERD_PIDDIR@/${name}.pid
|
||||
fi
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${sm_flags} ${command_args}
|
||||
fi
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.7 2004/02/12 06:14:58 xtraeme Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-11-05 01:18:17.000000000 +0100
|
||||
+++ Makefile.in 2003-11-05 01:18:49.000000000 +0100
|
||||
@@ -103,8 +103,8 @@
|
||||
install_sh = @install_sh@
|
||||
EXTRA_DIST = PROTOCOL Doxyfile.in
|
||||
|
||||
-SUBDIRS = ac-helpers etc tools man mio sx util expat idn scod $(JABBERD_SUBDIRS)
|
||||
-DIST_SUBDIRS = ac-helpers etc tools man mio sx util expat idn scod c2s resolver router s2s sm
|
||||
+SUBDIRS = ac-helpers tools man mio sx util expat idn scod $(JABBERD_SUBDIRS)
|
||||
+DIST_SUBDIRS = ac-helpers tools man mio sx util expat idn scod c2s resolver router s2s sm
|
||||
subdir = .
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.6 2004/03/17 02:19:12 xtraeme Exp $
|
||||
|
||||
--- etc/jabberd.cfg.in.orig 2003-09-27 11:12:14.000000000 +0200
|
||||
+++ etc/jabberd.cfg.in 2003-09-27 11:15:29.000000000 +0200
|
||||
@@ -12,8 +12,8 @@
|
||||
# program [ path to config file ]
|
||||
#
|
||||
|
||||
-@jabberd_router_bin@ @sysconfdir@/router.xml
|
||||
-@jabberd_resolver_bin@ @sysconfdir@/resolver.xml
|
||||
-@jabberd_sm_bin@ @sysconfdir@/sm.xml
|
||||
-@jabberd_s2s_bin@ @sysconfdir@/s2s.xml
|
||||
-@jabberd_c2s_bin@ @sysconfdir@/c2s.xml
|
||||
+router @PKG_SYSCONFDIR@/router.xml
|
||||
+resolver @PKG_SYSCONFDIR@/resolver.xml
|
||||
+sm @PKG_SYSCONFDIR@/sm.xml
|
||||
+s2s @PKG_SYSCONFDIR@/s2s.xml
|
||||
+c2s @PKG_SYSCONFDIR@/c2s.xml
|
|
@ -1,49 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.4 2004/02/12 06:14:59 xtraeme Exp $
|
||||
|
||||
--- etc/sm.xml.in.orig 2003-10-08 02:32:20.000000000 +0200
|
||||
+++ etc/sm.xml.in 2003-10-08 02:33:37.000000000 +0200
|
||||
@@ -9,7 +9,7 @@
|
||||
<!-- The process ID file. comment this out if you don't need to know
|
||||
to know the process ID from outside the process (eg for control
|
||||
scripts) -->
|
||||
- <pidfile>@localstatedir@/jabberd/pid/sm.pid</pidfile>
|
||||
+ <pidfile>@PIDDIR@/sm.pid</pidfile>
|
||||
|
||||
<!-- Router connection configuration -->
|
||||
<router>
|
||||
@@ -26,7 +26,7 @@
|
||||
commented out, or the file can't be read, no attempt will be
|
||||
made to establish an encrypted channel with the router. -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
|
||||
<!-- Router connection retry -->
|
||||
@@ -55,7 +55,7 @@
|
||||
|
||||
<!-- If logging to file, this is the filename of the logfile -->
|
||||
<!--
|
||||
- <file>@localstatedir@/jabberd/log/sm.log</file>
|
||||
+ <file>@LOGDIR@/sm.log</file>
|
||||
-->
|
||||
</log>
|
||||
|
||||
@@ -116,7 +116,7 @@
|
||||
<!-- Berkeley DB driver configuration -->
|
||||
<db>
|
||||
<!-- Directory to store database files under -->
|
||||
- <path>@localstatedir@/jabberd/db</path>
|
||||
+ <path>@DBDIR@</path>
|
||||
|
||||
<!-- Synchronize the database to disk after each write. If you
|
||||
disable this, database accesses may be faster, but data may
|
||||
@@ -371,7 +371,7 @@
|
||||
stored in the users data store when they are created. -->
|
||||
<template>
|
||||
<!--
|
||||
- <roster>@sysconfdir@/templates/roster.xml</roster>
|
||||
+ <roster>@PKG_SYSCONFDIR@/roster.xml</roster>
|
||||
-->
|
||||
</template>
|
||||
</user>
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.4 2004/02/12 06:14:59 xtraeme Exp $
|
||||
|
||||
--- etc/s2s.xml.in.orig 2003-10-08 02:31:16.000000000 +0200
|
||||
+++ etc/s2s.xml.in 2003-10-08 02:31:56.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
<!-- The process ID file. comment this out if you don't need to know
|
||||
to know the process ID from outside the process (eg for control
|
||||
scripts) -->
|
||||
- <pidfile>@localstatedir@/jabberd/pid/s2s.pid</pidfile>
|
||||
+ <pidfile>@PIDDIR@/s2s.pid</pidfile>
|
||||
|
||||
<!-- Router connection configuration -->
|
||||
<router>
|
||||
@@ -33,7 +33,7 @@
|
||||
commented out, or the file can't be read, no attempt will be
|
||||
made to establish an encrypted channel with the router. -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
|
||||
<!-- Router connection retry -->
|
||||
@@ -62,7 +62,7 @@
|
||||
|
||||
<!-- if logging to file, this is the filename of the logfile -->
|
||||
<!--
|
||||
- <file>@localstatedir@/jabberd/log/s2s.log</file>
|
||||
+ <file>@LOGDIR@/s2s.log</file>
|
||||
-->
|
||||
</log>
|
||||
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.7 2004/02/12 06:14:59 xtraeme Exp $
|
||||
|
||||
--- etc/router.xml.in.orig 2003-11-05 01:19:46.000000000 +0100
|
||||
+++ etc/router.xml.in 2003-11-05 01:20:44.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
<!-- The process ID file. comment this out if you don't need to know
|
||||
to know the process ID from outside the process (eg for control
|
||||
scripts) -->
|
||||
- <pidfile>@localstatedir@/jabberd/pid/router.pid</pidfile>
|
||||
+ <pidfile>@PIDDIR@/router.pid</pidfile>
|
||||
|
||||
<!-- Log configuration - type is "syslog", "file" or "stdout" -->
|
||||
<log type='syslog'>
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
<!-- If logging to file, this is the filename of the logfile -->
|
||||
<!--
|
||||
- <file>@localstatedir@/jabberd/log/router.log</file>
|
||||
+ <file>@LOGDIR@/router.log</file>
|
||||
-->
|
||||
</log>
|
||||
|
||||
@@ -34,7 +34,7 @@
|
||||
<!-- File containing the user table. This is where the router gets
|
||||
its component and secret information from for component
|
||||
authentication.-->
|
||||
- <users>@sysconfdir@/router-users.xml</users>
|
||||
+ <users>@PKG_SYSCONFDIR@/router-users.xml</users>
|
||||
|
||||
<!-- Shared secret used to identify legacy components (that is,
|
||||
"jabber:component:accept" components that authenticate using
|
||||
@@ -46,7 +46,7 @@
|
||||
connections. If this is commented out, connecting components
|
||||
will not be able to request a SSL-encrypted channel. -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
</local>
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.6 2004/02/12 06:14:59 xtraeme Exp $
|
||||
|
||||
--- etc/resolver.xml.in.orig 2003-10-08 02:27:59.000000000 +0200
|
||||
+++ etc/resolver.xml.in 2003-10-08 02:28:49.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
<!-- The process ID file. comment this out if you don't need to know
|
||||
to know the process ID from outside the process (eg for control
|
||||
scripts) -->
|
||||
- <pidfile>@localstatedir@/jabberd/pid/resolver.pid</pidfile>
|
||||
+ <pidfile>@PIDDIR@/resolver.pid</pidfile>
|
||||
|
||||
<!-- Router connection configuration -->
|
||||
<router>
|
||||
@@ -23,7 +23,7 @@
|
||||
commented out, or the file can't be read, no attempt will be
|
||||
made to establish an encrypted channel with the router. -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
|
||||
<!-- Router connection retry -->
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
<!-- If logging to file, this is the filename of the logfile -->
|
||||
<!--
|
||||
- <file>@localstatedir@/jabberd/log/resolver.log</file>
|
||||
+ <file>@LOGDIR@/resolver.log</file>
|
||||
-->
|
||||
</log>
|
||||
|
|
@ -1,58 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.6 2004/02/12 06:14:59 xtraeme Exp $
|
||||
|
||||
--- etc/c2s.xml.in.orig 2003-11-05 01:21:31.000000000 +0100
|
||||
+++ etc/c2s.xml.in 2003-11-05 01:23:03.000000000 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
<!-- The process ID file. comment this out if you don't need to know
|
||||
to know the process ID from outside the process (eg for control
|
||||
scripts) -->
|
||||
- <pidfile>@localstatedir@/jabberd/pid/c2s.pid</pidfile>
|
||||
+ <pidfile>@PIDDIR@/c2s.pid</pidfile>
|
||||
|
||||
<!-- Router connection configuration -->
|
||||
<router>
|
||||
@@ -23,7 +23,7 @@
|
||||
commented out, or the file can't be read, no attempt will be
|
||||
made to establish an encrypted channel with the router. -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
|
||||
<!-- Router connection retry -->
|
||||
@@ -56,7 +56,7 @@
|
||||
|
||||
<!-- If logging to file, this is the filename of the logfile -->
|
||||
<!--
|
||||
- <file>@localstatedir@/jabberd/log/c2s.log</file>
|
||||
+ <file>@LOGDIR@/c2s.log</file>
|
||||
-->
|
||||
</log>
|
||||
|
||||
@@ -88,7 +88,7 @@
|
||||
connections. If this is commented out, clients will not be
|
||||
offered the STARTTLS stream extension -->
|
||||
<!--
|
||||
- <pemfile>@sysconfdir@/server.pem</pemfile>
|
||||
+ <pemfile>@SSLCERTS@/server.pem</pemfile>
|
||||
-->
|
||||
|
||||
<!-- Older versions of jabberd support encrypted client connections
|
||||
@@ -282,7 +282,7 @@
|
||||
<!-- Berkeley DB module configuration -->
|
||||
<db>
|
||||
<!-- Directory to store database files under -->
|
||||
- <path>@localstatedir@/jabberd/db</path>
|
||||
+ <path>@DBDIR@</path>
|
||||
|
||||
<!-- Synchronize the database to disk after each write. If you
|
||||
disable this, database accesses may be faster, but data may
|
||||
@@ -316,7 +316,7 @@
|
||||
<!-- Pipe module configuration -->
|
||||
<pipe>
|
||||
<!-- Program to execute -->
|
||||
- <exec>@bindir@/pipe-auth.pl</exec>
|
||||
+ <exec>@BINDIR@/pipe-auth.pl</exec>
|
||||
</pipe>
|
||||
|
||||
</authreg>
|
Loading…
Reference in a new issue