Convert to cvs-package.mk
This commit is contained in:
parent
8c5e030617
commit
4f69d20fc4
6 changed files with 66 additions and 46 deletions
|
@ -1,25 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.9 2005/08/11 10:08:21 absd Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2006/02/15 16:08:07 tnn2 Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dclib-0.3.7
|
||||
DISTNAME= dclib
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://download.berlios.de/dcgui/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= tnn@netilium.org
|
||||
MAINTAINER= tnn@nygren.pp.se
|
||||
HOMEPAGE= http://dcgui.berlios.de/
|
||||
COMMENT= Direct Connect P2P library
|
||||
COMMENT= Direct Connect P2P library (cvs version)
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_LIBTOOL= YES
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PKGCONFIG_OVERRIDE+= dclib.pc.in
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../wip/valknut/Makefile.common"
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../archivers/bzip2/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../wip/libootool/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
38
dclib/PLIST
38
dclib/PLIST
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2005/01/11 18:21:35 tnn2 Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2006/02/15 16:08:07 tnn2 Exp $
|
||||
include/dclib/cclient.h
|
||||
include/dclib/cclientssl.h
|
||||
include/dclib/cconfig.h
|
||||
|
@ -12,32 +12,14 @@ include/dclib/chttp.h
|
|||
include/dclib/chublistmanager.h
|
||||
include/dclib/clistenmanager.h
|
||||
include/dclib/cmessagehandler.h
|
||||
include/dclib/core/casyncdns.h
|
||||
include/dclib/core/cbase32.h
|
||||
include/dclib/core/cbase64.h
|
||||
include/dclib/core/cbytearray.h
|
||||
include/dclib/core/cbz.h
|
||||
include/dclib/core/ccallback.h
|
||||
include/dclib/core/cconnection.h
|
||||
include/dclib/core/cdir.h
|
||||
include/dclib/core/cfile.h
|
||||
include/dclib/core/che3.h
|
||||
include/dclib/core/clist.h
|
||||
include/dclib/core/clisten.h
|
||||
include/dclib/core/clogfile.h
|
||||
include/dclib/core/cmanager.h
|
||||
include/dclib/core/cmd4.h
|
||||
include/dclib/core/cmd5.h
|
||||
include/dclib/core/cobject.h
|
||||
include/dclib/core/cplugin.h
|
||||
include/dclib/core/csingleton.h
|
||||
include/dclib/core/csocket.h
|
||||
include/dclib/core/cssl.h
|
||||
include/dclib/core/cstring.h
|
||||
include/dclib/core/cstringlist.h
|
||||
include/dclib/core/cthread.h
|
||||
include/dclib/core/cxml.h
|
||||
include/dclib/core/czlib.h
|
||||
include/dclib/core/filecopy.h
|
||||
include/dclib/core/platform.h
|
||||
include/dclib/core/types.h
|
||||
|
@ -52,8 +34,20 @@ include/dclib/cuserlist.h
|
|||
include/dclib/cutils.h
|
||||
include/dclib/dclib.h
|
||||
include/dclib/dcobject.h
|
||||
include/dclib/dcos.h
|
||||
include/dclib/hash/tiger.h
|
||||
include/dclib/hash/tigertree.h
|
||||
include/dclib/hash/Encoder.h
|
||||
include/dclib/hash/HashValue.h
|
||||
include/dclib/hash/MerkleTree.h
|
||||
include/dclib/hash/TigerHash.h
|
||||
include/dclib/hash/compat.h
|
||||
include/dclib/xfer/cxfercommunication.h
|
||||
include/dclib/xfer/cxferfilecheck.h
|
||||
include/dclib/xfer/cxferfilecopy.h
|
||||
include/dclib/xfer/cxferhandler.h
|
||||
include/dclib/xfer/cxfermanager.h
|
||||
include/dclib/xfer/cxferqueue.h
|
||||
include/dclib/xfer/cxferrequest.h
|
||||
include/dclib/xfer/cxfersharelist.h
|
||||
include/dclib/xfer/cxferusrban.h
|
||||
include/dclib/xfer/cxferusrslot.h
|
||||
lib/libdc.la
|
||||
lib/pkgconfig/dclib.pc
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.4 2005/02/22 08:21:50 tnn2 Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.5 2006/02/15 16:08:07 tnn2 Exp $
|
||||
|
||||
.include "../../wip/valknut/Makefile.version"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
DCLIB_BUILDLINK3_MK:= ${DCLIB_BUILDLINK3_MK}+
|
||||
|
@ -11,13 +13,10 @@ BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ndclib}
|
|||
BUILDLINK_PACKAGES+= dclib
|
||||
|
||||
.if !empty(DCLIB_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.dclib+= dclib>=0.3.7
|
||||
BUILDLINK_DEPENDS.dclib+= dclib>=${VALKNUT_PKG_VERSION}
|
||||
BUILDLINK_PKGSRCDIR.dclib?= ../../wip/dclib
|
||||
.endif # DCLIB_BUILDLINK3_MK
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../archivers/bzip2/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../wip/libootool/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/03/30 11:36:45 tnn2 Exp $
|
||||
$NetBSD: distinfo,v 1.7 2006/02/15 16:08:07 tnn2 Exp $
|
||||
|
||||
SHA1 (dclib-0.3.7.tar.bz2) = b82226c2ec60c655158ddfd63b6480d9f4b952cf
|
||||
RMD160 (dclib-0.3.7.tar.bz2) = 00e20acd20e626466a68a8ee32ca781b274a2cf4
|
||||
Size (dclib-0.3.7.tar.bz2) = 543586 bytes
|
||||
SHA1 (patch-aa) = 75f945cbe1a64b938c7970b5dfb3ecdbb78cb774
|
||||
SHA1 (patch-ab) = b825bb401e892cdeffcd9b154c6f4a70114eed74
|
||||
SHA1 (patch-ac) = 353eed0662889031d6c5fb9ad611a4037471c423
|
||||
|
|
14
dclib/patches/patch-ab
Normal file
14
dclib/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.3 2006/02/15 16:08:07 tnn2 Exp $
|
||||
|
||||
--- admin/detect-autoconf.sh.orig 2006-02-15 15:34:07.000000000 +0100
|
||||
+++ admin/detect-autoconf.sh
|
||||
@@ -95,9 +95,5 @@ checkWhich ()
|
||||
done
|
||||
}
|
||||
|
||||
-checkWhich
|
||||
-checkAutoconf
|
||||
-checkAutoheader
|
||||
-checkAutomakeAclocal
|
||||
|
||||
export WHICH AUTOHEADER AUTOCONF AUTOM4TE AUTOMAKE ACLOCAL
|
21
dclib/patches/patch-ac
Normal file
21
dclib/patches/patch-ac
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/02/15 16:08:07 tnn2 Exp $
|
||||
|
||||
--- dclib/hash/compat.h.orig 2006-02-15 16:20:32.000000000 +0100
|
||||
+++ dclib/hash/compat.h
|
||||
@@ -32,15 +32,7 @@
|
||||
# include <unistd.h>
|
||||
# define HAS_GETOPT
|
||||
# ifndef u_int8_t
|
||||
-# include <asm/types.h>
|
||||
- typedef __s8 int8_t;
|
||||
- typedef __s16 int16_t;
|
||||
- typedef __s32 int32_t;
|
||||
- typedef __s64 int64_t;
|
||||
- typedef __u8 u_int8_t;
|
||||
- typedef __u16 u_int16_t;
|
||||
- typedef __u32 u_int32_t;
|
||||
- typedef __u64 u_int64_t;
|
||||
+# include <stdint.h>
|
||||
# endif
|
||||
|
||||
#endif // _WIN32
|
Loading…
Reference in a new issue