initial import of java-gnujaf

GNU JAF is a framework for declaring what beans operate on what MIME type data.
Content handler beans can be defined to handle particular MIME content. The JAF
unites internet standards for declaring content with JavaBeans?.

The JAF defines two mechanisms within the framework. The first, the file type
map, specifies the MIME content type for a given file. The default
implementation of this uses the UNIX mime.types format to map filename
extensions to MIME types. The second mechanism, the command map, specifies
the actions that can be applied to a given MIME content type. The default
implementation of this uses the standard mailcap format to map actions to
JavaBean? classes. These beans can then view, edit, print, or perform
whatever other action is required on the underlying resource.
This commit is contained in:
pancake ;) 2004-07-17 15:42:29 +00:00 committed by Thomas Klausner
parent a408d0a316
commit 513bb5c040
5 changed files with 51 additions and 0 deletions

12
java-gnujaf/DESCR Normal file
View file

@ -0,0 +1,12 @@
GNU JAF is a framework for declaring what beans operate on what MIME type data.
Content handler beans can be defined to handle particular MIME content. The JAF
unites internet standards for declaring content with JavaBeans?.
The JAF defines two mechanisms within the framework. The first, the file type
map, specifies the MIME content type for a given file. The default
implementation of this uses the UNIX mime.types format to map filename
extensions to MIME types. The second mechanism, the command map, specifies
the actions that can be applied to a given MIME content type. The default
implementation of this uses the standard mailcap format to map actions to
JavaBean? classes. These beans can then view, edit, print, or perform
whatever other action is required on the underlying resource.

19
java-gnujaf/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/07/17 15:42:29 poppnk Exp $
#
DISTNAME= activation-1.0
PKGNAME= java-gnujaf-1.0
CATEGORIES= wip
MASTER_SITES= http://ftp.gnu.org/gnu/classpathx/
MAINTAINER= pancake@phreaker.net
HOMEPAGE= http://ftp.gnu.org/gnu/classpathx/
COMMENT= GNU Java Activation Framework
USE_BUILDLINK3= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
USE_GNU_TOOLS+= make
.include "../../mk/java-env.mk"
.include "../../mk/bsd.pkg.mk"

3
java-gnujaf/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/07/17 15:42:29 poppnk Exp $
share/java/activation.jar
@dirrm share/java

5
java-gnujaf/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/07/17 15:42:29 poppnk Exp $
SHA1 (activation-1.0.tar.gz) = 484347c75c1d2902383d97718d8593a920e514c0
Size (activation-1.0.tar.gz) = 146228 bytes
SHA1 (patch-aa) = 88b22d10cc17adb37f7ec62f507b4692662bba82

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/07/17 15:42:29 poppnk Exp $
--- Makefile.in.orig 2004-07-17 16:33:45.000000000 +0000
+++ Makefile.in 2004-07-17 16:34:04.000000000 +0000
@@ -371,7 +371,7 @@
activation: $(classes)
$(classes): $(dst)/%.class: $(src)/%.java
- $(JAVAC) $(JAVACFLAGS) -classpath $(ACTIVATION_CLASSPATH) -d $(dst) $<
+ $(JAVAC) $(JAVACFLAGS) -classpath $(ACTIVATION_CLASSPATH):${CLASSPATH} -d $(dst) $<
# Documentation