Import pev 0.80

I tried to update it in pkgsrc but it fails to build.
This commit is contained in:
Pierre Pronchery 2017-07-04 19:15:56 +02:00
parent a55e370d73
commit 545e359633
6 changed files with 78 additions and 0 deletions

View file

@ -2615,6 +2615,7 @@ SUBDIR+= peercoin
SUBDIR+= pentagram
SUBDIR+= pessulus
SUBDIR+= petsc
SUBDIR+= pev
SUBDIR+= pgp6
SUBDIR+= pgplot
SUBDIR+= pgstudio

3
pev/DESCR Normal file
View file

@ -0,0 +1,3 @@
pev is a PE file analysis toolkit that includes some nice programs to work with
PE files in many systems. It can be useful for programmers, security analysts
and forensic investigators. It's licensed under GPLv3+ terms.

27
pev/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.4 2016/03/05 11:29:24 jperkin Exp $
#
DISTNAME= pev-0.80
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pev/}
WRKSRC= ${WRKDIR}/pev
MAINTAINER= khorben@defora.org
HOMEPAGE= http://pev.sourceforge.net/
COMMENT= The PE analysis toolkit
LICENSE= gnu-gpl-v3
USE_TOOLS+= gmake
.include "../../mk/bsd.prefs.mk"
MAKE_FLAGS+= DESTDIR=${DESTDIR}
MAKE_FLAGS+= prefix=${PREFIX}
MAKE_FLAGS+= mandir=${PREFIX}/${PKGMANDIR}
AUTO_MKDIRS= yes
.include "../../security/openssl/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

25
pev/PLIST Normal file
View file

@ -0,0 +1,25 @@
@comment $NetBSD: PLIST,v 1.2 2014/12/09 14:37:06 khorben Exp $
bin/ofs2rva
bin/pedis
bin/pehash
bin/pepack
bin/peres
bin/pescan
bin/pesec
bin/pestr
bin/readpe
bin/rva2ofs
lib/libpe.so
lib/libpe.so.1
lib/libpe.so.1.0
man/man1/ofs2rva.1.gz
man/man1/pedis.1.gz
man/man1/pehash.1.gz
man/man1/pepack.1.gz
man/man1/peres.1.gz
man/man1/pescan.1.gz
man/man1/pesec.1.gz
man/man1/pestr.1.gz
man/man1/readpe.1.gz
man/man1/rva2ofs.1.gz
share/pev/userdb.txt

7
pev/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD$
SHA1 (pev-0.80.tar.gz) = 18dcb65269344b5047504cca8598477b33532bab
RMD160 (pev-0.80.tar.gz) = 01ed4fa37c5349397dbd8aa3b592b9657e63acf8
SHA512 (pev-0.80.tar.gz) = d0c8ff8fcd60470899d5dbccfd7a7e4d960da007f42be9c7eab6b22a3d7cf4dde3c3d5cd9c7d70e369164503fb124640cf508ceda3d4792244cf33d11ab83321
Size (pev-0.80.tar.gz) = 921102 bytes
SHA1 (patch-src_plugins.c) = 15a776eb72335f2dc3a0ff28eeb4b0d48fbf3af4

View file

@ -0,0 +1,15 @@
$NetBSD$
Also use ".so" on most BSD systems.
--- src/plugins.c.orig 2017-07-04 17:13:23.000000000 +0000
+++ src/plugins.c
@@ -167,7 +167,7 @@ int plugins_load_all_from_directory(cons
const char *filename = dir_entry->d_name;
// TODO(jweyrich): Use macro conditions for each system: .so, .dylib, .dll
-#if defined(__linux__)
+#if defined(__FreeBSD__) || defined(__linux__) || defined(__NetBSD__) || defined(__OpenBSD__)
const bool possible_plugin = utils_str_ends_with(filename, ".so") != 0;
#elif defined(__APPLE__)
const bool possible_plugin = utils_str_ends_with(filename, ".dylib") != 0;