Update to 9.0-Preview 1.
For a complete list of Changes since 8.50, see http://snapshot.opera.com/unix/u90p1.html
This commit is contained in:
parent
0604098bc2
commit
55a75a89ed
8 changed files with 110 additions and 155 deletions
|
@ -1,4 +1,4 @@
|
|||
Opera7 is powerful if you use the web for work or for entertainment.
|
||||
Opera is powerful if you use the either web for work or for entertainment.
|
||||
Features:
|
||||
* Supports HTML 3.2, 4.0, 4.01; XHTML 1.0; WML 1.3 & 2.0; XML; CSS 1.0, 2.0,
|
||||
2.1, 3.0; EcmaScript ECMA-262 2ed, 3ed (JavaScript 1.3/1.5 Core); DOM 1, 2
|
||||
|
@ -7,7 +7,7 @@ Features:
|
|||
* Proxy server support
|
||||
* File transfer, File upload support
|
||||
* Built-in M2 mail client
|
||||
* Handles cookies
|
||||
* IRC-compatible chat client, Newsreader, and RSS newsfeeds
|
||||
* Hot list, bookmarks and bookmark bar
|
||||
* Unique mouse gestures for easier browsing
|
||||
* Pop-up defense features
|
||||
|
@ -18,3 +18,4 @@ Features:
|
|||
* Customizable toolbar icons
|
||||
* Keyboard link navigation
|
||||
* Printing (PostScript)
|
||||
* Handles cookies
|
||||
|
|
|
@ -1,86 +1,72 @@
|
|||
# $NetBSD: Makefile,v 1.6 2005/09/28 22:35:53 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2005/10/21 19:15:20 ghen Exp $
|
||||
|
||||
DISTNAME= opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}
|
||||
PKGNAME= opera-${OPERA_PKG_VERSION}beta${OPERA_VER_DATE}
|
||||
PKGREVISION= # empty
|
||||
DISTNAME= opera-${OPERA_PKG_VERSION:S/u/pl/}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.panix.com/opera/files/${OPERA_DIR}/ \
|
||||
ftp://ftp.hu-berlin.de/pub/www/opera/${OPERA_DIR}/ \
|
||||
http://ftp.sunet.se/pub/www/clients/Opera/${OPERA_DIR}/ \
|
||||
http://opera.online.no/${OPERA_DIR}/ \
|
||||
ftp://ftp.task.gda.pl/pub/opera/${OPERA_DIR}/ \
|
||||
ftp://ftp.tuwien.ac.at/infosys/browsers/opera/${OPERA_DIR}/ \
|
||||
ftp://ftp.opera.com/pub/opera/${OPERA_DIR}/
|
||||
MASTER_SITES= http://snapshot.opera.com/${OPERA_DIR}/
|
||||
DISTFILES= opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= heinz@NetBSD.org
|
||||
HOMEPAGE= http://www.opera.com/
|
||||
COMMENT= Development version of a small, fast and customizable WWW client
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://snapshot.opera.com/
|
||||
COMMENT= Small, fast and customizable WWW client
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-*-i386 SunOS-*-sparc FreeBSD-*-i386
|
||||
|
||||
LICENSE= opera-license
|
||||
LICENSE= opera-850-license
|
||||
|
||||
NO_CONFIGURE= yes
|
||||
NO_TOOLS= yes
|
||||
USE_LANGUAGES= # empty
|
||||
#PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
NO_CONFIGURE= YES
|
||||
USE_LANGUAGES= # empty
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# A default so lintpkgsrc is happy
|
||||
OPERA_PKG_VERSION= 7.50beta
|
||||
OPERA_LANG= en
|
||||
OPERA_VER_DATE= 20051020
|
||||
OPERA_PKG_VERSION= 9.0
|
||||
OPERA_PKG_VERSION_DIR= 9.0-Preview-1
|
||||
|
||||
.if (${OPSYS} == NetBSD)
|
||||
DEPENDS+= suse_compat>=7.3:../../emulators/${SUSE_DIR_PREFIX}_compat
|
||||
DEPENDS+= suse_freetype2>=7.3:../../emulators/${SUSE_DIR_PREFIX}_freetype2
|
||||
DEPENDS+= suse_libjpeg>=7.3:../../emulators/${SUSE_DIR_PREFIX}_libjpeg
|
||||
DEPENDS+= suse_libpng>=7.3:../../emulators/${SUSE_DIR_PREFIX}_libpng
|
||||
_OPERA_OPSYS?= ${OPSYS}
|
||||
_OPERA_MACHINE_ARCH?= ${MACHINE_ARCH}
|
||||
|
||||
.if (${_OPERA_OPSYS} == NetBSD)
|
||||
DEPENDS+= suse_x11>=7.3:../../emulators/${SUSE_DIR_PREFIX}_x11
|
||||
DEPENDS+= suse_openmotif>=7.3:../../emulators/${SUSE_DIR_PREFIX}_openmotif
|
||||
|
||||
# we need the DIST_SUBDIR=. because of the inclusion of suse's Makefile.common
|
||||
DIST_SUBDIR= .
|
||||
EXTRACT_ONLY= # empty
|
||||
PLIST_SRC= ${WRKDIR}/PLIST_DYNAMIC
|
||||
DIST_SUBDIR= .
|
||||
EXTRACT_ONLY= # empty
|
||||
PLIST_SRC= ${WRKDIR}/PLIST_DYNAMIC
|
||||
|
||||
EXTRACT_SUFX= .rpm
|
||||
OPERA_ARCH= .i386
|
||||
OPERA_LANG= en
|
||||
OPERA_VER_DATE= 20040422
|
||||
OPERA_PKG_VERSION= 7.50
|
||||
OPERA_DIR= linux/${OPERA_PKG_VERSION:S/.//g}/beta1/${OPERA_LANG}/${OPERA_ARCH:S/.//}/static
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1-static-qt
|
||||
OPERA_DIR= unix/${OPERA_PKG_VERSION_DIR}/intel-linux
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION:C/beta.*//:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
|
||||
|
||||
RPMFILES= ${DISTFILES}
|
||||
RPMFILES= ${DISTFILES}
|
||||
RPM2PKGSTRIP= 0
|
||||
|
||||
.elif (${OPSYS} == FreeBSD)
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
.elif (${_OPERA_OPSYS} == FreeBSD)
|
||||
OPERA_ARCH= .i386.freebsd
|
||||
OPERA_LANG= en
|
||||
OPERA_VER_DATE= 20040422
|
||||
OPERA_PKG_VERSION= 7.50
|
||||
OPERA_DIR= unix/freebsd/${OPERA_PKG_VERSION:S/.//g}/beta1/${OPERA_LANG}/static
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1-static-qt
|
||||
OPERA_DIR= unix/${OPERA_PKG_VERSION_DIR}/intel-freebsd
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
|
||||
|
||||
WRKSRC= ${WRKDIR}/opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPE
|
||||
RA_LANG}
|
||||
|
||||
.elif (${OPSYS} == SunOS) && (${MACHINE_ARCH} == sparc)
|
||||
NO_BUILD= yes
|
||||
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
OPERA_ARCH= -sol8-sparc-local
|
||||
OPERA_LANG= en
|
||||
OPERA_VER_DATE= 20040422
|
||||
OPERA_PKG_VERSION= 7.50
|
||||
OPERA_DIR= unix/solaris/${OPERA_PKG_VERSION:S/.//g}/beta1/${OPERA_LANG}/static
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1-static-qt
|
||||
WRKSRC= ${WRKDIR}/opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}
|
||||
|
||||
SOLARIS_INSTALL_ETC_OPERARC?= no
|
||||
BUILD_DEFS+= SOLARIS_INSTALL_ETC_OPERARC
|
||||
OWN_DIRS= ${PREFIX}/share/opera/plugins
|
||||
|
||||
.elif (${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
OPERA_ARCH= -sol8-sparc-local
|
||||
OPERA_DIR= unix/${OPERA_PKG_VERSION_DIR}/sparc-solaris
|
||||
OPERA_DIST_VERSION= ${OPERA_PKG_VERSION:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
|
||||
|
||||
WRKSRC= ${WRKDIR}/opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}
|
||||
|
||||
BUILD_DEFS+= INSTALL_ETC_OPERARC
|
||||
INSTALL_ETC_OPERARC?= no
|
||||
OWN_DIRS= ${PREFIX}/lib/opera/plugins
|
||||
|
||||
. if !empty(SOLARIS_INSTALL_ETC_OPERARC:M[yY][eE][sS])
|
||||
. if !empty(INSTALL_ETC_OPERARC:M[yY][eE][sS])
|
||||
CONF_FILES+= ${PREFIX}/share/opera/config/opera6rc \
|
||||
/etc/opera6rc
|
||||
CONF_FILES+= ${PREFIX}/share/opera/config/opera6rc.fixed \
|
||||
|
@ -88,21 +74,26 @@ CONF_FILES+= ${PREFIX}/share/opera/config/opera6rc.fixed \
|
|||
. endif
|
||||
|
||||
PLIST_SUBST+= OPERA_VER_DATE=${OPERA_VER_DATE}
|
||||
PLIST_SUBST+= OPERA_PKG_VERSION=${OPERA_PKG_VERSION}
|
||||
PLIST_SUBST+= OPERA_PKG_VERSION=${OPERA_PKG_VERSION:C/u.*//}
|
||||
|
||||
SUBST_CLASSES+= opera7
|
||||
SUBST_STAGE.opera7= post-build
|
||||
SUBST_FILES.opera7= man/opera.1
|
||||
SUBST_SED.opera7= -e 's,/usr/,${PREFIX}/,g'
|
||||
.endif
|
||||
|
||||
.if (${OPSYS} == NetBSD)
|
||||
do-patch:
|
||||
@ # the patches do not work here
|
||||
@${TRUE}
|
||||
.if (((${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)) || (${_OPERA_OPSYS} == FreeBSD))
|
||||
NO_BUILD= YES
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
SUBST_CLASSES+= opera
|
||||
SUBST_STAGE.opera= post-build
|
||||
SUBST_FILES.opera= man/opera.1
|
||||
SUBST_SED.opera= -e 's,/usr/,${PREFIX}/,g'
|
||||
|
||||
.endif
|
||||
|
||||
INSTALLATION_DIRS= bin man/man1
|
||||
|
||||
do-build:
|
||||
${SED} -e 's#@EMULDIR@#${EMULDIR}#g' ${FILESDIR}/opera.sh > \
|
||||
.if (${_OPERA_OPSYS} == NetBSD)
|
||||
@ ${SED} -e 's#@EMULDIR@#${EMULDIR}#g' ${FILESDIR}/opera.sh > \
|
||||
${WRKDIR}/opera
|
||||
|
||||
post-install: post-install-manpage
|
||||
|
@ -110,9 +101,13 @@ post-install: post-install-manpage
|
|||
|
||||
.include "../../emulators/suse_linux/Makefile.application"
|
||||
|
||||
.if defined(MANCOMPRESSED) && !empty(MANCOMPRESSED:M[yY][eE][sS])
|
||||
USE_TOOLS+= gzip
|
||||
.endif
|
||||
|
||||
post-install-manpage:
|
||||
# The SuSE common makefile defines "MANCOMPRESSED".
|
||||
. if defined(MANCOMPRESSED)
|
||||
# The SuSE common makefile defines "MANCOMPRESSED=yes".
|
||||
. if defined(MANCOMPRESSED) && !empty(MANCOMPRESSED:M[yY][eE][sS])
|
||||
${GZIP_CMD} ${EMULDIR}/usr/share/man/man1/opera.1
|
||||
${LN} -fs ../../${EMULSUBDIR}/usr/share/man/man1/opera.1.gz \
|
||||
${PREFIX}/man/man1
|
||||
|
@ -122,17 +117,27 @@ post-install-manpage:
|
|||
. endif
|
||||
.endif
|
||||
|
||||
.if ((${OPSYS} == SunOS) && (${MACHINE_ARCH} == sparc)) || (${OPSYS} == FreeBSD)
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
.if (((${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)) || (${_OPERA_OPSYS} == FreeBSD))
|
||||
do-install:
|
||||
@cd ${WRKSRC} && ${ECHO} "n" | PKGSRC_PREFIX=${PREFIX} ./install.sh --prefix=${PREFIX}
|
||||
@${ECHO}
|
||||
@${ECHO} "=> You can ignore any previous lines about '... cannot be prefixed'"
|
||||
@cd ${WRKSRC} && ${ECHO} "n" | ./install.sh --prefix=${PREFIX}
|
||||
@${ECHO} "=> You can ignore any previous lines about opera6rc"
|
||||
@${ECHO}
|
||||
|
||||
post-install:
|
||||
@${INSTALL_MAN} ${WRKSRC}/man/opera.1 ${PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
# regenerate distinfo for all ports supported by this package
|
||||
opera-distinfo:
|
||||
( ${ECHO} '$$'NetBSD'$$'; \
|
||||
${ECHO} ''; \
|
||||
_OPERA_OPSYS=NetBSD ${MAKE} distinfo 1>&2; \
|
||||
${GREP} opera distinfo; \
|
||||
_OPERA_OPSYS=FreeBSD ${MAKE} distinfo 1>&2; \
|
||||
${GREP} opera distinfo; \
|
||||
_OPERA_OPSYS=SunOS _OPERA_MACHINE_ARCH=sparc make distinfo 1>&2; \
|
||||
${GREP} opera distinfo; \
|
||||
) > distinfo.new
|
||||
${MV} -f distinfo.new distinfo
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2005/10/21 19:15:21 ghen Exp $
|
||||
bin/opera
|
||||
man/man1/opera.1
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
@comment $NetBSD: PLIST.FreeBSD,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
@comment $NetBSD: PLIST.FreeBSD,v 1.2 2005/10/21 19:15:21 ghen Exp $
|
||||
bin/opera
|
||||
man/man1/opera.1
|
||||
share/doc/opera/LICENSE
|
||||
share/doc/opera/help
|
||||
share/opera/bin/m2.so
|
||||
share/opera/bin/missingsyms.so
|
||||
share/opera/bin/spellcheck.so
|
||||
share/opera/bin/opera
|
||||
share/opera/bin/works
|
||||
share/opera/chartables.bin
|
||||
|
@ -12,6 +12,7 @@ share/opera/config/opera6rc
|
|||
share/opera/config/opera6rc.fixed
|
||||
share/opera/help/advertising.html
|
||||
share/opera/help/background.png
|
||||
share/opera/help/chat.html
|
||||
share/opera/help/dialogs.html
|
||||
share/opera/help/filetypes.html
|
||||
share/opera/help/fonts.html
|
||||
|
@ -32,6 +33,7 @@ share/opera/help/mouse.html
|
|||
share/opera/help/multimedia.html
|
||||
share/opera/help/network.html
|
||||
share/opera/help/page.html
|
||||
share/opera/help/panels.html
|
||||
share/opera/help/paths.html
|
||||
share/opera/help/personal.html
|
||||
share/opera/help/preferences.html
|
||||
|
@ -63,7 +65,9 @@ share/opera/images/startup1.png
|
|||
share/opera/images/startup2.png
|
||||
share/opera/ini/dialog.ini
|
||||
share/opera/ini/fastforward.ini
|
||||
share/opera/ini/minimal_toolbar.ini
|
||||
share/opera/ini/filehandler.ini
|
||||
share/opera/ini/pluginpath.ini
|
||||
share/opera/ini/spellcheck.ini
|
||||
share/opera/ini/standard_keyboard.ini
|
||||
share/opera/ini/standard_menu.ini
|
||||
share/opera/ini/standard_mouse.ini
|
||||
|
@ -74,6 +78,7 @@ share/opera/java/opera.policy
|
|||
share/opera/jsconsole.html
|
||||
share/opera/lngcode.txt
|
||||
share/opera/locale/en/default.adr
|
||||
share/opera/locale/en/lngcode.txt
|
||||
share/opera/locale/en/search.ini
|
||||
share/opera/locale/english.lng
|
||||
share/opera/opera6.adr
|
||||
|
@ -114,7 +119,7 @@ share/opera/styles/OPF.css
|
|||
@dirrm share/opera/styles/user
|
||||
@dirrm share/opera/styles
|
||||
@dirrm share/opera/skin
|
||||
@dirrm share/opera/plugins
|
||||
@comment @dirrm share/opera/plugins
|
||||
@dirrm share/opera/locale/en
|
||||
@dirrm share/opera/locale
|
||||
@dirrm share/opera/java
|
||||
|
@ -123,4 +128,4 @@ share/opera/styles/OPF.css
|
|||
@dirrm share/opera/help
|
||||
@dirrm share/opera/config
|
||||
@dirrm share/opera/bin
|
||||
@dirrm share/opera
|
||||
@comment @dirrm share/opera
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
@comment $NetBSD: PLIST.SunOS,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
@comment $NetBSD: PLIST.SunOS,v 1.2 2005/10/21 19:15:21 ghen Exp $
|
||||
bin/opera
|
||||
lib/opera/${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1/missingsyms.so
|
||||
lib/opera/${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1/opera
|
||||
lib/opera/${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1/spellcheck.so
|
||||
lib/opera/${OPERA_PKG_VERSION}-${OPERA_VER_DATE}.1/works
|
||||
lib/opera/plugins/libnpp.so
|
||||
lib/opera/plugins/operamotifwrapper
|
||||
lib/opera/plugins/operamotifwrapper-1
|
||||
lib/opera/plugins/operamotifwrapper-2
|
||||
lib/opera/plugins/operamotifwrapper-3
|
||||
lib/opera/plugins/operamotifwrapper-4
|
||||
lib/opera/plugins/operaplugincleaner
|
||||
man/man1/opera.1
|
||||
share/doc/opera/LICENSE
|
||||
|
@ -22,7 +25,6 @@ share/opera/help/fonts.html
|
|||
share/opera/help/glossary.html
|
||||
share/opera/help/help.css
|
||||
share/opera/help/history.html
|
||||
share/opera/help/hotlist.html
|
||||
share/opera/help/index.html
|
||||
share/opera/help/input.html
|
||||
share/opera/help/keyboard.html
|
||||
|
|
|
@ -1,13 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2005/10/21 19:15:21 ghen Exp $
|
||||
|
||||
SHA1 (./opera-7.50-20040422.1-static-qt.i386-en.rpm) = 6c9c7f9835ade208a24d329a06994dca68ff0f1e
|
||||
Size (./opera-7.50-20040422.1-static-qt.i386-en.rpm) = 5227723 bytes
|
||||
SHA1 (./opera-7.50-20040422.1-static-qt.ppc-en.rpm) = caa6c47cbfda349fd7f05faddfb84b158d00ade1
|
||||
Size (./opera-7.50-20040422.1-static-qt.ppc-en.rpm) = 5532498 bytes
|
||||
SHA1 (./opera-7.50-20040422.1-static-qt.sparc-en.rpm) = 3eb0c8987821c78e248e6b749310a61a6a21500f
|
||||
Size (./opera-7.50-20040422.1-static-qt.sparc-en.rpm) = 5283563 bytes
|
||||
SHA1 (opera-7.50-20040422.1-static-qt-sol8-sparc-local-en.tar.bz2) = f9e56cea29be00962197e12555e5355b6704cb70
|
||||
Size (opera-7.50-20040422.1-static-qt-sol8-sparc-local-en.tar.bz2) = 5959864 bytes
|
||||
SHA1 (opera-7.50-20040422.1-static-qt.i386.freebsd-en.tar.bz2) = 706bd42d297f037fc9d973fdf57685178bfe5adb
|
||||
Size (opera-7.50-20040422.1-static-qt.i386.freebsd-en.tar.bz2) = 4765183 bytes
|
||||
SHA1 (patch-aa) = 2a17dd41d9cf67c4e668b2d831ec6437cbcd2f19
|
||||
SHA1 (./opera-9.0-20051020.1-static-qt.i386-en.rpm) = 908041345306a55f12c421f7b81b73d6b74733cf
|
||||
RMD160 (./opera-9.0-20051020.1-static-qt.i386-en.rpm) = e097ea839248d3fbf342e97b02f2eaf892b86047
|
||||
Size (./opera-9.0-20051020.1-static-qt.i386-en.rpm) = 6724180 bytes
|
||||
SHA1 (opera-9.0-20051020.1-static-qt.i386.freebsd-en.tar.gz) = 291d8125f33479286d1e9168627c424ec5d274ae
|
||||
RMD160 (opera-9.0-20051020.1-static-qt.i386.freebsd-en.tar.gz) = 306176addfa3b4fe176c2898297b434c2d8e1cd8
|
||||
Size (opera-9.0-20051020.1-static-qt.i386.freebsd-en.tar.gz) = 6630139 bytes
|
||||
SHA1 (opera-9.0-20051020.1-static-qt-sol8-sparc-local-en.tar.bz2) = 05959b0537cd49f740132abfc7387da3de023ecd
|
||||
RMD160 (opera-9.0-20051020.1-static-qt-sol8-sparc-local-en.tar.bz2) = 1e4c88ead1a5db7024add46ccbb50c57c09d4d2f
|
||||
Size (opera-9.0-20051020.1-static-qt-sol8-sparc-local-en.tar.bz2) = 7660478 bytes
|
||||
|
|
|
@ -1,6 +1,4 @@
|
|||
#!/bin/sh
|
||||
# $NetBSD: opera.sh,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
#
|
||||
LINUX_KERN_OSREL=`/sbin/sysctl -n emul.linux.kern.osrelease 2>/dev/null`
|
||||
if [ -z "$LINUX_KERN_OSREL" -o "$LINUX_KERN_OSREL" = "2.0.38" ]
|
||||
then
|
||||
|
@ -8,7 +6,7 @@ then
|
|||
mkdir -p $OPERADIR || exit 1
|
||||
for FILE in $OPERADIR/opera6.ini $OPERADIR/opera.ini
|
||||
do
|
||||
if [ -e ${FILE} ]
|
||||
if [ -f ${FILE} ]
|
||||
then
|
||||
if grep -q '^Synchronous DNS Lookup=0$' ${FILE}
|
||||
then
|
||||
|
|
|
@ -1,54 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/04/28 22:41:41 kheinz Exp $
|
||||
|
||||
--- install.sh.orig Thu Apr 22 14:53:20 2004
|
||||
+++ install.sh Wed Apr 28 11:39:11 2004
|
||||
@@ -767,6 +767,7 @@
|
||||
case "${machine}:${os}" in
|
||||
i[3456]86:Linux|i[3456]86:FreeBSD|i[3456]86:NetBSD|i[3456]86:OpenBSD)
|
||||
wrapper_plugin_paths="
|
||||
+ ${PKGSRC_PREFIX}/Acrobat[45]/Browsers/intellinux \\
|
||||
/usr/local/Acrobat[45]/Browsers/intellinux \\
|
||||
/usr/lib/Acrobat[45]/Browsers/intellinux \\
|
||||
/usr/X11R6/lib/Acrobat[45]/Browsers/intellinux \\
|
||||
@@ -782,6 +783,7 @@
|
||||
|
||||
sun*:SunOS*|sparc*:SunOS*)
|
||||
wrapper_plugin_paths="
|
||||
+ ${PKGSRC_PREFIX}/Acrobat[45]/Browsers/sparcsolaris \\
|
||||
/opt/Acrobat[45]/Browsers/sparcsolaris \\
|
||||
/usr/local/Acrobat[45]/Browsers/sparcsolaris \\
|
||||
/usr/lib/Acrobat[45]/Browsers/sparcsolaris \\
|
||||
@@ -833,6 +835,7 @@
|
||||
|
||||
# Location of the Opera binaries
|
||||
OPERA_BINARYDIR=${str_localdirexec}
|
||||
+LD_LIBRARY_PATH=\${LD_LIBRARY_PATH}:\${OPERA_BINARYDIR}
|
||||
|
||||
# Parse commandline parameters
|
||||
passflags=''
|
||||
@@ -983,6 +986,7 @@
|
||||
|
||||
# Acrobat Reader
|
||||
for BINDIR in \\
|
||||
+ ${PKGSRC_PREFIX}/Acrobat[45]/bin \\
|
||||
/usr/local/Acrobat[45]/bin \\
|
||||
/usr/lib/Acrobat[45]/bin \\
|
||||
/usr/X11R6/lib/Acrobat[45]/bin \\
|
||||
@@ -1129,7 +1133,7 @@
|
||||
mkdir $mkdirv $mkdirp $doc_dir/
|
||||
chmod $chmodv 755 $doc_dir
|
||||
cp $cpv $cpf LICENSE $doc_dir
|
||||
- if not "test -d $doc_dir/help"; then ln -s $str_localdirshare/help $doc_dir/help; fi
|
||||
+ if not test -d "$doc_dir/help"; then ln -s $str_localdirshare/help $doc_dir/help; fi
|
||||
|
||||
# Shared files
|
||||
debug_msg 1 "Shared files"
|
||||
@@ -1180,7 +1184,7 @@
|
||||
chmod $chmodv 755 $share_dir/styles/user
|
||||
cp $cpv $cpf $cpR styles/user/* $share_dir/styles/user/
|
||||
|
||||
- if not "test -f $share_dir/styles/OPF.css"; then
|
||||
+ if not test -f "$share_dir/styles/OPF.css"; then
|
||||
ln $lns opf.css $share_dir/styles/OPF.css
|
||||
fi
|
||||
|
Loading…
Reference in a new issue