Update to 1.11

Changes:
----
added Dutch translation (by t.c.witte@phys.uu.nl)
added partial Esperanto translation (by mterry@fastmail.fm)
added Romanian translation (by eugenh@urban-grafx.ro)
added Russian translation (by avl@cad.ru)
added missing "include <sys/time.h>" (by netgeek@speakeasy.net)
added missing #defines for solaris (by alan@cesma.usb.ve)
added new icon and install icon family into new location per icon theme spec
fixed disk-full-causes-xpad-contents-to-disappear bug
made pads not show up in taskbar
added 'pads start sticky' option

It's totally ready to import into pkgsrc :)
This commit is contained in:
Juan Romero Pardines 2003-09-02 02:20:27 +00:00
parent 5c460ba6b6
commit 58193ba2e5
4 changed files with 37 additions and 22 deletions

View file

@ -1,18 +1,25 @@
# $NetBSD: Makefile,v 1.3 2003/08/28 09:48:48 xtraeme Exp $
# $NetBSD: Makefile,v 1.4 2003/09/02 02:20:27 xtraeme Exp $
#
DISTNAME= xpad-1.10.1
DISTNAME= xpad-1.11
CATEGORIES= wip
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xpad/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= xtraeme@NetBSD.org
HOMEPAGE= http://xpad.sourceforge.net/
COMMENT= Sticky note application in GTK 2
USE_BUILDLINK2= yes
BUILD_USES_MSGFMT= yes
DEPENDS+= gnome2-dirs>=1.2:../../misc/gnome2-dirs
GNU_CONFIGURE= yes
USE_BUILDLINK2= yes
USE_GMAKE= yes
USE_PKGLOCALEDIR= yes
USE_X11= yes
.include "../../converters/libiconv/buildlink2.mk"
.include "../../x11/gtk2/buildlink2.mk"
.include "../../textproc/intltool/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,21 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/07/15 21:08:42 xtraeme Exp $
@comment $NetBSD: PLIST,v 1.2 2003/09/02 02:20:27 xtraeme Exp $
bin/xpad
man/man1/xpad.1
share/applications/xpad.desktop
share/pixmaps/xpad.xpm
share/icons/hicolor/128x128/apps/xpad.png
share/icons/hicolor/16x16/apps/xpad.png
share/icons/hicolor/22x22/apps/xpad.png
share/icons/hicolor/32x32/apps/xpad.png
share/icons/hicolor/48x48/apps/xpad.png
share/icons/hicolor/64x64/apps/xpad.png
share/icons/hicolor/96x96/apps/xpad.png
share/icons/hicolor/scalable/apps/xpad.svg
${PKGLOCALEDIR}/locale/dk/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/eo/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/ro/LC_MESSAGES/xpad.mo
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/xpad.mo
share/pixmaps/xpad.png

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.2 2003/07/15 22:57:45 blef Exp $
$NetBSD: distinfo,v 1.3 2003/09/02 02:20:27 xtraeme Exp $
SHA1 (xpad-1.10.1.tar.gz) = 3fb35e66792b7507acc5e2f42cdd4bf6774ccb97
Size (xpad-1.10.1.tar.gz) = 293749 bytes
SHA1 (patch-aa) = 60090a8dccdd6acfae54f067deff5fb6b263841c
SHA1 (patch-ab) = d7f8ba8946a1d09fb7c73e80b2b0079926709cb6
SHA1 (xpad-1.11.tar.bz2) = d226fcfd56097849f2cb283c92c318ec17d28ae5
Size (xpad-1.11.tar.bz2) = 235533 bytes
SHA1 (patch-aa) = acad079b9577710aec48c7e41b359b97eeb17b45

View file

@ -1,19 +1,12 @@
$NetBSD: patch-aa,v 1.2 2003/07/15 22:57:45 blef Exp $
$NetBSD: patch-aa,v 1.3 2003/09/02 02:20:28 xtraeme Exp $
--- src/sm.c.orig Wed Mar 26 11:11:23 2003
+++ src/sm.c Tue Jul 15 15:51:36 2003
@@ -25,12 +25,13 @@
--- src/sm.c.orig 2003-09-02 04:09:39.000000000 +0200
+++ src/sm.c 2003-09-02 04:10:05.000000000 +0200
@@ -25,6 +25,7 @@
#include "main.h"
#include <X11/SM/SMlib.h>
#include <stdio.h> /* only for printf */
+#include <sys/types.h> /* for getuid and getpwuid */
+#include <sys/types.h> /* for getuid and getpwuid */
#include <sys/select.h> /* for select */
#include <stdlib.h> /* for free */
#include <string.h> /* for strlen */
#include <unistd.h> /* for getuid */
#include <pwd.h> /* for getpwuid */
-#include <sys/types.h> /* for getuid and getpwuid */
+#include <sys/time.h>
static SmcConn xpad_sm_conn = NULL;
static int xpad_interact_style;