ap-auth-mysql moved to master NetBSD pkgsrc, thanks Quentin!
This commit is contained in:
parent
7ac4b3daba
commit
5b05220330
9 changed files with 2 additions and 225 deletions
5
Makefile
5
Makefile
|
@ -1,5 +1,5 @@
|
|||
# $Id: Makefile,v 1.1390 2004/07/16 01:04:39 schmonz Exp $
|
||||
# $NetBSD: Makefile,v 1.1390 2004/07/16 01:04:39 schmonz Exp $
|
||||
# $Id: Makefile,v 1.1391 2004/07/16 11:36:17 dolecek Exp $
|
||||
# $NetBSD: Makefile,v 1.1391 2004/07/16 11:36:17 dolecek Exp $
|
||||
|
||||
COMMENT= WIP pkgsrc packages
|
||||
|
||||
|
@ -28,7 +28,6 @@ SUBDIR+= amsn
|
|||
SUBDIR+= aols-postgres
|
||||
SUBDIR+= aolserver
|
||||
SUBDIR+= aolserver4
|
||||
SUBDIR+= ap-auth-mysql
|
||||
SUBDIR+= ap-bunzip2
|
||||
SUBDIR+= ap-frontpage
|
||||
SUBDIR+= ap-macro
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
mod_auth_mysql will allow you to use a MySQL database to authenticate users
|
||||
with the Apache HTTP server.
|
|
@ -1,35 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.3 2004/05/14 00:45:33 blef Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libapache-mod-auth-mysql_4.1.7
|
||||
PKGNAME= ${DISTNAME:S/libapache-mod/ap/:S/_/-/}
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/liba/libapache-mod-auth-mysql/}
|
||||
|
||||
MAINTAINER= cube@NetBSD.org
|
||||
HOMEPAGE= http://packages.debian.org/unstable/web/libapache-mod-auth-mysql.html
|
||||
COMMENT= Module to allow Apache authentication against a MySQL database.
|
||||
|
||||
CONFLICTS+= ap2-auth-mysql-*
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-mysql-includes=${BUILDLINK_PREFIX.mysql-client}/include/mysql \
|
||||
--with-mysql-libs=${BUILDLINK_PREFIX.mysql-client}/lib/mysql
|
||||
CPPFLAGS+= -I${BUILDLINK_PREFIX.mysql-client}/include/mysql
|
||||
LDFLAGS+= -lmysqlclient -L${BUILDLINK_PREFIX.mysql-client}/lib/mysql \
|
||||
-Wl,${RPATH_FLAG} -Wl,${BUILDLINK_PREFIX.mysql-client}/lib/mysql
|
||||
|
||||
APACHE_MODULE_NAME= mod_auth_mysql.so
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/mod_auth_mysql
|
||||
${INSTALL_DATA} ${WRKSRC}/DIRECTIVES ${PREFIX}/share/doc/mod_auth_mysql
|
||||
${INSTALL_DATA} ${WRKSRC}/USAGE ${PREFIX}/share/doc/mod_auth_mysql
|
||||
|
||||
.include "../../databases/mysql-client/buildlink3.mk"
|
||||
.include "../../www/apache/module.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,5 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
lib/httpd/mod_auth_mysql.so
|
||||
share/doc/mod_auth_mysql/DIRECTIVES
|
||||
share/doc/mod_auth_mysql/USAGE
|
||||
@dirrm share/doc/mod_auth_mysql
|
|
@ -1,8 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
|
||||
SHA1 (libapache-mod-auth-mysql_4.1.7.tar.gz) = 21814a175e52b07928a49f828e64db19739421f4
|
||||
Size (libapache-mod-auth-mysql_4.1.7.tar.gz) = 49605 bytes
|
||||
SHA1 (patch-aa) = a6e07c72348e46a93a3264d37579dbc5a9e7262b
|
||||
SHA1 (patch-ab) = 0afe885fc1d1b5461b0423eef347fd72511be907
|
||||
SHA1 (patch-ac) = 9375037c029ef3611ea8efccaa834d2091b4c7dd
|
||||
SHA1 (patch-ad) = ea796e555cc2e52af424e2e70484692656095858
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
|
||||
--- config.h.in.orig 2002-11-12 15:18:49.000000000 +0100
|
||||
+++ config.h.in
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
/* Define to 1 if you have the <crypt.h> header file. */
|
||||
#undef HAVE_CRYPT_H
|
||||
+#undef HAVE_LIBCRYPT
|
||||
#undef CRYPT_DES
|
||||
#undef CRYPT_MD5
|
||||
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
|
||||
--- configure.ac.orig 2003-09-24 01:39:03.000000000 +0200
|
||||
+++ configure.ac
|
||||
@@ -84,11 +84,14 @@ AC_SUBST(build_opts, "$mysql_includes $m
|
||||
|
||||
# Checks for header files.
|
||||
AC_CHECK_HEADERS([crypt.h])
|
||||
+AC_CHECK_LIB([crypt], [crypt])
|
||||
|
||||
-if test -n $HAVE_CRYPT_H; then
|
||||
+if test -n $HAVE_CRYPT_H -a $HAVE_LIBCRYPT; then
|
||||
AC_TRY_RUN(
|
||||
[
|
||||
+#ifdef HAVE_CRYPT_H
|
||||
#include <crypt.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
|
||||
int main()
|
||||
@@ -101,7 +104,9 @@ AC_DEFINE(CRYPT_MD5),
|
||||
,,)
|
||||
AC_TRY_RUN(
|
||||
[
|
||||
+#ifdef HAVE_CRYPT_H
|
||||
#include <crypt.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
|
||||
int main()
|
|
@ -1,98 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
|
||||
--- configure.orig 2003-09-24 01:41:07.000000000 +0200
|
||||
+++ configure
|
||||
@@ -2640,7 +2640,72 @@ fi
|
||||
done
|
||||
|
||||
|
||||
-if test -n $HAVE_CRYPT_H; then
|
||||
+echo "$as_me:$LINENO: checking for crypt in -lcrypt" >&5
|
||||
+echo $ECHO_N "checking for crypt in -lcrypt... $ECHO_C" >&6
|
||||
+if test "${ac_cv_lib_crypt_crypt+set}" = set; then
|
||||
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
+else
|
||||
+ ac_check_lib_save_LIBS=$LIBS
|
||||
+LIBS="-lcrypt $LIBS"
|
||||
+cat >conftest.$ac_ext <<_ACEOF
|
||||
+#line $LINENO "configure"
|
||||
+#include "confdefs.h"
|
||||
+
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+#ifdef __cplusplus
|
||||
+extern "C"
|
||||
+#endif
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char crypt ();
|
||||
+#ifdef F77_DUMMY_MAIN
|
||||
+# ifdef __cplusplus
|
||||
+ extern "C"
|
||||
+# endif
|
||||
+ int F77_DUMMY_MAIN() { return 1; }
|
||||
+#endif
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+crypt ();
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
+ (eval $ac_link) 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); } &&
|
||||
+ { ac_try='test -s conftest$ac_exeext'
|
||||
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
+ (eval $ac_try) 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); }; }; then
|
||||
+ ac_cv_lib_crypt_crypt=yes
|
||||
+else
|
||||
+ echo "$as_me: failed program was:" >&5
|
||||
+cat conftest.$ac_ext >&5
|
||||
+ac_cv_lib_crypt_crypt=no
|
||||
+fi
|
||||
+rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
|
||||
+LIBS=$ac_check_lib_save_LIBS
|
||||
+fi
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_lib_crypt_crypt" >&5
|
||||
+echo "${ECHO_T}$ac_cv_lib_crypt_crypt" >&6
|
||||
+if test $ac_cv_lib_crypt_crypt = yes; then
|
||||
+ cat >>confdefs.h <<_ACEOF
|
||||
+#define HAVE_LIBCRYPT 1
|
||||
+_ACEOF
|
||||
+
|
||||
+ LIBS="-lcrypt $LIBS"
|
||||
+
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+if test -n $HAVE_CRYPT_H -a $HAVE_LIBCRYPT; then
|
||||
if test "$cross_compiling" = yes; then
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling" >&5
|
||||
echo "$as_me: error: cannot run test program while cross compiling" >&2;}
|
||||
@@ -2650,7 +2715,9 @@ else
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
+#ifdef HAVE_CRYPT_H
|
||||
#include <crypt.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
|
||||
int main()
|
||||
@@ -2691,7 +2758,9 @@ else
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
+#ifdef HAVE_CRYPT_H
|
||||
#include <crypt.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
|
||||
int main()
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
||||
|
||||
--- mod_auth_mysql.c.orig 2003-11-18 13:59:00.000000000 +0100
|
||||
+++ mod_auth_mysql.c
|
||||
@@ -62,7 +62,7 @@ static int auth_db_override = 1;
|
||||
#define CRYPT_MD5_ENCRYPTION_FLAG 1<<3
|
||||
#endif
|
||||
#define PHP_MD5_ENCRYPTION_FLAG 1<<4
|
||||
-#ifdef HAVE_CRYPT_H
|
||||
+#if defined(HAVE_CRYPT_H) || defined(HAVE_LIBCRYPT)
|
||||
#define CRYPT_ENCRYPTION_FLAG 1<<5
|
||||
#endif
|
||||
|
||||
@@ -94,7 +94,7 @@ static int check_crypt_MD5_encryption(co
|
||||
}
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_CRYPT_H
|
||||
+#if defined(HAVE_CRYPT_H) || defined(HAVE_LIBCRYPT)
|
||||
static int check_crypt_encryption(const char *passwd, char *enc_passwd)
|
||||
{
|
||||
return (!strcmp(crypt(passwd, enc_passwd), enc_passwd));
|
||||
@@ -165,7 +165,9 @@ encryption_type_entry supported_encrypti
|
||||
#if CRYPT_MD5
|
||||
{ "Crypt_MD5", check_crypt_MD5_encryption, CRYPT_MD5_ENCRYPTION_FLAG },
|
||||
#endif
|
||||
+#if defined(HAVE_CRYPT_H) || defined(HAVE_LIBCRYPT)
|
||||
{ "Crypt", check_crypt_encryption, CRYPT_ENCRYPTION_FLAG },
|
||||
+#endif
|
||||
{ "PHP_MD5", check_PHP_MD5_encryption, PHP_MD5_ENCRYPTION_FLAG },
|
||||
/* add additional encryption types below */
|
||||
{ NULL, NULL, 0 }
|
Loading…
Reference in a new issue