Package has been imported into pkgsrc/devel. Deleting wip package.

This commit is contained in:
John R. Shannon 2004-06-01 21:41:44 +00:00 committed by Thomas Klausner
parent 9032129e46
commit 5b0f628f8d
39 changed files with 0 additions and 818 deletions

View file

@ -1,3 +0,0 @@
GDB, the GNU Project debugger, allows you to see what is
going on `inside' another program while it executes -- or
what another program was doing at the moment it crashed.

View file

@ -1,50 +0,0 @@
# $NetBSD: Makefile,v 1.10 2004/06/01 15:48:48 johnrshannon Exp $
#
DISTNAME= gdb-6.1
CATEGORIES= devel
MASTER_SITES= ftp://sources.redhat.com/pub/gdb/releases/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= john@johnrshannon.com
HOMEPAGE= http://www.gnu.org/software/gdb/gdb.html
COMMENT= The GNU Project Debugger
BUILD_USES_MSGFMT= yes
USE_BUILDLINK3= yes
USE_GNU_TOOLS= make
USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
USE_MAKEINFO= yes
INFO_FILES= annotate.info bfd.info configure.info
INFO_FILES+= gdb.info gdbint.info mmalloc.info
INFO_FILES+= stabs.info standards.info
.include "../../mk/bsd.prefs.mk"
BUILD_DEFS= USE_GCC_34
USE_GCC_34?= NO
pre-patch:
${CP} ${FILESDIR}/nbsd-nat.c ${WRKSRC}/gdb
do-test:
if `${PKG_INFO} -qe dejagnu` ;then \
(cd ${WRKSRC} && ${GMAKE} check); \
else \
${ECHO} dejagnu is required for the test target; \
fi
.if !empty(USE_GCC_34:M[Yy][Ee][Ss])
.include "../../wip/gcc-3.4/buildlink3.mk"
pre-configure:
. include "../../wip/gcc-3.4/preconfigure.mk"
.endif
.include "../../wip/libiberty/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,34 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2004/05/13 09:53:34 johnrshannon Exp $
bin/gdb
bin/gdbtui
include/ansidecl.h
include/bfd.h
include/bfdlink.h
include/dis-asm.h
include/symcat.h
lib/libbfd.a
lib/libbfd.la
lib/libiberty.a
lib/libmmalloc.a
lib/libopcodes.a
lib/libopcodes.la
man/man1/gdb.1
man/man1/gdbtui.1
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/id/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/ro/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/ro/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/bfd.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/opcodes.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/bfd.mo

View file

@ -1 +0,0 @@
- Further testing of NetBSD native pthread support is required

View file

@ -1,37 +0,0 @@
$NetBSD: distinfo,v 1.5 2004/06/01 15:48:49 johnrshannon Exp $
SHA1 (gdb-6.1.tar.bz2) = 588c967d164f226ed33eb966e765c046bac066a5
Size (gdb-6.1.tar.bz2) = 12571495 bytes
SHA1 (patch-Makefile_in) = 208bf8aa72b1b307323a2992ef1f5de45af5c54f
SHA1 (patch-Makefile_tpl) = b5c98fc990606e2f5c566864d02565d8fc9adeb4
SHA1 (patch-ax_gdb_c) = bc9a4e5d77d571a6f06b88984fb2030beec37654
SHA1 (patch-cli_cli_decode_c) = 19dbdb326643bf32a3d0c26cfea056cca19deb13
SHA1 (patch-cli_cli_dump_c) = 976cbe2b27c23a113c43cab791562a04d9e6d7e3
SHA1 (patch-cli_cli_script_c) = c53cc22ac5a2c5d5b2c1a7b0825558d8787b2bed
SHA1 (patch-cli_cli_setshow_c) = 048c03512a18f3234422a3afc00d6c45f2dea58d
SHA1 (patch-cli_cmds_c) = 66e40920b5de734cbcf66c0b357e82a74f3c48c0
SHA1 (patch-config_xm_nbsd_h) = a54471bf7cdd42def5e78137df3674988ae3c04b
SHA1 (patch-configure) = ee3c8d6ace35837870cd1df517ab18122af1257c
SHA1 (patch-corelow_c) = 6ae7afb646fe7464b8a3667913ac6681b1df34e6
SHA1 (patch-gdb_configure_in) = 5721068e232c1418bec9a3e7b2dd0d911f841f27
SHA1 (patch-i386_nbsdelf_mh) = 45b48c56f8d3e6ad61644ee02fd04d21c79fba20
SHA1 (patch-i386_nm_nbsd_h) = 11df264e672894836effbb922381dff6abb42aca
SHA1 (patch-i386bsd_nat_c) = 00e6c4298513e237dab5040dcb58e536a5c530e5
SHA1 (patch-i386nbsd_tdep_c) = 6b977d1da6d94ff32bdf1e3627ee534333cc2a79
SHA1 (patch-i387_tdep_c) = 3e41ee1623a52802268d5986559ce7ab742f36e7
SHA1 (patch-inftarg_c) = bf4b1c62b003e65f5810a7d28f8464e936e8d190
SHA1 (patch-mi_mi_cmd_break_c) = d8b8e91f191837fd1b98e23733780ccfecd61b3b
SHA1 (patch-mi_mi_cmd_disas_c) = eef1bd1d5f00a6fc65d81c46063be9983dbe472b
SHA1 (patch-mi_mi_cmd_env_c) = f60be4c062e0df4a31f1795b5d2708065ee368cb
SHA1 (patch-mi_mi_cmd_file_c) = 0595fd12a2dd0f7ec4ec95b74537094ea7314273
SHA1 (patch-mi_mi_cmd_stack_c) = 0ec7cfe9b232caeb1d6fd20fb5fd64f045e68bbf
SHA1 (patch-mi_mi_getopt_c) = 272b4035d1bcde2fadc04a90ad471de681680c34
SHA1 (patch-mi_mi_interp_c) = bacd2687675ccbb7cbc05359323c0bf32f75e9e5
SHA1 (patch-mi_mi_main_c) = edcb6662c891738a0582bbfed151bff3812a5f8d
SHA1 (patch-mi_mi_out_c) = b3f7b9f8a3ad7762637fe9f60a45e50206b713ae
SHA1 (patch-nm_nbsd_h) = cb22084e35ec088a5a2c9153f83e13406e6a8e78
SHA1 (patch-readline_rltty_c) = 63dde49eaf61bf85ce6dae12ec9af33ae4addfb5
SHA1 (patch-remote_c) = 1d61936ee63219576a1d70d154d8696dfe7de29e
SHA1 (patch-remote_fileio_c) = 9c8d886a5b412e64a9a8e6165110a5c336ff65ae
SHA1 (patch-ser_pipe_c) = 840ce6ceb34afea4c8b789c70fb848ad9942ce39
SHA1 (patch-tui_interp_c) = dd353978d62cc45aadf6259e8b5f7b2895317f9c

View file

@ -1,54 +0,0 @@
/* Low level Unix child interface to ptrace, for GDB when running under Unix.
Copyright 1988, 1989, 1990, 1991, 1992, 1993, 1994, 1995, 1996,
1998, 1999, 2000, 2001, 2002
Free Software Foundation, Inc.
This file is part of GDB.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
#include "defs.h"
#include "frame.h"
#include "inferior.h"
#include "target.h"
#include "gdb_string.h"
#include "regcache.h"
#include "gdb_wait.h"
#include "command.h"
#include <sys/types.h>
#include "gdb_dirent.h"
#include <sys/ptrace.h>
#include <machine/reg.h>
#include "i386-tdep.h"
#define ATTACH_DETACH
/* Start debugging the process whose number is PID. */
int
attach (int pid)
{
errno = 0;
if (pid == getpid())
ptrace (PT_TRACE_ME, pid, (PTRACE_ARG3_TYPE) 0, 0);
else
ptrace (PT_ATTACH, pid, (PTRACE_ARG3_TYPE) 0, 0);
if (errno)
perror_with_name ("ptrace");
attach_flag = 1;
return pid;
}

View file

@ -1,13 +0,0 @@
$NetBSD: patch-Makefile_in,v 1.1 2004/06/01 15:48:57 johnrshannon Exp $
--- Makefile.in.orig 2004-06-01 08:06:05.000000000 -0600
+++ Makefile.in
@@ -23853,7 +23853,7 @@ configure-target-zlib: $(ALL_GCC_C)
configure-target-examples: $(ALL_GCC_C)
configure-target-libgloss: $(ALL_GCC)
all-target-libgloss: maybe-configure-target-newlib
-configure-target-libiberty: $(ALL_GCC)
+maybe-configure-target-libiberty: $(ALL_GCC)
configure-target-libtermcap: $(ALL_GCC_C)
configure-target-newlib: $(ALL_GCC)
configure-target-rda: $(ALL_GCC_C)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-Makefile_tpl,v 1.1 2004/06/01 15:48:57 johnrshannon Exp $
--- Makefile.tpl.orig 2004-06-01 08:06:45.000000000 -0600
+++ Makefile.tpl
@@ -1370,7 +1370,7 @@ configure-target-zlib: $(ALL_GCC_C)
configure-target-examples: $(ALL_GCC_C)
configure-target-libgloss: $(ALL_GCC)
all-target-libgloss: maybe-configure-target-newlib
-configure-target-libiberty: $(ALL_GCC)
+maybe-configure-target-libiberty: $(ALL_GCC)
configure-target-libtermcap: $(ALL_GCC_C)
configure-target-newlib: $(ALL_GCC)
configure-target-rda: $(ALL_GCC_C)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ax_gdb_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- gdb/ax-gdb.c.orig 2004-02-06 11:30:47.000000000 -0700
+++ gdb/ax-gdb.c
@@ -743,6 +743,8 @@ gen_usual_unary (struct agent_expr *ax,
case TYPE_CODE_ENUM:
value->type = builtin_type_int;
break;
+ default:
+ ;
}
/* If the value is an lvalue, dereference it. */

View file

@ -1,13 +0,0 @@
$NetBSD: patch-cli_cli_decode_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- ./gdb/cli/cli-decode.c.orig 2004-02-10 12:08:15.000000000 -0700
+++ ./gdb/cli/cli-decode.c
@@ -1207,8 +1207,6 @@ deprecated_cmd_warning (char **text)
struct cmd_list_element *alias = NULL;
struct cmd_list_element *prefix_cmd = NULL;
struct cmd_list_element *cmd = NULL;
- struct cmd_list_element *c;
- char *type;
if (!lookup_cmd_composition (*text, &alias, &prefix_cmd, &cmd))
/* return if text doesn't evaluate to a command */

View file

@ -1,28 +0,0 @@
$NetBSD: patch-cli_cli_dump_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- gdb/cli/cli-dump.c.orig 2004-02-28 11:04:37.000000000 -0700
+++ gdb/cli/cli-dump.c
@@ -72,7 +72,6 @@ scan_expression_with_cleanup (char **cmd
static void
do_fclose_cleanup (void *arg)
{
- FILE *file = arg;
fclose (arg);
}
@@ -233,7 +232,6 @@ dump_memory_to_file (char *cmd, char *mo
void *buf;
char *lo_exp;
char *hi_exp;
- int len;
/* Open the file. */
filename = scan_filename_with_cleanup (&cmd, NULL);
@@ -521,7 +519,6 @@ static void
restore_binary_file (char *filename, struct callback_data *data)
{
FILE *file = fopen_with_cleanup (filename, FOPEN_RB);
- int status;
char *buf;
long len;

View file

@ -1,15 +0,0 @@
$NetBSD: patch-cli_cli_script_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- gdb/cli/cli-script.c.orig 2004-02-25 08:57:42.000000000 -0700
+++ gdb/cli/cli-script.c
@@ -1071,9 +1071,8 @@ define_command (char *comname, int from_
CMD_POST_HOOK
};
struct command_line *cmds;
- struct cmd_list_element *c, *newc, *oldc, *hookc = 0;
+ struct cmd_list_element *c, *newc, *hookc = 0;
char *tem = comname;
- char *tem2;
char tmpbuf[MAX_TMPBUF];
int hook_type = CMD_NO_HOOK;
int hook_name_size = 0;

View file

@ -1,13 +0,0 @@
$NetBSD: patch-cli_cli_setshow_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- gdb/cli/cli-setshow.c.orig 2004-02-28 11:04:37.000000000 -0700
+++ gdb/cli/cli-setshow.c
@@ -276,8 +276,6 @@ do_setshow_command (char *arg, int from_
{
case var_string:
{
- unsigned char *p;
-
if (*(unsigned char **) c->var)
fputstr_filtered (*(unsigned char **) c->var, '"', stb->stream);
quote = 1;

View file

@ -1,21 +0,0 @@
$NetBSD: patch-cli_cmds_c,v 1.1 2004/05/07 08:50:18 johnrshannon Exp $
--- gdb/cli/cli-cmds.c.orig 2004-02-28 11:04:37.000000000 -0700
+++ gdb/cli/cli-cmds.c
@@ -225,7 +225,6 @@ compare_strings (const void *arg1, const
static void
complete_command (char *arg, int from_tty)
{
- int i;
int argpoint;
char **completions, *point, *arg_prefix;
@@ -836,7 +835,7 @@ disassemble_command (char *arg, int from
{
CORE_ADDR low, high;
char *name;
- CORE_ADDR pc, pc_masked;
+ CORE_ADDR pc;
char *space_index;
#if 0
asection *section;

View file

@ -1,10 +0,0 @@
$NetBSD: patch-config_xm_nbsd_h,v 1.1 2004/05/10 22:11:50 johnrshannon Exp $
--- gdb/config/xm-nbsd.h.orig 2001-12-01 19:57:13.000000000 -0700
+++ gdb/config/xm-nbsd.h
@@ -24,3 +24,5 @@
/* NetBSD has termios facilities. */
#define HAVE_TERMIOS
+
+#define PT_IO 1

View file

@ -1,13 +0,0 @@
$NetBSD: patch-configure,v 1.1 2004/06/01 15:48:57 johnrshannon Exp $
--- configure.orig 2004-06-01 08:25:47.000000000 -0600
+++ configure
@@ -920,7 +920,7 @@ target_configdirs=`echo ${target_librari
# This should be done more generally, but at the moment it doesn't matter.
if test ${host_alias} != ${build_alias} ; then
# This is the only build module.
- build_modules=libiberty
+ build_modules=
else
build_modules=
fi

View file

@ -1,20 +0,0 @@
$NetBSD: patch-corelow_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/corelow.c.orig 2004-02-28 11:04:36.000000000 -0700
+++ gdb/corelow.c
@@ -493,7 +493,6 @@ get_core_register_section (char *name,
static void
get_core_registers (int regno)
{
- int status;
if (!(core_gdbarch && gdbarch_regset_from_core_section_p (core_gdbarch))
&& (core_vec == NULL || core_vec->core_read_registers == NULL))
@@ -540,7 +539,6 @@ core_xfer_partial (struct target_ops *op
struct bfd_section *section;
bfd_size_type size;
- char *contents;
section = bfd_get_section_by_name (core_bfd, ".auxv");
if (section == NULL)

View file

@ -1,27 +0,0 @@
$NetBSD: patch-gdb_configure_in,v 1.1 2004/05/28 11:28:58 johnrshannon Exp $
--- gdb/configure.in.orig 2004-02-25 17:41:46.000000000 -0700
+++ gdb/configure.in
@@ -941,6 +941,22 @@ if test ${build} = ${host} -a ${host} =
CONFIG_LDFLAGS="${CONFIG_LDFLAGS} -lpthdebug"
fi
;;
+ netbsd*)
+ AC_MSG_CHECKING(for NetBSD thread debugging library)
+ AC_CACHE_VAL(gdb_cv_have_netbsd_thread_debug,
+ [AC_TRY_COMPILE([#include <pthread_dbg.h>],
+ [#ifndef TD_STATE_RUNNING
+ #error
+ #endif],
+ gdb_cv_have_netbsd_thread_debug=yes,
+ gdb_cv_have_netbsd_thread_debug=no)])
+ AC_MSG_RESULT($gdb_cv_have_netbsd_thread_debug)
+ if test $gdb_cv_have_netbsd_thread_debug = yes; then
+ CONFIG_SRCS="${CONFIG_SRCS} nbsd-thread.c"
+ CONFIG_OBS="${CONFIG_OBS} nbsd-thread.o"
+ CONFIG_LDFLAGS="${CONFIG_LDFLAGS} -lpthread_dbg"
+ fi
+ ;;
esac
AC_SUBST(CONFIG_LDFLAGS)
fi

View file

@ -1,10 +0,0 @@
$NetBSD: patch-i386_nbsdelf_mh,v 1.3 2004/05/10 22:13:45 johnrshannon Exp $
--- gdb/config/i386/nbsdelf.mh.orig 2004-02-22 09:20:22.000000000 -0700
+++ gdb/config/i386/nbsdelf.mh
@@ -1,4 +1,4 @@
# Host: NetBSD/i386 ELF
-NATDEPFILES= fork-child.o infptrace.o inftarg.o i386bsd-nat.o
+NATDEPFILES= fork-child.o nbsd-nat.o infptrace.o inftarg.o i386bsd-nat.o
NAT_FILE= nm-nbsd.h
XM_FILE= xm-nbsd.h

View file

@ -1,18 +0,0 @@
$NetBSD: patch-i386_nm_nbsd_h,v 1.2 2004/05/10 22:11:50 johnrshannon Exp $
--- gdb/config/i386/nm-nbsd.h.orig 2004-02-22 09:20:22.000000000 -0700
+++ gdb/config/i386/nm-nbsd.h
@@ -23,7 +23,13 @@
#ifndef NM_NBSD_H
#define NM_NBSD_H
+#include <sys/param.h>
+
/* Get generic NetBSD native definitions. */
#include "config/nm-nbsd.h"
+#include <sys/lock.h>
+#include <machine/vmparam.h>
+#define KERNEL_U_ADDR USRSTACK
+
#endif /* nm-nbsd.h */

View file

@ -1,18 +0,0 @@
$NetBSD: patch-i386bsd_nat_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/i386bsd-nat.c.orig 2003-09-28 07:35:44.000000000 -0600
+++ gdb/i386bsd-nat.c
@@ -109,11 +109,13 @@ static int have_ptrace_xmmregs = -1;
/* Return nonzero if we shouldn't try to fetch register REGNO. */
+#if !defined (CANNOT_FETCH_REGISTER)
static int
cannot_fetch_register (int regno)
{
return (reg_offset[regno] == -1);
}
+#endif
/* Transfering the registers between GDB, inferiors and core files. */

View file

@ -1,12 +0,0 @@
$NetBSD: patch-i386nbsd_tdep_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/i386nbsd-tdep.c.orig 2004-02-22 09:20:22.000000000 -0700
+++ gdb/i386nbsd-tdep.c
@@ -137,7 +137,6 @@ i386nbsd_sigtramp_offset (CORE_ADDR pc)
{
unsigned char ret[sizeof(sigtramp_retcode)], insn;
LONGEST off;
- int i;
if (read_memory_nobpt (pc, &insn, 1) != 0)
return -1;

View file

@ -1,12 +0,0 @@
$NetBSD: patch-i387_tdep_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/i387-tdep.c.orig 2004-02-28 13:43:51.000000000 -0700
+++ gdb/i387-tdep.c
@@ -206,7 +206,6 @@ i387_print_float_info (struct gdbarch *g
struct frame_info *frame, const char *args)
{
struct gdbarch_tdep *tdep = gdbarch_tdep (get_frame_arch (frame));
- char buf[4];
ULONGEST fctrl;
ULONGEST fstat;
ULONGEST ftag;

View file

@ -1,16 +0,0 @@
$NetBSD: patch-inftarg_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/inftarg.c.orig 2004-02-04 14:49:55.000000000 -0700
+++ gdb/inftarg.c
@@ -106,11 +106,7 @@ child_wait (ptid_t ptid, struct target_w
{
int save_errno;
int status;
- char *execd_pathname = NULL;
int exit_status;
- int related_pid;
- int syscall_id;
- enum target_waitkind kind;
int pid;
do

View file

@ -1,22 +0,0 @@
$NetBSD: patch-mi_mi_cmd_break_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-cmd-break.c.orig 2002-03-18 19:51:08.000000000 -0700
+++ gdb/mi/mi-cmd-break.c
@@ -90,7 +90,7 @@ mi_cmd_break_insert (char *command, char
{"c", CONDITION_OPT, 1},
{"i", IGNORE_COUNT_OPT, 1},
{"p", THREAD_OPT, 1},
- 0
+ {0}
};
/* Parse arguments. It could be -r or -h or -t, <location> or ``--''
@@ -194,7 +194,7 @@ mi_cmd_break_watch (char *command, char
{
{"r", READ_OPT, 0},
{"a", ACCESS_OPT, 0},
- 0
+ {0}
};
/* Parse arguments. */

View file

@ -1,21 +0,0 @@
$NetBSD: patch-mi_mi_cmd_disas_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-cmd-disas.c.orig 2002-09-30 09:57:26.000000000 -0600
+++ gdb/mi/mi-cmd-disas.c
@@ -51,7 +51,6 @@
enum mi_cmd_result
mi_cmd_disassemble (char *command, char **argv, int argc)
{
- enum mi_cmd_result retval;
CORE_ADDR start;
int mixed_source_and_assembly;
@@ -84,7 +83,7 @@ mi_cmd_disassemble (char *command, char
{"n", NUM_OPT, 1},
{"s", START_OPT, 1},
{"e", END_OPT, 1},
- 0
+ {0}
};
/* Get the options with their arguments. Keep track of what we

View file

@ -1,22 +0,0 @@
$NetBSD: patch-mi_mi_cmd_env_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-cmd-env.c.orig 2004-01-18 18:20:12.000000000 -0700
+++ gdb/mi/mi-cmd-env.c
@@ -126,7 +126,7 @@ mi_cmd_env_path (char *command, char **a
static struct mi_opt opts[] =
{
{"r", RESET_OPT, 0},
- 0
+ {0}
};
dont_repeat ();
@@ -198,7 +198,7 @@ mi_cmd_env_dir (char *command, char **ar
static struct mi_opt opts[] =
{
{"r", RESET_OPT, 0},
- 0
+ {0}
};
dont_repeat ();

View file

@ -1,13 +0,0 @@
$NetBSD: patch-mi_mi_cmd_file_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-cmd-file.c.orig 2003-04-02 15:10:35.000000000 -0700
+++ gdb/mi/mi-cmd-file.c
@@ -33,8 +33,6 @@ enum mi_cmd_result
mi_cmd_file_list_exec_source_file(char *command, char **argv, int argc)
{
struct symtab_and_line st;
- int optind = 0;
- char *optarg;
if ( !mi_valid_noargs("mi_cmd_file_list_exec_source_file", argc, argv) )
error ("mi_cmd_file_list_exec_source_file: Usage: No args");

View file

@ -1,12 +0,0 @@
$NetBSD: patch-mi_mi_cmd_stack_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-cmd-stack.c.orig 2004-01-23 21:21:55.000000000 -0700
+++ gdb/mi/mi-cmd-stack.c
@@ -232,7 +232,6 @@ list_args_or_locals (int locals, int val
struct block *block;
struct symbol *sym;
struct dict_iterator iter;
- int nsyms;
struct cleanup *cleanup_list;
static struct ui_stream *stb = NULL;
struct type *type;

View file

@ -1,13 +0,0 @@
$NetBSD: patch-mi_mi_getopt_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-getopt.c.orig 2003-04-02 15:10:35.000000000 -0700
+++ gdb/mi/mi-getopt.c
@@ -82,7 +82,7 @@ mi_valid_noargs (const char *prefix, int
char *optarg;
static struct mi_opt opts[] =
{
- 0
+ {0}
};
if (mi_getopt (prefix, argc, argv, opts, &optind, &optarg) == -1)

View file

@ -1,12 +0,0 @@
$NetBSD: patch-mi_mi_interp_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-interp.c.orig 2004-01-18 18:20:12.000000000 -0700
+++ gdb/mi/mi-interp.c
@@ -190,7 +190,6 @@ mi_cmd_interpreter_exec (char *command,
struct interp *interp_to_use;
enum mi_cmd_result result = MI_CMD_DONE;
int i;
- struct interp_procs *procs;
if (argc < 2)
{

View file

@ -1,38 +0,0 @@
$NetBSD: patch-mi_mi_main_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-main.c.orig 2004-02-15 08:22:06.000000000 -0700
+++ gdb/mi/mi-main.c
@@ -817,7 +817,7 @@ mi_cmd_data_read_memory (char *command,
static struct mi_opt opts[] =
{
{"o", OFFSET_OPT, 1},
- 0
+ {0}
};
while (1)
@@ -1027,7 +1027,7 @@ mi_cmd_data_write_memory (char *command,
static struct mi_opt opts[] =
{
{"o", OFFSET_OPT, 1},
- 0
+ {0}
};
while (1)
@@ -1192,7 +1192,6 @@ mi_execute_command (char *cmd, int from_
{
struct mi_parse *command;
struct captured_mi_execute_command_args args;
- struct ui_out *saved_uiout = uiout;
int result;
/* This is to handle EOF (^D). We just quit gdb. */
@@ -1220,7 +1219,6 @@ mi_execute_command (char *cmd, int from_
if (args.action == EXECUTE_COMMAND_DISPLAY_ERROR || result < 0)
{
char *msg = error_last_message ();
- struct cleanup *cleanup = make_cleanup (xfree, msg);
/* The command execution failed and error() was called
somewhere */
fputs_unfiltered (command->token, raw_stdout);

View file

@ -1,12 +0,0 @@
$NetBSD: patch-mi_mi_out_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/mi/mi-out.c.orig 2004-01-18 18:20:12.000000000 -0700
+++ gdb/mi/mi-out.c
@@ -106,7 +106,6 @@ mi_table_begin (struct ui_out *uiout,
int nr_rows,
const char *tblid)
{
- mi_out_data *data = ui_out_data (uiout);
mi_open (uiout, tblid, ui_out_type_tuple);
mi_field_int (uiout, -1/*fldno*/, -1/*width*/, -1/*alin*/,
"nr_rows", nr_rows);

View file

@ -1,22 +0,0 @@
$NetBSD: patch-nm_nbsd_h,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/config/nm-nbsd.h.orig 2002-05-21 21:59:53.000000000 -0600
+++ gdb/config/nm-nbsd.h
@@ -18,10 +18,16 @@
Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
-#define PTRACE_ARG3_TYPE char*
+#define PTRACE_ARG3_TYPE caddr_t
#define FETCH_INFERIOR_REGISTERS
#define ATTACH_DETACH
#include "solib.h" /* Support for shared libraries. */
+
+#include <signal.h>
+#ifdef SIGRTMIN
+#define REALTIME_LO SIGRTMIN
+#define REALTIME_HI SIGRTMAX
+#endif

View file

@ -1,14 +0,0 @@
$NetBSD: patch-readline_rltty_c,v 1.1 2004/06/01 15:48:58 johnrshannon Exp $
--- readline/rltty.c.orig 2004-06-01 09:01:39.000000000 -0600
+++ readline/rltty.c
@@ -619,6 +619,9 @@ prepare_terminal_settings (meta_flag, ol
just to be sure. This includes ^Y and ^V. This should not really
be necessary. */
#if defined (TERMIOS_TTY_DRIVER) && defined (_POSIX_VDISABLE)
+#if defined (VDISCARD)
+ tiop->c_cc[VDISCARD] = _POSIX_VDISABLE;
+#endif
#if defined (VLNEXT)
tiop->c_cc[VLNEXT] = _POSIX_VDISABLE;

View file

@ -1,91 +0,0 @@
$NetBSD: patch-remote_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/remote.c.orig 2004-02-25 13:41:00.000000000 -0700
+++ gdb/remote.c
@@ -645,8 +645,6 @@ add_packet_config_cmd (struct packet_con
struct cmd_list_element **show_remote_list,
int legacy)
{
- struct cmd_list_element *set_cmd;
- struct cmd_list_element *show_cmd;
char *set_doc;
char *show_doc;
char *cmd_name;
@@ -2324,8 +2322,6 @@ remote_detach (char *args, int from_tty)
static void
remote_disconnect (char *args, int from_tty)
{
- struct remote_state *rs = get_remote_state ();
- char *buf = alloca (rs->remote_packet_size);
if (args)
error ("Argument given to \"detach\" when remotely debugging.");
@@ -2718,11 +2714,18 @@ async_remote_interrupt_twice (gdb_client
static void
cleanup_sigint_signal_handler (void *dummy)
{
+ struct async_signal_handler *tmp;
signal (SIGINT, handle_sigint);
if (sigint_remote_twice_token)
- delete_async_signal_handler ((struct async_signal_handler **) & sigint_remote_twice_token);
+ {
+ tmp = (struct async_signal_handler *) sigint_remote_twice_token;
+ delete_async_signal_handler (&tmp);
+ }
if (sigint_remote_token)
- delete_async_signal_handler ((struct async_signal_handler **) & sigint_remote_token);
+ {
+ tmp = (struct async_signal_handler *) sigint_remote_token;
+ delete_async_signal_handler (&tmp);
+ }
}
/* Send ^C to target to halt it. Target will respond, and send us a
@@ -2895,7 +2898,6 @@ remote_wait (ptid_t ptid, struct target_
continue;
case 'T': /* Status with PC, SP, FP, ... */
{
- int i;
char regs[MAX_REGISTER_SIZE];
/* Expedited reply, containing Signal, {regno, reg} repeat */
@@ -3084,7 +3086,6 @@ remote_async_wait (ptid_t ptid, struct t
continue;
case 'T': /* Status with PC, SP, FP, ... */
{
- int i;
char regs[MAX_REGISTER_SIZE];
/* Expedited reply, containing Signal, {regno, reg} repeat */
@@ -3385,7 +3386,6 @@ store_register_using_P (int regnum)
char *buf = alloca (rs->remote_packet_size);
char regp[MAX_REGISTER_SIZE];
char *p;
- int i;
sprintf (buf, "P%s=", phex_nz (reg->pnum, 0));
p = buf + strlen (buf);
@@ -3406,7 +3406,6 @@ remote_store_registers (int regnum)
struct remote_state *rs = get_remote_state ();
char *buf;
char *regs;
- int i;
char *p;
set_thread (PIDGET (inferior_ptid), 1);
@@ -4978,7 +4977,6 @@ remote_rcmd (char *command,
struct ui_file *outbuf)
{
struct remote_state *rs = get_remote_state ();
- int i;
char *buf = alloca (rs->remote_packet_size);
char *p = buf;
@@ -5453,7 +5451,6 @@ _initialize_remote (void)
{
static struct cmd_list_element *remote_set_cmdlist;
static struct cmd_list_element *remote_show_cmdlist;
- struct cmd_list_element *tmpcmd;
/* architecture specific data */
remote_gdbarch_data_handle = register_gdbarch_data (init_remote_state);

View file

@ -1,37 +0,0 @@
$NetBSD: patch-remote_fileio_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/remote-fileio.c.orig 2004-01-27 16:19:51.000000000 -0700
+++ gdb/remote-fileio.c
@@ -1279,19 +1279,19 @@ static struct {
char *name;
void (*func)(char *);
} remote_fio_func_map[] = {
- "open", remote_fileio_func_open,
- "close", remote_fileio_func_close,
- "read", remote_fileio_func_read,
- "write", remote_fileio_func_write,
- "lseek", remote_fileio_func_lseek,
- "rename", remote_fileio_func_rename,
- "unlink", remote_fileio_func_unlink,
- "stat", remote_fileio_func_stat,
- "fstat", remote_fileio_func_fstat,
- "gettimeofday", remote_fileio_func_gettimeofday,
- "isatty", remote_fileio_func_isatty,
- "system", remote_fileio_func_system,
- NULL, NULL
+ {"open", remote_fileio_func_open},
+ {"close", remote_fileio_func_close},
+ {"read", remote_fileio_func_read},
+ {"write", remote_fileio_func_write},
+ {"lseek", remote_fileio_func_lseek},
+ {"rename", remote_fileio_func_rename},
+ {"unlink", remote_fileio_func_unlink},
+ {"stat", remote_fileio_func_stat},
+ {"fstat", remote_fileio_func_fstat},
+ {"gettimeofday", remote_fileio_func_gettimeofday},
+ {"isatty", remote_fileio_func_isatty},
+ {"system", remote_fileio_func_system},
+ {NULL, NULL}
};
static int

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ser_pipe_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/ser-pipe.c.orig 2004-01-22 15:20:39.000000000 -0700
+++ gdb/ser-pipe.c
@@ -132,8 +132,6 @@ pipe_close (struct serial *scb)
}
}
-static struct serial_ops pipe_ops;
-
void
_initialize_ser_pipe (void)
{

View file

@ -1,12 +0,0 @@
$NetBSD: patch-tui_interp_c,v 1.1 2004/05/07 08:50:19 johnrshannon Exp $
--- gdb/tui/tui-interp.c.orig 2004-02-06 21:40:36.000000000 -0700
+++ gdb/tui/tui-interp.c
@@ -194,7 +194,6 @@ _initialize_tui_interp (void)
tui_display_prompt_p,
tui_command_loop,
};
- struct interp *tui_interp;
/* Create a default uiout builder for the TUI. */
tui_out = tui_out_new (gdb_stdout);