Initial import of mod_python 3.0.3.

mod_python is an Apache module that embeds the Python interpreter
within the server. With mod_python you can write web-based applications
in Python that will run many times faster than traditional CGI and
will have access to advanced features such as ability to retain
database connections and other data between hits and access to
Apache internals.
This commit is contained in:
Marc Recht 2003-08-07 12:29:07 +00:00
parent d4083268e4
commit 5bae9c639d
5 changed files with 64 additions and 0 deletions

6
ap2-python/DESCR Normal file
View file

@ -0,0 +1,6 @@
mod_python is an Apache module that embeds the Python interpreter
within the server. With mod_python you can write web-based applications
in Python that will run many times faster than traditional CGI and
will have access to advanced features such as ability to retain
database connections and other data between hits and access to
Apache internals.

25
ap2-python/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/08/07 12:29:07 marc Exp $
#
DISTNAME= mod_python-3.0.3
CATEGORIES= www python
MASTER_SITES= http://www.apache.org/dist/httpd/modpython/
EXTRACT_SUFX= .tgz
MAINTAINER= marc@informatik.uni-bremen.de
HOMEPAGE= http://www.modpython.org/
COMMENT= Module that embeds the Python interpreter within the server
USE_BUILDLINK2= yes
PY_PATCHPLIST= yes
APACHE_MODULE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
CONFIGURE_ARGS+= --with-python=${PYTHONBIN}
PYTHON_VERSIONS_ACCEPTED= 23pth
.include "../../lang/python/extension.mk"
.include "../../www/apache2/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

13
ap2-python/PLIST Normal file
View file

@ -0,0 +1,13 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/08/07 12:29:07 marc Exp $
lib/httpd/mod_python.so
${PYSITELIB}/mod_python/__init__.pyc
${PYSITELIB}/mod_python/__init__.pyo
${PYSITELIB}/mod_python/apache.pyc
${PYSITELIB}/mod_python/apache.pyo
${PYSITELIB}/mod_python/cgihandler.pyc
${PYSITELIB}/mod_python/cgihandler.pyo
${PYSITELIB}/mod_python/publisher.pyc
${PYSITELIB}/mod_python/publisher.pyo
${PYSITELIB}/mod_python/util.pyc
${PYSITELIB}/mod_python/util.pyo
@dirrm ${PYSITELIB}/mod_python

5
ap2-python/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/08/07 12:29:07 marc Exp $
SHA1 (mod_python-3.0.3.tgz) = 7f108c8bb9f5d399709af1c03699b1ecc66bc419
Size (mod_python-3.0.3.tgz) = 219378 bytes
SHA1 (patch-aa) = 8b4a3f5d406bc13630f9cdef21cac800fc405bf5

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/08/07 12:29:07 marc Exp $
--- src/requestobject.c.orig 2003-07-31 16:14:23.000000000 +0200
+++ src/requestobject.c 2003-07-31 16:14:45.000000000 +0200
@@ -1052,8 +1052,8 @@
{
PyMemberDef *md = find_memberdef(request_rec_mbrs, name);
char *addr = (char *)self->request_rec + md->offset;
- if (sizeof(apr_off_t) == sizeof(LONG_LONG)) {
- LONG_LONG l = *(LONG_LONG*)addr;
+ if (sizeof(apr_off_t) == sizeof(PY_LONG_LONG)) {
+ PY_LONG_LONG l = *(PY_LONG_LONG*)addr;
return PyLong_FromLongLong(l);
}
else {