Added some patches for NetBSD and some primitive gmake-Makefile
This commit is contained in:
parent
1e05dd5e65
commit
5bf91062fa
7 changed files with 143 additions and 8 deletions
|
@ -1,7 +1,3 @@
|
|||
This is the farsight version of Google's libjingle as distributed by
|
||||
Freedesktop.org. It's required by gst-plugins-farsight.
|
||||
|
||||
Google's Libjingle (http://code.google.com/apis/talk/index.html) is Google
|
||||
Talk's implementation of Jingle and Jingle-Audio (proposed extensions to
|
||||
XMPP) to interoperate with Google Talk's peer-to-peer and voice calling
|
||||
capabilities.
|
||||
Google's Libjingle is Google Talk's implementation of Jingle and Jingle-Audio
|
||||
(proposed extensions to XMPP) to interoperate with Google Talk's peer-to-peer
|
||||
and voice calling capabilities.
|
||||
|
|
|
@ -1,6 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.5 2011/12/28 01:25:34 mwilhelmy Exp $
|
||||
$NetBSD: distinfo,v 1.6 2011/12/29 18:21:14 mwilhelmy Exp $
|
||||
|
||||
SHA1 (libjingle-0.6.6.zip) = d62c0d456662245020127453f4e218cd8e09b279
|
||||
RMD160 (libjingle-0.6.6.zip) = 8ba62866b0aa065470f5d5efe8aabf68180c29c1
|
||||
Size (libjingle-0.6.6.zip) = 8243577 bytes
|
||||
SHA1 (patch-ae) = a7e01c562aab794bddf7fc3237c304c29c02abd2
|
||||
SHA1 (patch-af) = cf794f13ee217d7f53c716e04074545739698020
|
||||
SHA1 (patch-ag) = 9a0a1b86b6caa2927ab8541621ca049c303642f6
|
||||
SHA1 (patch-ah) = 88f838513cb0de976358168828d308387b5c7d2e
|
||||
SHA1 (patch-ai) = 2d74b1fcd80552191f4b6137d9e93df3154b4b31
|
||||
|
|
27
libjingle/files/Makefile
Normal file
27
libjingle/files/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
CPPFLAGS= -I../.. -I.. \
|
||||
-DHAMMER_TIME=1 \
|
||||
-DLOGGING=1 \
|
||||
-DFEATURE_ENABLE_SSL \
|
||||
-DFEATURE_ENABLE_VOICEMAIL \
|
||||
-DFEATURE_ENABLE_PSTN \
|
||||
-DHAVE_SRTP \
|
||||
-DHASHNAMESPACE=__gnu_cxx \
|
||||
-DHASH_NAMESPACE=__gnu_cxx \
|
||||
-DPOSIX \
|
||||
-DBSD \
|
||||
-DDISABLE_DYNAMIC_CAST \
|
||||
-DHAVE_OPENSSL_SSL_H=1 \
|
||||
-D_REENTRANT
|
||||
CFLAGS= -Wall -Werror -Wno-switch -fno-exceptions -fvisibility=hidden -gdwarf-2
|
||||
CXXFLAGS= -Wno-non-virtual-dtor -Wno-ctor-dtor-privacy -fno-rtti
|
||||
LTCOMP= libtool --mode=compile --silent
|
||||
CXX= ${LTCOMP} c++
|
||||
|
||||
#SRCS= $(wildcard *.cc)
|
||||
SRCS= $(shell find . \( -name "*.cc" -a \! -name "*_unittest.cc" -a \! -name "mac*" -a \! -name "win32*" \))
|
||||
OBJS= $(SRCS:.cc=.o)
|
||||
|
||||
all: $(OBJS)
|
||||
|
||||
.cc.o:
|
||||
-${CXX} ${CPPFLAGS} ${CXXFLAGS} -c $< -o $@
|
58
libjingle/patches/patch-af
Normal file
58
libjingle/patches/patch-af
Normal file
|
@ -0,0 +1,58 @@
|
|||
$NetBSD: patch-af,v 1.1 2011/12/29 18:21:14 mwilhelmy Exp $
|
||||
|
||||
--- latebindingsymboltable.cc.orig 2011-12-29 16:56:17.000000000 +0100
|
||||
+++ latebindingsymboltable.cc 2011-12-29 16:57:00.000000000 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
#include "talk/base/latebindingsymboltable.h"
|
||||
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
#include <dlfcn.h>
|
||||
#endif
|
||||
|
||||
@@ -36,7 +36,7 @@
|
||||
namespace talk_base {
|
||||
|
||||
inline static const char *GetDllError() {
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
char *err = dlerror();
|
||||
if (err) {
|
||||
return err;
|
||||
@@ -49,7 +49,7 @@
|
||||
}
|
||||
|
||||
DllHandle InternalLoadDll(const char dll_name[]) {
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
DllHandle handle = dlopen(dll_name, RTLD_NOW);
|
||||
#else
|
||||
#error Not implemented
|
||||
@@ -61,7 +61,7 @@
|
||||
}
|
||||
|
||||
void InternalUnloadDll(DllHandle handle) {
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
if (dlclose(handle) != 0) {
|
||||
LOG(LS_ERROR) << GetDllError();
|
||||
}
|
||||
@@ -73,7 +73,7 @@
|
||||
static bool LoadSymbol(DllHandle handle,
|
||||
const char *symbol_name,
|
||||
void **symbol) {
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
*symbol = dlsym(handle, symbol_name);
|
||||
char *err = dlerror();
|
||||
if (err) {
|
||||
@@ -96,7 +96,7 @@
|
||||
int num_symbols,
|
||||
const char *const symbol_names[],
|
||||
void *symbols[]) {
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
// Clear any old errors.
|
||||
dlerror();
|
||||
#endif
|
13
libjingle/patches/patch-ag
Normal file
13
libjingle/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1 2011/12/29 18:21:14 mwilhelmy Exp $
|
||||
|
||||
--- latebindingsymboltable.h.orig 2011-12-29 16:58:00.000000000 +0100
|
||||
+++ latebindingsymboltable.h 2011-12-29 16:58:42.000000000 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
namespace talk_base {
|
||||
|
||||
-#ifdef LINUX
|
||||
+#if defined(LINUX) || defined(__NetBSD__)
|
||||
typedef void *DllHandle;
|
||||
|
||||
const DllHandle kInvalidDllHandle = NULL;
|
22
libjingle/patches/patch-ah
Normal file
22
libjingle/patches/patch-ah
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ah,v 1.1 2011/12/29 18:21:14 mwilhelmy Exp $
|
||||
|
||||
--- nethelpers.cc.orig 2011-12-14 16:58:28.000000000 +0100
|
||||
+++ nethelpers.cc 2011-12-29 17:07:38.000000000 +0100
|
||||
@@ -57,7 +57,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
-#if defined(WIN32) || defined(ANDROID) || defined(OPENBSD)
|
||||
+#if defined(WIN32) || defined(ANDROID) || defined(OPENBSD) || defined(__NetBSD__)
|
||||
static hostent* DeepCopyHostent(const hostent* ent) {
|
||||
// Get the total number of bytes we need to copy, and allocate our buffer.
|
||||
int num_aliases = 0, num_addrs = 0;
|
||||
@@ -168,7 +168,7 @@
|
||||
#elif defined(OSX) || defined(IOS) || defined(FREEBSD)
|
||||
// Mac OS returns an object with everything allocated.
|
||||
result = getipnodebyname(hostname, AF_INET, AI_DEFAULT, herrno);
|
||||
-#elif defined(OPENBSD)
|
||||
+#elif defined(OPENBSD) || defined(__NetBSD__)
|
||||
hostent* ent = gethostbyname(hostname);
|
||||
if (!ent) {
|
||||
return NULL;
|
15
libjingle/patches/patch-ai
Normal file
15
libjingle/patches/patch-ai
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ai,v 1.1 2011/12/29 18:21:14 mwilhelmy Exp $
|
||||
|
||||
--- timing.cc.orig 2011-12-14 16:58:28.000000000 +0100
|
||||
+++ timing.cc 2011-12-29 17:25:34.000000000 +0100
|
||||
@@ -27,7 +27,9 @@
|
||||
|
||||
#include "talk/base/timing.h"
|
||||
|
||||
-#if defined(POSIX)
|
||||
+#if defined(__NetBSD__)
|
||||
+#define _POSIX_C_SOURCE 200112L
|
||||
+#elif defined(POSIX)
|
||||
#define _POSIX_C_SOURCE 199506L
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue