guile-gtk-devel moved to pkgsrc/devel/guile-gtk.

This commit is contained in:
Thomas Klausner 2004-12-03 15:36:46 +00:00
parent 9bd25d64c1
commit 5cebb69126
7 changed files with 2 additions and 118 deletions

View file

@ -1,5 +1,5 @@
# $Id: Makefile,v 1.1564 2004/12/03 13:42:32 thomasklausner Exp $
# $NetBSD: Makefile,v 1.1564 2004/12/03 13:42:32 thomasklausner Exp $
# $Id: Makefile,v 1.1565 2004/12/03 15:36:46 thomasklausner Exp $
# $NetBSD: Makefile,v 1.1565 2004/12/03 15:36:46 thomasklausner Exp $
COMMENT= WIP pkgsrc packages
@ -277,7 +277,6 @@ SUBDIR+= gtkglk
SUBDIR+= gtklookat
SUBDIR+= gtkpod
SUBDIR+= guile-gnome
SUBDIR+= guile-gtk-devel
SUBDIR+= guile-lib
SUBDIR+= guile-scsh
SUBDIR+= guile16-slib

View file

@ -1,10 +0,0 @@
Guile-gtk is a library written to make GTK 1.2 accessible from
guile. It provides a convenient interface for Scheme programmers to
develop visual applications. It can also integrate with GNOME via the
Gnome-guile module. (For glib2, see guile-gobject instead.)
Guile-gtk was started by Marius Vollmer <mvo@zagadka.ping.de> and
is currently maintained by Ariel Rios <jarios@usa.net> and other
intrepid Guile hackers around the world.
Guile-gtk is free software licensed under the GPL.

View file

@ -1,28 +0,0 @@
# $NetBSD: Makefile,v 1.5 2004/11/17 00:13:19 lexort Exp $
#
DISTNAME= guile-gtk-0.40.91
CATEGORIES= devel x11
MASTER_SITES= http://www.ir.bbn.com/~gdt/pkgsrc-wip/
MAINTAINER= gdt@ir.bbn.com
HOMEPAGE= http://www.gnu.org/software/guile-gtk/
COMMENT= Library to make GTK 1.2 accessible from guile
USE_BUILDLINK3= # defined
USE_X11= # defined
USE_LIBTOOL= # defined
GNU_CONFIGURE= # defined
MAKE_ENV+= MACHINE_ARCH=${MACHINE_ARCH}
.include "../../lang/guile/buildlink3.mk"
# Skip glade, because it pulls in gnome-libs.
# Later, make a new package for just the glade parts,
# or a BUILD_DEF.
# .include "../../devel/libglade/buildlink3.mk"
# glade-config may be in ${LOCALBASE}/bin, so force not using it.
CONFIGURE_ARGS+= --without-glade
.include "../../x11/gtk/buildlink3.mk"
.include "../../graphics/gdk-pixbuf/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,26 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2004/09/23 05:59:42 jlamwww Exp $
bin/build-guile-gtk
bin/build-guile-gtk-1.2
include/guile-gtk.h
info/guile-gtk.info
lib/libguilegdkpixbuf-1.2.la
lib/libguilegtk-1.2.la
share/guile-gtk/gdk-1.2.defs
share/guile-gtk/gdk-pixbuf.defs
share/guile-gtk/gtk-1.2.defs
share/guile/gtk-1.2/config.scm
share/guile/gtk-1.2/dynlink.scm
share/guile/gtk-1.2/gdk-pixbuf.scm
share/guile/gtk-1.2/gdk.scm
share/guile/gtk-1.2/gtk.scm
share/guile/gtk-1.2/repl.scm
share/guile/gtk-1.2/threads.scm
share/guile/gtk/config.scm
share/guile/gtk/dynlink.scm
share/guile/gtk/gdk.scm
share/guile/gtk/gtk.scm
share/guile/gtk/repl.scm
share/guile/gtk/threads.scm
@dirrm share/guile/gtk-1.2
@dirrm share/guile/gtk
@dirrm share/guile-gtk

View file

@ -1,21 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2004/06/16 12:37:59 lexort Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
GUILE_GTK_DEVEL_BUILDLINK3_MK:= ${GUILE_GTK_DEVEL_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= guile-gtk-devel
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nguile-gtk}
BUILDLINK_PACKAGES+= guile-gtk-devel
.if !empty(GUILE_GTK_DEVEL_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.guile-gtk+= guile-gtk-devel>=0.40
BUILDLINK_PKGSRCDIR.guile-gtk?= ../../wip/guile-gtk-devel
.endif # GUILE_GTK_DEVEL_BUILDLINK3_MK
.include "../../lang/guile/buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,5 +0,0 @@
$NetBSD: distinfo,v 1.2 2004/11/17 00:13:20 lexort Exp $
SHA1 (guile-gtk-0.40.91.tar.gz) = 9044067d0ff4e745167c38325cd41dbc47e9c483
Size (guile-gtk-0.40.91.tar.gz) = 708183 bytes
SHA1 (patch-aa) = f3f6e47727ea7429c671fe02d2a93e8e962e920b

View file

@ -1,25 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/06/16 12:37:59 lexort Exp $
--- Makefile.in.orig Wed Jul 26 19:24:58 2000
+++ Makefile.in
@@ -641,3 +641,20 @@ dist-hook:
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
+
+# problems with optimization. triggers internal compiler errors
+
+COMPILE_NOOPT=${COMPILE:C/-O[0-9]*//g}
+LTCOMPILE_NOOPT=${LTCOMPILE:C/-O[0-9]*//g}
+
+.if (${MACHINE_ARCH} == "alpha")
+
+gdk-glue.o: gdk-glue.c
+ $(COMPILE_NOOPT) -c gdk-glue.c
+
+gdk-glue.lo: gdk-glue.c
+ @echo "Compiling without optimization to work around gcc -O* compiler bug"
+ $(LTCOMPILE_NOOPT) -c gdk-glue.c
+
+.endif
+