Set LICENSE and split out Makefile.common, add a patch for python module.
This commit is contained in:
parent
8ca08cc20e
commit
626d6a8eac
4 changed files with 46 additions and 7 deletions
|
@ -1,12 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/01/23 07:40:58 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2010/01/13 10:49:51 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cabocha-0.53
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.chasen.org/~taku/software/cabocha/src/
|
||||
.include "Makefile.common"
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://www.chasen.org/~taku/software/cabocha/
|
||||
COMMENT= Yet another Japanese Dependency Structure Analyzer
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
|
15
cabocha/Makefile.common
Normal file
15
cabocha/Makefile.common
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2010/01/13 10:49:51 obache Exp $
|
||||
# used by wip/p5-cabocha/Makefile
|
||||
# used by wip/py-cabocha/Makefile
|
||||
# used by wip/ruby-cabocha/Makefile
|
||||
|
||||
DISTNAME= cabocha-0.53
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.chasen.org/~taku/software/cabocha/src/
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../wip/cabocha/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../wip/cabocha/patches
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://www.chasen.org/~taku/software/cabocha/
|
||||
LICENSE= gnu-lgpl-v2.1
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/01/23 07:40:58 obache Exp $
|
||||
$NetBSD: distinfo,v 1.2 2010/01/13 10:49:51 obache Exp $
|
||||
|
||||
SHA1 (cabocha-0.53.tar.gz) = 6b8903aa6843887bb669d9d5baea8a0eae320d80
|
||||
RMD160 (cabocha-0.53.tar.gz) = 39b637adc8b882542ecc3b6df34d8f6b99be3e38
|
||||
Size (cabocha-0.53.tar.gz) = 11552551 bytes
|
||||
SHA1 (patch-aa) = cb868fa8b88180ed5f84d55796d042e5774862af
|
||||
|
|
27
cabocha/patches/patch-aa
Normal file
27
cabocha/patches/patch-aa
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/01/13 10:49:51 obache Exp $
|
||||
|
||||
--- python/CaboCha_wrap.cxx.orig 2005-07-21 13:31:23.000000000 +0000
|
||||
+++ python/CaboCha_wrap.cxx
|
||||
@@ -1206,7 +1206,7 @@ type_error:
|
||||
obj = pyobj;
|
||||
if (PyCFunction_Check(obj)) {
|
||||
/* here we get the method pointer for callbacks */
|
||||
- char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
|
||||
+ const char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
|
||||
c = doc ? strstr(doc, "swig_ptr: ") : 0;
|
||||
if (c) {
|
||||
c = ty ? SWIG_UnpackVoidPtr(c + 10, &vptr, ty->name) : 0;
|
||||
@@ -3260,11 +3260,11 @@ extern "C" {
|
||||
swig_type_info **types_initial) {
|
||||
size_t i;
|
||||
for (i = 0; methods[i].ml_name; ++i) {
|
||||
- char *c = methods[i].ml_doc;
|
||||
+ const char *c = methods[i].ml_doc;
|
||||
if (c && (c = strstr(c, "swig_ptr: "))) {
|
||||
int j;
|
||||
swig_const_info *ci = 0;
|
||||
- char *name = c + 10;
|
||||
+ const char *name = c + 10;
|
||||
for (j = 0; const_table[j].type; ++j) {
|
||||
if (strncmp(const_table[j].name, name,
|
||||
strlen(const_table[j].name)) == 0) {
|
Loading…
Reference in a new issue